LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2006, 03:01 PM   #1
cuk
Member
 
Registered: Jun 2004
Distribution: slackware 10.2.
Posts: 39

Rep: Reputation: 15
Kde shortcuts with more then 2 keys pressed not working


Hello,
I am running slackware 10.2 with kernel 2.6.13 on a thinkpad r40. KDE shortcuts combining more than 2 keys aren't working, neither does any shortcut combination consisting of only shift, ctrl or alt keys. (f.e. layout switcher> alt-shift.) xev interprets these as keypress and keyrelease events, not as keymap notify events. my xorg.conf reads following>
Option "XkbModel" "pc104"
Option "XkbLayout" "us,cz,tr"
Option "XkbVariant" ""
Option "XkbOptions" "grp:alt_shift_toggle"
I understand it is some conflict between kde and x, and did some googling about the topic, but to no avail. i would appreciate any tips for where to start.
Best c.

Last edited by cuk; 01-13-2006 at 03:11 PM.
 
Old 01-14-2006, 08:13 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
try a read of these if you have time
http://www.linuxquestions.org/questi...d.php?t=390368
http://krusader.sourceforge.net//php...pic.php?t=1392

if I understand your question you are looking for a keyboard shortcut to perform a task eg run a executable etc......you could also consider enabling mouse gestures
 
Old 01-14-2006, 09:31 AM   #3
cuk
Member
 
Registered: Jun 2004
Distribution: slackware 10.2.
Posts: 39

Original Poster
Rep: Reputation: 15
not exactly

Thank you for your answer, I had a look at the links. But it is not exactly the problem, I am not trying to add a sequence to start an executable, i am just trying to use the existing shortcuts, mainly the keyboard layout shortcut alt-shift. To clarify the problem>
If i assigned a shortcut (KHotkey) to start f.e. krusader with alt+k, this shortcut would work, but if it was alt+shift+k it wouldn't. Any combination with (shift/ctrl/alt)+(any key) works, any combination with (shift/ctrl/alt) + (shift/control/alt) doesn't. Like the language layout switcher alt+shift. When I try to assign them in the control center/Khotkeys/triggers/new/select shortcut dialog, i press alt, it says alt; i press shift or control, it says ISO_prev_group and closes the configuration window. I hope I explained the problem better this time. I would still be grateful for any tips,
have a good day
c.
 
Old 01-14-2006, 07:10 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
lets troubleshoot sorry if you have already done so ...but this post may help others?

1 go into kde control centre then system then khotkeys and make sure the disable boxes are unchecked for both tabs

2 go into accessibilty then keyboardshortcuts and choose scheme= kde with 3 or 4 moodifier keys and activate and test

3 if still fails maybe it is the manufacturer of your keyboard....the layout itself...so go into accessibility and layout and play around with keyboard layouts after enabling the function

4 Now I think your answer is this....kde cc...accessibilty...Xkboptions....if enabled..you have possible GROUP shift on....
so alt then control...(second from top changes group)...
unselect it and retest your keys

(b) alt and shift (6 down) ditto

5 Otherwise search for each key type and try other layout options?

Last edited by aus9; 01-14-2006 at 07:32 PM.
 
Old 01-15-2006, 08:34 AM   #5
cuk
Member
 
Registered: Jun 2004
Distribution: slackware 10.2.
Posts: 39

Original Poster
Rep: Reputation: 15
In control center>keyboard shortcuts>modifier keys there is a table comparing Kde modifiers with Xmod, and underneath another table which shows X modifier mapping. It looks like X11 thinks my alt is a win key.

--------------------
Kde modifiers X-11 mod
Shift shift
Ctrl control
Alt mod1
Win mod4

---------------------
X 11 modifier mapping
X11 mod Key1 Key2
Shift Shift_L Shift_R
control Control_L Control_R
Mod2 Num_lock
Mod4 -
----------------------
I think this identifies the problem, I have to add mod1 to the X11 modifier mapping. Now I can start looking for a solution. Thanks for your tips and time, have a good day
c.
 
Old 01-16-2006, 03:33 AM   #6
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
try easy way....change your keyboard as a 105 intĺ then 104 etc to see if that works....otherwise you have a envious task of reading man setkeycodes and man loadkeys....there are other references as well here is a brief idea

http://www.linux.com/howtos/Keyboard...-HOWTO-2.shtml

EDIT

just been reading, oops its gets messy but try different keyboards first.

man dumpkeys gives some options....ref /usr/src/linux/drivers/char/defkeymap gives you a reference but

dumpkeys -l (for long) and dumpkeys -n (for number) are your friends.

you may need the hex number when you see the setkeycodes function. now that I am playing with my WINKEY it opens the kde cascading menu....= MS start button

Last edited by aus9; 01-16-2006 at 05:47 AM.
 
Old 01-16-2006, 06:04 AM   #7
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
oops

try kde control...access/....keyboard shortcuts....select scheme ....WINDOWS with win key

Last edited by aus9; 01-16-2006 at 06:12 AM.
 
Old 01-16-2006, 10:58 AM   #8
cuk
Member
 
Registered: Jun 2004
Distribution: slackware 10.2.
Posts: 39

Original Poster
Rep: Reputation: 15
hi,
I'm afraid that it is not in the control center, i tried the different options with shortcuts schemes in all possible variations. My computer is a thinkpad R40 laptop and doesn't even have a win key. I will definitely try to change xorg.conf to 105pc, but still i am afraid that I
Quote:
have an envious task of reading man setkeycodes and man loadkeys
Well, thanks for your time, I won't be able to peep into the problem until friday though, when I find the solution I will post it here.
best c.
 
Old 01-23-2006, 12:39 PM   #9
cuk
Member
 
Registered: Jun 2004
Distribution: slackware 10.2.
Posts: 39

Original Poster
Rep: Reputation: 15
I did a fresh install for various reasons and still no solution for the keyboard problem. Everything works in fluxbox or blackbox with the above mentioned xorg.conf, i can switch between layouts using alt+shift, but in kde i still can't use alt+shift combinations, and now i also cant use an apostrophe (') unless i press space right after pressing the ' key. So it is clearly a kde issue. I started to look into xkb, but it looks very complicated, so my question is> do you think it is something i can solve if i delve into xkb issues, or is there some sort of simple thing which could help me, f.e. some part of kde doesn't have the right permission or something.
one more interesting thing is> when I try to assign a keyboard shortcut in control center, immediately after pressing alt - shift a keyboard shortcut gets chosen, which is labelled alt+ISO_Next_Group. I tried to google from there, but could not find any useful information.
 
Old 01-24-2006, 09:57 AM   #10
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
well my brain hurts but try running your xorg.conf or XF86config or I think XF86cfg and see if you can change that keyboard......it will be simpler than playing with all that other junk.
I don use slack any more so just go into /usr/bin or sbin and double check the spelling of the commands pls
 
Old 01-24-2006, 11:42 AM   #11
cuk
Member
 
Registered: Jun 2004
Distribution: slackware 10.2.
Posts: 39

Original Poster
Rep: Reputation: 15
well, it is clearly not an xorg problem, because in fluxbox and any other window manager everything works as it should. only place the keys get messed up is kde.
If everything is working in X, but not in kde, that means kde probably further enhances or changes xorg, or has some settings which override xorg.conf. But where and how? i am right now stuck in some point, where i don't know where to look further. I went through all kde files in /opt, i read many keyboard howto's, which all dealt with xorg, i googled all sort of combinations of keywords, but everywhere i get the impression that if something works in X, it should work in kde too.
sorry to cause you brain-ache, i enjoy it too, well, got to be at least a bit masochistic to deal with all this anyway
 
Old 01-25-2006, 07:46 AM   #12
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
some links on xev that may help?

http://lists.ibiblio.org/pipermail/b...ay/000585.html

http://linux.wikicities.com/wiki/Fir...with_Slackware

http://www.faqs.org/docs/Linux-mini/Intkeyb.html

I read somewhere here keycode is 116 or 117 for win logo key
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shortcut keys for Non-KDE apps in KDE thebeast Linux - Software 0 12-03-2005 01:36 PM
Console shortcuts not working. jmr71769 Linux - General 1 09-14-2005 10:33 PM
Keyboard shortcuts not working in KDE when using a second language? joe_huddleston Linux - Software 1 06-17-2005 02:07 PM
KDE shortcuts? carlosinfl Fedora 3 07-10-2004 06:37 PM
Assigning keyboard shortcuts to keyboard keys the who Linux - Hardware 3 02-20-2004 09:36 PM


All times are GMT -5. The time now is 06:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration