LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-13-2009, 03:32 AM   #1
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
KDE Screen size problem


I am getting a problem under 12.2 after I close an KDE session and open a new one. When I first boot up, everything is fine. But if I log out (or kill X) and then log back in again, KDE acts as if the screen size was less (both in width and height) than the actual size. The desktop background covers the whole screen, but the task bar sits well above the bottom of the screen and only covers ~80% of the width. Windows are constrained to the 'smaller screen'.

The problem is presumably connected to the fact that in the KDE Control Centre->Display->Multiple monitors I have two displays, one smaller than the other BUT the second display only shows up after I log out of a KDE session and log back in again (ie on an initial boot, there's only one display).

So far the only solution I've found is a reboot. My xorg.conf doesn't contain anything about a second display.

Any ideas?
 
Old 06-13-2009, 03:28 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I don't know whether this will help, but in the Control Center, Peripherals, Display, Size & Orientation tab, there is a check box labeled Apply settings on KDE startup. Enable that option then select the Apply button.
 
Old 06-14-2009, 03:14 PM   #3
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
Quote:
Originally Posted by Woodsman View Post
I don't know whether this will help, but in the Control Center, Peripherals, Display, Size & Orientation tab, there is a check box labeled Apply settings on KDE startup. Enable that option then select the Apply button.
Thanks Woodsman. I should have mentioned that the screen size problem is already visible at the KDM screen - so before those KDE settings would even be implemented - and that if I log into Fluxbox everything is normal. Also, changing those screen dimension settings in that same panel doesn't resolve the problem.
 
Old 06-14-2009, 06:39 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I never have used dual monitors. Perhaps somebody else can pipe in here and help.

However, I'm reasonably sure that your xorg.conf should contain one section for each monitor and one section for each video card. I think there probably also should be two screen sections.
 
Old 06-14-2009, 06:48 PM   #5
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64 14.0
Posts: 981

Rep: Reputation: 88
Might help, maybe not. This is an old xorg.conf I had work for two monitors years ago, take a look, it may give you some ideas.

Code:
Section "Device"
Identifier "NVIDIA0"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "NVIDIA1"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Monitor"
Identifier "Monitor0"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Nvidia1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
 
Old 06-15-2009, 12:26 AM   #6
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
I'm only using one monitor and my xorg.conf is the Slackware default with the device driver changed to "intel".
 
Old 06-15-2009, 10:11 AM   #7
joegumbo
Member
 
Registered: Sep 2006
Distribution: Frugalware
Posts: 228

Rep: Reputation: 32
Have you tried your monitor's Auto-Adjust button? (Assuming it has one.) When I get strange or less than ideal output, this usually solves it for me.

Good Luck!

Last edited by joegumbo; 06-15-2009 at 10:16 AM.
 
Old 06-16-2009, 01:33 AM   #8
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
Quote:
Originally Posted by joegumbo View Post
Have you tried your monitor's Auto-Adjust button? (Assuming it has one.) When I get strange or less than ideal output, this usually solves it for me.

Good Luck!
It's a laptop so no reset button. In any case, the problem is with KDE thinking the display is smaller than it really is, not with Xorg.
 
Old 07-10-2009, 06:08 PM   #9
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
To add some more info about this problem which is still causing me problems:

1) ~/.xsession-errors reports that no 1280x800-sized screen can be found, but this is the size of my screen

2) /var/log/Xorg.0.log normally contains lines like: (II) intel(0): Modeline "1280x800"x0.0 68.90 1280 1304 1336 1400 800 804 808 820 -hsync -vsync (49.2 kHz)


3) but when the problem is present, no such lines appear in the logs; instead I get: (II) intel(0): Output VGA using initial mode 1152x768 (this is the size of the second monitor which appears in the KDE Multiple Monitors dialog box)


I'm including a diff of the two Xorg.0.log files, but the lines which grabbed my attention when I went through it were:
Code:
< (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 11 00:26:31 2009
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 11 00:24:05 2009
48c48,49
< (II) Open ACPI successful (/var/run/acpid.socket)
---
> (WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
Hope someone has some ideas!
Attached Files
File Type: txt xorg.txt (3.7 KB, 0 views)
 
Old 07-27-2009, 04:44 PM   #10
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
I'm still experiencing this problem. I have just found a link (http://paulsiu.wordpress.com/2007/11...nate-in-linux/) which refers to a similar problem after one logs out after having using hibernation.

He writes:
Quote:
On my Averatec 2370 running the binary Nvidia drivers “Nvidia”, if I set it to go to sleep or hibernate, then wake the computer, and then logout, the screen goes from the 1280800 to 1024768. This problem affects both Ubuntu 7.10 and Fedora 8.

Xorg gets the screen size from reading the Extended display identification data (EDID) information from the monitor. It appears that the EDID is read correctly when you start up, but after hibernation or sleep the info gets scrambled.

To correct the problem, I copied the correct EDID info into file when the EDID info is not scrambled. I then have xorg read the file instead of reading it from the monitor.

* Run the following command to launch the Nvidia Settings application:

Code:
gksudo nvidia-settings
* Click on the “DFP-0 – (Seiko) option. This brings up the options for the LCD monitor

* Click on the “Acquire EDID” button. This gets the EDID config info from the LCD monitor and ask where to save it. I saved it as “/etc/X11/SeikoEdid.bin”.

*Sudo edit the /etc/X11/xorg.conf file. Add the following line to the section for “Monitor”.

Code:
Option "CustomEDID" "DFP-0:/etc/X11/SeikoEdid.bin"
What seems to be happening is when you start X, it reads the EDID from the monitor. After a suspend or hibernate, you can no longer read the EDID for some reason. As a result, the driver defaults to a lower resolution, causing the screen to shrink. What I am doing is to record the correct EDID information into a file when it is correct and have X read from the file instead of the device. This should work around the problem.
This could be my problem, though I don't know if the fix is suitable. I have an Intel card (and am running Slackware!). Any suggestions?
 
Old 07-27-2009, 04:50 PM   #11
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
removed

Last edited by brixtoncalling; 07-27-2009 at 04:55 PM. Reason: double post
 
Old 07-27-2009, 09:00 PM   #12
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Quote:
This could be my problem, though I don't know if the fix is suitable. I have an Intel card (and am running Slackware!). Any suggestions?
The fix is fine. I use it all the time on my laptop, which has an EDID that incorrectly reports the highest resolution mode. One suggestion would be to add 'TerminateServer=true' to kdmrc, so that the Xserver is restarted after logout. This will ensure that your custom EDID file is read when X is restarted.
 
Old 07-28-2009, 12:48 AM   #13
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Original Poster
Rep: Reputation: 67
Thanks allend, finally I'm getting somewhere!

So how do I determine my correct EDID? The suggestion above is for Nvidia. I have the following in my Xorg.0.log:
Code:
(II) intel(0): EDID vendor "LPL", prod id 7681
 
Old 07-28-2009, 01:16 AM   #14
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
I got my EDID by using the nvidia-settings program referred to in the link that you posted. ( I had to edit mine with a hex editor according to instructions I found on the Toshiba web page. )
As you have Intel graphics then you will need to find a way to access the EDID. A quick Google search shows that read-edid should do what you want. http://john.fremlin.de/programs/linux/read-edid/

PS The Wikipedia entry for EDID is the best source of technical information that I have seen.

Last edited by allend; 07-28-2009 at 01:20 AM.
 
  


Reply

Tags
kde, screen, size, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with screen size cf13 Grafpup 5 06-11-2007 08:40 PM
KDE screen size on Mandrake baseballtwin86 Linux - Newbie 4 10-09-2004 08:33 PM
Screen size problem darkstar420 Slackware 5 08-08-2004 04:12 PM
xscreensaver in KDE uses wrong screen size EdoardoC Mandriva 4 03-23-2004 09:15 AM
Screen size problem Linux~Powered Linux - Hardware 5 02-11-2004 02:24 AM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration