LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-11-2006, 10:48 PM   #1
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
KDE screen saver trouble


Any one else having screen saver trouble with KDE in Slackware 11.0? I'm getting random oddities. Sometimes it works, sometimes it doesn't, on both the laptop and desktop (clean install). Has anyone else had this problem and did they fix it? If so how? Chances are I just made the same mistake twice since it appears no one else has asked about it, but if anyone else made the same mistake, let me know.

Thanks!
...drkstr
 
Old 10-12-2006, 06:06 AM   #2
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
Same here too.
I wouldn't know what causes it.
Also clean install.
Maybe something to do with the fact that I kept my old /home/?
If I'm not mistaking, the screensaver for root works well.

Last edited by adriv; 10-12-2006 at 06:07 AM.
 
Old 10-12-2006, 12:01 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,294

Rep: Reputation: Disabled
The solution is to either activate the monitor's power saving features in the KDE desktop menu, or else add the following line to the [ScreenSaver] section of .kde/share/config/desktoprc:
Code:
DPMS-dependent=false
Don't ask me why, but these worked for me.

Eric
 
Old 10-12-2006, 12:48 PM   #4
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Rep: Reputation: 32
I had it suddenly stop working on me even though I have "Enable display power management" checked. I found that by unchecking it and rechecking it, screensavers worked again. Go figure.
 
Old 10-12-2006, 02:08 PM   #5
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by Alien Bob
The solution is to either activate the monitor's power saving features in the KDE desktop menu, or else add the following line to the [ScreenSaver] section of .kde/share/config/desktoprc:
Code:
DPMS-dependent=false
Don't ask me why, but these worked for me.

Eric
Thanks Eric, that did the trick!

...aaron
 
Old 10-12-2006, 03:33 PM   #6
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
Quote:
Originally Posted by drkstr
Thanks Eric, that did the trick!
Same here.
Thanks!
 
Old 10-12-2006, 09:08 PM   #7
alienux
Member
 
Registered: Sep 2006
Location: Dayton, Ohio
Distribution: Slackware 12, Fedora Core, PCLinuxOS
Posts: 194

Rep: Reputation: 30
Never had any screensaver problems in 10.2, but couldn't get them to start automatically in 11. Just enabling power management as Alien Bob suggested was enough for me.
 
Old 10-13-2006, 05:14 AM   #8
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu
Posts: 110
Blog Entries: 1

Rep: Reputation: 17
glad to have you with us earth dwellers Alien Bob....thanks for the tip .
 
Old 10-21-2006, 11:33 PM   #9
Mountain Man
Member
 
Registered: Jul 2006
Distribution: Ubuntu 11.10 (desktop), lubuntu 11.10 (netbook)
Posts: 73

Rep: Reputation: 15
Another possible fix.

I was having the same problem in Mepis 6.0-1, and found this thread while trying to solve the problem. None of the fixes listed above worked for me, but I did find a (rather strange) fix that worked for me so I thought I'd add it here. If I turn on the screensaver and have it set to go off either before or concurrent with standby (in pwr mgmt section) and then set suspend to go off after standby, the screensaver kicks in when suspend should. I haven't tried all combinations, but the order of the triggers does seem to make a difference.

For example, if I set the screensaver time to 1 min, standby to 1 min, and suspend to 2 min the screen goes black (backlight still on) after 1 min, and then the screensaver kicks on in another 2 min (3 min after last input).

If the other fixes don't work for you, maybe this one will. Also, I've read that sometimes installing xscreensaver trips something in the KDE screensaver and it will start working as expected. I haven't tried this though because mine is working and I don't wan't to screw with it any more .

Last edited by Mountain Man; 10-22-2006 at 11:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
screen saver in kde 3.3 bullwinkle Linux - Newbie 1 06-15-2005 10:05 AM
KDE screen-saver in MD9.2 santiagosilva Linux - Newbie 4 04-03-2004 12:00 PM
KDE Screen Saver Bug? olias Linux - Software 1 04-21-2003 09:27 PM
screen saver on kde. Ciccio Linux - Newbie 2 12-09-2002 10:17 PM
buggy kde-2.2 screen saver sakeeb Linux - Software 4 06-04-2002 08:31 AM


All times are GMT -5. The time now is 10:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration