LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE Network Management problems (http://www.linuxquestions.org/questions/slackware-14/kde-network-management-problems-4175487024/)

Geremia 12-05-2013 03:42 PM

KDE Network Management problems
 
Even with the recent KDE 4.11.4 on Slack 14.1, I have not been able to get KDE's Network Management working. It's completely blank and says it's disabled.

Bertman123 12-05-2013 04:03 PM

What kind of wireless card do you have?

Alien Bob 12-06-2013 06:08 AM

Did you make the /etc/rc.d/rc.networkmanager script executable?

Eric

Geremia 12-06-2013 09:24 AM

Quote:

Originally Posted by Bertman123 (Post 5076169)
What kind of wireless card do you have?

The wireless card works. I've been using wpa_supplicant and wpa_gui, but it doesn't work as well as I'd like. I always have to restart /etc/rc.d/rc.inet1.
Quote:

Originally Posted by Alien Bob (Post 5076435)
Did you make the /etc/rc.d/rc.networkmanager script executable?

Eric

No, it's not. But, when I started it, NetworkManager seemed to conflict with my /etc/rc.d/rc.inet1.conf settings, and it disconnected my ethernet connection.

Alien Bob 12-06-2013 12:24 PM

Quote:

Originally Posted by Geremia (Post 5076511)
The wireless card works. I've been using wpa_supplicant and wpa_gui, but it doesn't work as well as I'd like. I always have to restart /etc/rc.d/rc.inet1.No, it's not. But, when I started it, NetworkManager seemed to conflict with my /etc/rc.d/rc.inet1.conf settings, and it disconnected my ethernet connection.

Well yes, they conflict of course. You should use one or the other.
If you want to use NetworkManager, then clean out the /etc/rc.d/rc.inet1.conf file (an empty one can be downloaded here if you do not know how to clean that file) and make /etc/rc.d/rc.networkmanager executable. Then your KDE applet will work.

Eric

Geremia 12-08-2013 06:18 PM

Quote:

Originally Posted by Geremia (Post 5076511)
The wireless card works. I've been using wpa_supplicant and wpa_gui, but it doesn't work as well as I'd like. I always have to restart /etc/rc.d/rc.inet1.No, it's not. But, when I started it, NetworkManager seemed to conflict with my /etc/rc.d/rc.inet1.conf settings, and it disconnected my ethernet connection.

I have my rc.inet1.conf pretty customized for eth0 (custom IP, IPv6 tunnel, etc.) and blank for wlan0, so I would like to use NetworkManager for wlan0. Is that possible?
thanks

guanx 12-08-2013 06:32 PM

Quote:

Originally Posted by Geremia (Post 5077605)
I have my rc.inet1.conf pretty customized for eth0 (custom IP, IPv6 tunnel, etc.) and blank for wlan0, so I would like to use NetworkManager for wlan0. Is that possible?
thanks

I've tried the same with no luck. This is why I went back to "rc.inet1.conf".

Bertman123 12-08-2013 06:59 PM

I think that you need to use one or the other.

Geremia 12-08-2013 11:37 PM

Quote:

Originally Posted by Bertman123 (Post 5077618)
I think that you need to use one or the other.

Why exactly do they conflict?

Bertman123 12-10-2013 07:59 PM

It's like having two light switches control the lights in a room. Only one switch at a time can turn the light on. I'm not sure if that helps or is accurate, but it makes sense in my head.

allend 12-10-2013 09:16 PM

Quote:

Why exactly do they conflict?
This thread has an example. http://www.linuxquestions.org/questi...5/#post5064134

Quote:

I have my rc.inet1.conf pretty customized for eth0 (custom IP, IPv6 tunnel, etc.) and blank for wlan0, so I would like to use NetworkManager for wlan0. Is that possible?
Perhaps put the customisations for eth0 in a script in /etc/NetworkManager/dispatcher.d and use NetworkManager for all.


All times are GMT -5. The time now is 01:08 PM.