LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE Logon Hang with 64-bit nVidia 304.64 GeForce 7150M (http://www.linuxquestions.org/questions/slackware-14/kde-logon-hang-with-64-bit-nvidia-304-64-geforce-7150m-4175445064/)

Erik_FL 01-10-2013 08:59 PM

KDE Logon Hang with 64-bit nVidia 304.64 GeForce 7150M
 
Is anyone else having problems with the 64-bit nVidia version 304.64 proprietary driver?

The problem I have is with Slackware 14 64-bit. The first time that I log in to KDE it works. If I log out and try to log back in the second time, then the computer freezes near the end of the KDE logon animation. Sometimes I can get a console with Ctrl+Alt+F1.

I tried installing KDE version 4.9.5 and it behaves the same way. I tried disabling frame buffer and building the kernel without frame buffer support. That also did not solve the problem.

I reverted to an older nVidia version 304.43 driver and the problem does not happen. The problem does not happen with the Nouveau driver included with Slackware 14. As expected, some of the KDE desktop effects won't work with the Nouveau driver.

My hardware is an HP DV9999US laptop with an nVidia chip-set and GeForce 7150M graphics chip. This is the first time that I've tried running a 64-bit kernel instead of a 32-bit kernel. I'm using the huge 64-bit kernel version 3.2.29 that comes with Slackware.

Can anyone confirm if there is a problem with the nVidia version 304.64 driver or suggest other solutions? I don't mind using older drivers for a while, but I eventually would like to get more recent drivers to work.

Any advice is appreciated.

slackass 01-11-2013 12:07 AM

Quote:

Originally Posted by Erik_FL (Post 4867411)

Can anyone confirm if there is a problem with the nVidia version 304.64 driver or suggest other solutions? I don't mind using older drivers for a while, but I eventually would like to get more recent drivers to work.


I havent had any problems at all on 6 boxes.
X86_64-304.64
GeForce 9500 and various others useing nvidia cards.
Slack64-14 Multilib & non-Multilib boxes.

EDIT:
Ok I shot my face off before I understood the problem, again.
I do have this problem also.
I dropped back to 304.60 with same results.
I dropped back to 304.43 and that fixed it.

kabamaru 01-11-2013 03:15 AM

nVidia 650GTX (310.19), same problem with KDE. I've searched the whole internet to find a proper solution but there isn't one.The options for now are:

1. Use init 3 and startx instead of KDM.
2. Continue with init 4, and when the problem occurs, change to init 3 and then back to 4.
3. Continue with init 4, and disable desktop effects.
4. Use an older version of the nvidia blob. I remember trying out several versions (with my 7900GTX which also had the problem), but I don't remember which one worked. I do remember though that the downgrade caused other issues with a couple of games.

Erik_FL 01-11-2013 12:23 PM

Thanks for the replies.

I remember having a similar problem with a Voodoo3 graphics card. In that case the screen would just be black after a logout. I found a way to force the xserver to restart on every logout. I'm going to look for that information again when I get a chance. It might fix the problem.

tuxbg 01-12-2013 07:12 AM

Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection

This is from here http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT

Erik_FL 01-12-2013 02:17 PM

Quote:

Originally Posted by tuxbg (Post 4868324)
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection

This is from here http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT

Thanks. I am aware of that information. I have to do that in all of the Slackware systems that I run in VirtualBox virtual machines.

Erik_FL 01-12-2013 11:22 PM

Work Around
 
I found that the work around I was using for an old Voodoo 3 card seems to also solve this nVidia driver issue.

The work around is to force the X-Server to restart on every log out.

To do that I edited the file "/etc/kde/kdm/kdmrc". I un-commented the "TerminateServer=true" line.
Code:

# Restart instead of resetting the local X-server after session exit.
# Use it if the server leaks memory etc.
# Default is false
TerminateServer=true

So far I haven't run into other problems with the 304.64 driver.

Tsu Jan 02-24-2013 11:52 PM

Quote:

Originally Posted by Erik_FL (Post 4867411)
Is anyone else having problems with the 64-bit nVidia version 304.64 proprietary driver?

The problem I have is with Slackware 14 64-bit. The first time that I log in to KDE it works. If I log out and try to log back in the second time, then the computer freezes near the end of the KDE logon animation. Sometimes I can get a console with Ctrl+Alt+F1.

I have the same problem with the 64-bit nVidia 304.64 on Debian. I found that if I restart X with the KDM menu before logging in, the freeze won't happen.

Tsu Jan 02-25-2013 04:21 AM

Good news: the problem is fixed with nVidia 313.18.

Erik_FL 03-10-2013 07:55 PM

The 304.84 driver recently released by nVidia does not correct this problem. In fact that driver works even worse than the 304.64 driver. The 304.84 driver always displays a black screen when logging out of KDE or switching to a text console. That occurs even when using "TerminateServer".

So far, using the 304.64 with the "TerminateServer" option in "kdmrc" works well.

Tsu Jan 03-11-2013 03:53 AM

Quote:

Originally Posted by Erik_FL (Post 4908827)
The 304.84 driver recently released by nVidia does not correct this problem...

V313.18 (from Debian Experimental) is OK here; no problem at all.

Erik_FL 03-11-2013 02:32 PM

Quote:

Originally Posted by Tsu Jan (Post 4908980)
V313.18 (from Debian Experimental) is OK here; no problem at all.

Unfortunately nVidia has many different forks of the same driver code. Depending on the graphics card, they may or may not include changes and bug fixes. Are you testing with a GeForce 7150M graphics card on an AMD CPU?

Tsu Jan 03-12-2013 01:04 AM

Quote:

Originally Posted by Erik_FL (Post 4909361)
Unfortunately nVidia has many different forks of the same driver code. Depending on the graphics card, they may or may not include changes and bug fixes. Are you testing with a GeForce 7150M graphics card on an AMD CPU?

I have GeForce 9500 GT with Intel(R) Core(TM)2 Duo CPU. However, IMHO using "TerminateServer" option is good in general because it prevents memory leaks.

Erik_FL 03-12-2013 12:53 PM

I was actually more concerned with the fact that the newest driver works worse. Problems with the nVidia and AMD (ATI) graphics drivers have been one my difficulties using Linux. It doesn't help that KDE keeps changing and generally increasing the requirements for the graphics drivers.

I don't have any complaint about using TerminateServer, and I can use a slightly out of date graphics driver for now.


All times are GMT -5. The time now is 10:09 PM.