LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-27-2012, 08:42 AM   #1
PenguinWearsFedora
Member
 
Registered: Jul 2009
Distribution: Slackware-14
Posts: 52

Rep: Reputation: 1
KDE gives blank screen on logouts (using startx not KDM)


I log into run level 3, then I use startx to get KDE. When I logout of KDE instead of falling into run level 3 with nice prompt, I get blank screen. Monitor's power light goes orange (from green).

This has been a problem since downloading new (NVIDIA-Linux-x86-285.05.09.run) from nvidia website. I havn't changed xorg.conf either. I removed old nvidia with nvidia-uninstall and ran the new script.

Can't find anything useful in Xorg.log but my syslog gives this:
Code:
Feb 27 18:49:40 darkstar console-kit-daemon[1765]: WARNING: Failed to acquire org.freedesktop.ConsoleKit 
Feb 27 18:49:40 darkstar console-kit-daemon[1765]: WARNING: Could not acquire name; bailing out
Running Slackware-13.37 with 2.6.37.6-smp.

Any suggestions will be appreciated.

Edit: I installed NVIDIA-Linux-x86-295.20.run, I copied/pasted the wrong file name.

Last edited by PenguinWearsFedora; 02-28-2012 at 11:34 AM.
 
Old 02-27-2012, 06:26 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,555

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
how about upgrading the NVidia driver?
NVidia's latest driver is 295.20
 
Old 03-13-2012, 09:57 PM   #3
b1tch-x
LQ Newbie
 
Registered: Sep 2011
Location: Canada
Distribution: slackware64 14.0
Posts: 7

Rep: Reputation: Disabled
Sorry, wrong solution.

Last edited by b1tch-x; 03-13-2012 at 09:58 PM. Reason: Mistake
 
Old 03-13-2012, 11:25 PM   #4
saycheese
LQ Newbie
 
Registered: Mar 2012
Distribution: Slackware64 13.37
Posts: 6

Rep: Reputation: 0
I was having a similar problem with getting a black screen after logging out of KDE (init 3 like you). It magically fixed itself after I reinstalled for other reasons but I did try to find a solution.

http://www.linuxquestions.org/questi...th-kdm-765433/

It's a shot in the dark, but I had saved that link to apply the change to kdmrc file if the black screens started happening again. Maybe it'll help you.
 
Old 03-14-2012, 12:25 PM   #5
PenguinWearsFedora
Member
 
Registered: Jul 2009
Distribution: Slackware-14
Posts: 52

Original Poster
Rep: Reputation: 1
I've seen the above post, but the OP (thach.trung.ngoc) was having problem when booting into runlevel 4 (multiuser with X) unlike me (I was having problem when I boot into runlevel 3, and startx into KDE). I assume thach.trung.ngoc's fix was to tinker with kdmrc file since he is using KDM. Since, I don't use KDM this might not work for me. I would definitely have given it a try, but I've already reverted back to my previous nvidia driver. Guess what, problem went away!
 
  


Reply

Tags
blank, kde, screen, startx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kdm works but startx doesn't (black screen stop) spikeygg Linux - Software 5 01-10-2010 04:38 PM
(nvidia) First startx = blank screen, second startx = works ?!? BuckRogers01 Linux - Hardware 2 04-07-2006 05:26 PM
blank screen when i startx jimjamjahaa Debian 5 01-24-2006 11:23 AM
StartX Then Blank Screen computer_kid Linux - Newbie 12 02-20-2004 03:29 PM
startx and blank screen! etillman Slackware 10 11-16-2003 08:41 AM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration