LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-24-2007, 10:28 PM   #1
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Rep: Reputation: 30
KDE freezes at start up after Alsa setup


I was setting up alsa on my slak 10.2 kernel 2.4.31 box and during alsaconf the system froze, no keyboard no nothing. It was in the middle of oss set up. So, I rebooted and now neither root nor user can finish KDE 3.4 start up. It makes it to loading the window manager and freezes. I can't remember the command to ,pardon syntax here, re make kde environment. I know you can, or could, in the Gnome environment. I can access the command line b/c I don't boot to kdm. Can someone plz point me in the right direction.

Thanks for any and all help..!!
 
Old 05-25-2007, 12:48 AM   #2
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Hi Rollo

It sounds to me like you "may" have an IRQ device resource conflict.

The alsaconf tool when it probes your hardware, will try all IRQ and DMA settings for whatever "module" it believe's it should try for your hardware. The "module" being a driver.

What I propose you do is give us the printout of "lspci" and paste it here.

In addition, I think you should pull out any "un-necessary" PCI cards that you may have. For example if you do not need a modem, the pull it out. You may also have to move the sound card to a different slot. You didnt specify if you have a laptop or desktop.

Lastly, check in the bios of your pc and check to see if there are any settings for the sound card there. Sometimes, in the bios there is a button to reset the bios to defaults for the sound card. I've found that for example windows, since it is a plug and play OS can change the settings to work the pc better but they may not be so good for you in linux. Resetting the bios may help.

Well hope this gives you some idea where to start.

Also, you can turn stop alsa from starting with your pc by making /etc/rc.d/rc.alsa not executable on startup so you can get into a gui if need be.

Also if you run 'xwmconfig' you can select fluxbox to run as your default window manager for the time being to get things cleared up.

Oh yea, you do have the isapnp tools installed correct?
 
Old 05-25-2007, 04:48 PM   #3
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Original Poster
Rep: Reputation: 30
Thanks for your quick reply. I'm using fluxbox now to get you the info you requested. I don't have any pci cards. Everything is onboard and is either SiS or Realtek.

1st -
lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 651 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge) (rev 25)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter

I've changed rc.alsa so that it's not executable on startup. I will check now to see if that was the conflict. c ya in a minute.

Thanks

[edit]
After rebooting KDE still won't start up, it's still hanging up at 'loading the window manager'. I didn't like flux or blackbox to much but xfce wasn't to bad. That's just my personal opinion and everyone has different tastes. If there is any other nfo I can provide you with let me know.
What causes dma to be turned off and what makes a file system unclean?? Both of these are coming up during boot. I didn't have this problem when this hd was in other pc, but since the switch to the faster pc (from p3 pc to 1.8ghz pc) it continues to come up. It specifically says dma is turned off on the hd and I didn't turn it off.

Thank you for your help.!!.

Last edited by Rollo69; 05-25-2007 at 05:01 PM.
 
Old 05-26-2007, 01:10 AM   #4
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
about the fluxbox:

yea I was just mentioning that to you so you could use your computer still, while the solution for your issue is worked out.

just so you know you can run "fluxbox-generate_menu" and it will work up a menu for you that includes all the programs on your computer.

-----------

Quote:
what makes a file system unclean??
I venture to guess that you hit the reset key to reboot your pc when it froze? Not properly rebooting will do that.

You can schedule a diskcheck on the hard drive with the "shutdown" command. Check the manpage it will tell you how to schedule the disk check on next reboot. use "man shutdown" and you'll see it there.

---------------

Quote:
What causes dma to be turned off
try going the the 'dmesg' of the computer. see what it says about your hard drive.

also check the 'man hdparm' that's the utility to tweak the DMA settings and other IO parameter's of the hard drive. some people report that slackware doesnt put it on there correctly for them and that it was supposed to.

"hdparm -i /dev/hda" shows info for the drive /dev/hda for example

and this one helps"
"hdparm /dev/hda" also

-------------------

I wonder if you might not be better to install the 2.6 kernel that slackware 10.2 ships in /testing to address your issues for the sound, and quite possibly your hard drive.

At this link here you can see that Mr. Pat V also includes some new alsa driver's as well in addition to the new kernel.


http://ftp.uwsg.indiana.edu/linux/sl.../linux-2.6.13/

It is quite simple to do. Just DO NOT put the headers in. Keep slackware's 2.4 headers in there.
 
Old 05-29-2007, 09:12 PM   #5
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Original Poster
Rep: Reputation: 30
Thanks for your help Old_Fogie. You were correct about the reset button. The file system showed up clean when I booted up. I will use the man hdparm to turn dma on because hdparm /dev/hda* showed that dma was off. As far as alsa goes, it worked fine with the other hd I had in this machine b4 the swap. Not sure why there's a problem now.

KDE is still not functioning correctly. It hangs up at the same spot even w/ alsa stopped. Any suggestions would be greatly appreciated.
 
Old 05-29-2007, 09:34 PM   #6
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 924

Rep: Reputation: 94
Maybe something that starts up with KDE is causing the problem, e.g. something configured for autostart or one of the apps from your last session.

Can you switch to console using Ctrl+Alt+F1(..F6) (Use F7 to return to X). If you can, then it's an X/KDE freeze only, if not, then it could be a hardware issue.

If you suspect KDE, you can try renaming the .kde directory to something else so that your user settings are reset. See if it works that way.
 
Old 06-03-2007, 01:15 PM   #7
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
apparently the latest ATI driver's address this issue, see the release notes.
 
Old 06-07-2007, 09:58 PM   #8
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Original Poster
Rep: Reputation: 30
Thanks for your replies guys and sorry for not responding earlier than today. I just moved and got internet set up.

Quote:
Originally Posted by Ilgar
Maybe something that starts up with KDE is causing the problem, e.g. something configured for autostart or one of the apps from your last session.

Can you switch to console using Ctrl+Alt+F1(..F6) (Use F7 to return to X). If you can, then it's an X/KDE freeze only, if not, then it could be a hardware issue.

If you suspect KDE, you can try renaming the .kde directory to something else so that your user settings are reset. See if it works that way.
I can switch to console using Ctrl-Alt-F# (#=2-6) and come back using F7. So that I understand you correctly Ilgar, your saying to cp -r .kde to .kdebad and rm -r .kde then restart kde??

Quote:
Originally Posted by Old_Fogie
apparently the latest ATI driver's address this issue, see the release notes
Forgive me for being a newb but where do I find the release notes you're refering to??

Thanks again..
 
Old 06-07-2007, 10:07 PM   #9
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
oops that reply was meant for a different thread sorry, I had one of my moments.
 
Old 06-07-2007, 11:29 PM   #10
Prostetnic_Jeltz
Member
 
Registered: Feb 2006
Posts: 66

Rep: Reputation: 16
yes, you can try removing .kde, and clean out /tmp as well

also, if you are starting X from a console (ie, by typing "startx") there should be some error messages on that console when kde bombs out, make sure to search for solutions by searching for those exact error messages

another thing you could try as a last resort, if all else fails, is reinstalling kde (NOT the whole distro!), even though its unlikely the problem, you may have installed some corrupt/incomplete packages - you can grab them at slackware.com, then remove all existing kde packages by running "pkgtool" (as root) and install the new ones. be careful with the version you pick if you do that, try reinstalling the version you have installed now, so as not to run into dependency problems (by using the latest current version with a stock 10.2 install, for example).
 
Old 06-08-2007, 04:27 AM   #11
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 924

Rep: Reputation: 94
Quote:
Originally Posted by Rollo69
I can switch to console using Ctrl-Alt-F# (#=2-6) and come back using F7. So that I understand you correctly Ilgar, your saying to cp -r .kde to .kdebad and rm -r .kde then restart kde??
You can simply do

Code:
mv .kde .kde_old
(while kde is off) and then login with KDE. If it turns out that your KDE settings are not the source of the problem, you can do

Code:
rm -rf .kde
mv .kde_old .kde
to bring the old settings back.
 
Old 06-09-2007, 02:56 PM   #12
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Original Poster
Rep: Reputation: 30
Thanks for your help guys.
I tried the mv command and then restarted kde but didn't work. I loaded up bare Slack (vmlinuz) and everything work fine, so I removed the alsadriver(1.0.9) pkg's I loaded w/ pkgtool. working again. I did rm -rf .kde and mv .kde_old .kde then tried starting kde and voila... Only one prob I see is that some icons are now missing from b4 as well as my bookmarks in firefox. Hopefully my bookmarks are in the xfce directory still. I will look and see. I guess I will have to research some more on getting alsa-driver to work correctly and in unison w/ kde. Any clues how would be appreciated.

Thanks for your help.!!.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa sometimes freezes on startup bluefire Linux - General 1 03-20-2005 07:03 PM
fedora core 2 (FC2) freezes while running. Cannot boot into KDE it freezes mraswan Fedora 0 05-25-2004 07:46 PM
SBLive 5.1 In Gentoo - tried to setup ALSA now KDE Sound doesn't even work kierl Linux - Hardware 13 04-21-2004 03:36 AM
kde 3.2 COnfigure desktop hangs, "start" meue freezes qwijibow Linux - Software 3 02-08-2004 05:06 AM
KDE freezes after installing ALSA disciple061 Linux - Software 0 12-17-2003 02:05 PM


All times are GMT -5. The time now is 09:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration