LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-08-2010, 05:33 PM   #1
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
KDE desktop effects not working with Intel graphics (Slackware-Current; March 7, 2010


I've just noticed that KDE desktop effects aren't working anymore; I assume this happened after the recent X update. I've tried the alternate Intel drivers in /extra with no luck. I've also tried Alien Bob's KDE 4.4.1 packages... still no luck.

Some info about my graphics card:
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
Code:
bash-4.1$ glxinfo | grep rendering
direct rendering: Yes
Attached is a screenshot of the error I get when trying to enable desktop effects. (I've already tried messing with the settings)
Attached Images
File Type: png snapshot1.png (42.9 KB, 22 views)

Last edited by piratesmack; 03-09-2010 at 08:09 AM.
 
Old 03-09-2010, 05:30 AM   #2
shyko
LQ Newbie
 
Registered: Nov 2009
Location: Maríla, SP BRA
Distribution: Slackware
Posts: 4

Rep: Reputation: 1
I got same problem with a similar card (also Intel, but a desktop one). The solution I found was downgrade Mesa to 7.6.1 version.
 
1 members found this post helpful.
Old 03-09-2010, 06:04 AM   #3
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Quote:
Originally Posted by piratesmack View Post
I've just noticed that KDE desktop effects aren't working anymore; I assume this happened after the recent X update. I've tried the alternate Intel drivers in /extra with no luck. I've also tried Alien Bob's KDE 4.4.1 packages... still no luck.

Some info about my graphics card:
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
Code:
bash-4.1$ glxinfo | grep rendering
direct rendering: Yes
Direct rendering does not mean you have 3D acceleration working. The Mesa software rasterizer can provide direct rendering but is incapable of running desktop effects. What is the output of 'glxinfo | grep -i render'?
 
1 members found this post helpful.
Old 03-09-2010, 07:18 AM   #4
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Original Poster
Rep: Reputation: 133Reputation: 133
Thanks for replying

@adam
Code:
bash-4.1$ glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: Gallium 0.3 on i915 (chipset: 945GME)
@shyko
I'll give that a try.

Last edited by piratesmack; 03-09-2010 at 01:09 PM.
 
Old 03-09-2010, 07:26 AM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Alright, so you definitely have 3D acceleration. I'm rather surprised it's using the gallium driver, as I didn't realize that it was ready for prime time yet. Though, maybe it's not, and that's the reason for your problems. I'd try downgrading to Mesa 7.6.1, too, as shyko suggested.

Adam
 
1 members found this post helpful.
Old 03-09-2010, 08:08 AM   #6
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Original Poster
Rep: Reputation: 133Reputation: 133
Thanks again, guys.
Downgrading mesa worked.

Update: Looks like they fixed it
Code:
x/mesa-7.7-i486-3.txz:  Rebuilt.
  Removed --enable-gallium-intel and --enable-gallium-radeon from ./configure.

Last edited by piratesmack; 03-12-2010 at 11:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1st March 2010 -current - bash completion lopid Slackware 11 03-06-2010 06:28 PM
kde 4.2.4 - videos stop working on enabling desktop effects dpsh Linux - Desktop 5 07-15-2009 02:08 AM
Slackware 12.2(current) + KDE 4.1.96 + Xinerama = No Desktop Effects frandalla Slackware 3 01-29-2009 10:22 AM
KDE and GNOME Desktop effects not working neolithic_psyche Fedora 1 02-09-2008 11:14 AM


All times are GMT -5. The time now is 09:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration