LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-28-2003, 02:34 PM   #1
localnihilist
LQ Newbie
 
Registered: Sep 2003
Distribution: Slackware, what else?
Posts: 3

Rep: Reputation: 0
KDE crashing


Hi folks,

I have Slack 9.1 setup on my Inspiron 8200 laptop, and have been using KDE happily for some time. Recently 2 problems have arisen. One Konqueror is crashing whenever I close the browser with the following error:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384 (LWP 3912)]

0x410d2f29 in wait4 () from /lib/libc.so.6
#0 0x410d2f29 in wait4 () from /lib/libc.so.6
#1 0x41153234 in __DTOR_END__ () from /lib/libc.so.6
#2 0x40ee8103 in waitpid () from /lib/libpthread.so.0
#3 0x40633c4d in KCrash::defaultCrashHandler(int) ()
from /opt/kde/lib/libkdecore.so.4
#4 <signal handler called>
#5 0x40c19fc7 in QGDict::unlink_ascii(char const*, void*) ()
from /usr/lib/qt/lib/libqt-mt.so.3
#6 0x40c1a474 in QGDict::take_ascii(char const*) ()
from /usr/lib/qt/lib/libqt-mt.so.3
#7 0x403e1dc1 in KActionCollection::_take(KAction*) ()
from /opt/kde/lib/libkdeui.so.4
#8 0x403e1f26 in KActionCollection::take(KAction*) ()
from /opt/kde/lib/libkdeui.so.4
#9 0x403d1790 in KAction::~KAction() () from /opt/kde/lib/libkdeui.so.4
#10 0x409afbf2 in QObject::~QObject() () from /usr/lib/qt/lib/libqt-mt.so.3
#11 0x403e1707 in KActionCollection::~KActionCollection() ()
from /opt/kde/lib/libkdeui.so.4
#12 0x409e1508 in QWidget::~QWidget() () from /usr/lib/qt/lib/libqt-mt.so.3
#13 0x40a8c6ef in QMainWindow::~QMainWindow() ()
from /usr/lib/qt/lib/libqt-mt.so.3
#14 0x404330ae in KMainWindow::~KMainWindow() ()
from /opt/kde/lib/libkdeui.so.4
#15 0x4003c388 in KParts::MainWindow::~MainWindow() ()
from /opt/kde/lib/libkparts.so.2
#16 0x41394781 in KonqMainWindow::~KonqMainWindow() ()
from /opt/kde/lib/konqueror.so
#17 0x409b0623 in QObject::event(QEvent*) () from /usr/lib/qt/lib/libqt-mt.so.3
#18 0x409e6c4c in QWidget::event(QEvent*) () from /usr/lib/qt/lib/libqt-mt.so.3
#19 0x40a8e3a2 in QMainWindow::event(QEvent*) ()
from /usr/lib/qt/lib/libqt-mt.so.3
#20 0x409548c4 in QApplication::internalNotify(QObject*, QEvent*) ()
from /usr/lib/qt/lib/libqt-mt.so.3
#21 0x4095408b in QApplication::notify(QObject*, QEvent*) ()
from /usr/lib/qt/lib/libqt-mt.so.3
#22 0x405b8c69 in KApplication::notify(QObject*, QEvent*) ()
from /opt/kde/lib/libkdecore.so.4
#23 0x40955658 in QApplication::sendPostedEvents(QObject*, int) ()
from /usr/lib/qt/lib/libqt-mt.so.3
#24 0x40968749 in QEventLoop::enterLoop() () from /usr/lib/qt/lib/libqt-mt.so.3
#25 0x40968608 in QEventLoop::exec() () from /usr/lib/qt/lib/libqt-mt.so.3
#26 0x40954af1 in QApplication::exec() () from /usr/lib/qt/lib/libqt-mt.so.3
#27 0x4138f457 in main () from /opt/kde/lib/konqueror.so
#28 0x0804cb41 in strcpy ()
#29 0x0804d7fb in strcpy ()
#30 0x0804dcac in strcpy ()
#31 0x0804e9b9 in strcpy ()
#32 0x4103abb4 in __libc_start_main () from /lib/libc.so.6

The second and more distressing issue is that today KDE itself crashed and sent me to the command prompt with the following error:

Fatal server error:
Caught signal 11. Server aborting


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

ksmserver: Fatal IO error: client killed
ICE default IO error handler doing an exit(), pid = 1154, errno = 2
ICE default IO error handler doing an exit(), pid = 1156, errno = 0
ICE default IO error handler doing an exit(), pid = 1160, errno = 0
zone still contained 73 blocks
ICE default IO error handler doing an exit(), pid = 1165, errno = 0
ICE default IO error handler doing an exit(), pid = 1166, errno = 0
ICE default IO error handler doing an exit(), pid = 1181, errno = 0
ICE default IO error handler doing an exit(), pid = 1897, errno = 2
zone still contained 71 blocks
secondstr1ke@aaron:~$ KLauncher: Exiting on signal 1
klauncher: Fatal IO error: client killed
startkde: Running shutdown scripts...
startkde: Done.

Im not sure if the 2 problems are connected, but can anyone point me in the right direction. I'm pretty new to Linux and have been enjoying it, but am confused on the above mentioned problems.

Thanks in advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE crashing Klaus Paiva Linux - Software 3 10-27-2005 06:54 AM
KDE crashing vinceo03 Mandriva 8 10-26-2005 09:46 PM
Fedora W/ KDE Crashing jeopardyracing Linux - Newbie 3 09-23-2004 06:47 AM
KDE crashing jasonmcneil0 Linux - Software 3 12-15-2003 05:07 PM
terminal keeps crashing in KDE Pcghost Linux - Software 0 03-19-2003 11:01 AM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration