LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-22-2012, 12:06 PM   #1
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
kde cannot hibernate, xfce can


I'm on -current with Alien Bob's kde 4.8.0. In xfce both sleep and hibernate work. In kde sleep works, but hibernate hangs with the black screen, blinking cursor, and fan revved up, like it's ready to shut off but just can't. /var/log/pm-suspend.log, which I assume is the relevant one, shows nothing but successes. Can anyone help me with this?

BTW, resume from hibernate is sooo much faster on the new kernel. Yay!

Thanks,
Brian
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 02-22-2012, 04:46 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
My laptop with slackware64-current and KDE 4.8.0 hibernates just fine. However I created a necessary initrd using option "mkinitrd -h /my/swap/partition" and added append="resume=/my/swap/partition" to /etc/lilo.conf.

Eric
 
Old 02-22-2012, 06:47 PM   #3
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
I started with a fresh ~/.kde directory and that fixed it. I'm glad because I'm enjoying my test drive of KDE 4.8.0 :-)
 
Old 03-05-2012, 09:49 AM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
Just an update on this...

Hibernation on my laptop (HP Pavilion dv6) is still broken (although it works sometimes), but it looks like a kernel issue. I have found similar reports from fedora and Redhat that at some point in 3.2 kernel hibernation stop working (consistently). So I'm leaving this as solved, because it is not a Slack issue. I'll just have to wait until the kernel is fixed.

Hibernation and suspend were issues on laptops (mine, anyway) for a long time. Then the past few kernels/Slack releases solved those problems, and I hoped they were a thing of the past. I'm sad to see them back again.

Brian
 
Old 03-13-2012, 07:18 PM   #5
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
Hi!

I'm also having problems with hibernation after upgrading to slackware-current and Eric's kde-4.8.1.
I use nvidia card with proprietary drivers and kernel-generic-3.2.7. Hibernation sometimes works and sometimes doesn't. Logs show nothing.
Quote:
However I created a necessary initrd using option "mkinitrd -h /my/swap/partition" and added append="resume=/my/swap/partition" to /etc/lilo.conf.
Is adding -h option to mkinitrd REALLY necessary? Never used it and didn't have any issues so far (I use append line in lilo.conf though).
Anyway - is it possible that it's not a 3.2 kernel issue? Maybe some setting changes in kernel config between slackware-13.37 and current? Maybe it's memory related? I remember having similar problems long time ago when my swap partition was smaller - now it's twice the size of my physical RAM. Just my thoughts...
Anyone has an idea what could it be?

Regards

alekow
 
Old 03-23-2012, 02:52 PM   #6
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
It doesn't have anything to do with kde. It is kernel related. There are bugs reported for other distros regarding this.

The problem does have something to do with memory in a way, as it seems to relate to the size of the image to be written. On my laptop, below a point somewhere between 1.11G and 1.22G of memory usage (as reported by top) hibernation succeeds. Above that it fails. I have more than adequate space on the swap drive. This is on 3.2.11 (I've been kernel-chasing, waiting for the bug fix).

Brian

Last edited by BCarey; 03-23-2012 at 02:54 PM.
 
Old 03-23-2012, 02:55 PM   #7
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
Is there a way to change the subject of a thread?

Brian
 
Old 03-23-2012, 04:16 PM   #8
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
First of all - it would be nice if the thread wasn't marked [SOLVED], as it doesn't look like solved for me.

Anyway - the problem mysteriously went away and I don't know why. All I did (I think) was some cleaning in /var/tmp and maybe in /tmp which I made for some other reason.
 
Old 03-24-2012, 09:22 AM   #9
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
I marked it as solved at the point I thought it was solved. I left it as solved because the subject line is so misleading and the current problem has nothing to do with kde as the subject heading implies.

Brian
 
Old 03-26-2012, 01:06 PM   #10
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
As a work-around, flushing the memory cache makes it much more likely that hibernation will work. I created a file in /etc/pm/sleep.d with the following contents:

Code:
#!/bin/sh

clear_caches()
{
	sync
	echo 1 > /proc/sys/vm/drop_caches
}

case "$1" in
	suspend|hibernate)
		clear_caches
		;;
	resume|thaw)
		;;
	*) exit $NA
		;;
esac

Brian

Last edited by BCarey; 03-26-2012 at 01:08 PM.
 
2 members found this post helpful.
Old 03-30-2012, 09:11 PM   #11
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 133

Rep: Reputation: 19
Quote:
Originally Posted by BCarey View Post
...Hibernation on my laptop (HP Pavilion dv6) is still broken (although it works sometimes), but it looks like a kernel issue. I have found similar reports from fedora and Redhat that at some point in 3.2 kernel hibernation stop working (consistently). So I'm leaving this as solved, because it is not a Slack issue. I'll just have to wait until the kernel is fixed.
This is probably a kernel issue (subject line is a bit misleading). I use the hibernation function a lot and had a similar problem on a desktop and a laptop. In my case hibernation worked most of the time but froze every once in a while and pm-suspend.log showed no errors. The few times when this has happened, both machines had been suspended to RAM and then woken and used for a while before hibernation. Suspend to RAM always worked. I've compiled a custom 3.3 kernel based on a generic config with the fs stuff built in, and the problem seemed to disappear, then switched to the 3.2.13 kernel a couple days ago as I follow -current and sure enough it didn't take long before I got another freeze. I switched back to 3.3 and so far the problem hasn't occurred.
 
Old 05-14-2012, 06:08 PM   #12
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Rep: Reputation: 1
Quote:
Originally Posted by BCarey View Post
As a work-around, flushing the memory cache makes it much more likely that hibernation will work. I created a file in /etc/pm/sleep.d ...
Thanks for that! It seems to work very well. Normally I have about 20% success rate of hibernation, and with this workaround, it's run well twice in a row. FWIW I slightly altered the script, so that it logs (to /var/log/pm-suspend.log ) if the cache-flushing works. I also gave the file a low number (i.e. 00_flush_memory_caches), so it runs first.

Code:
#!/usr/bin/env bash

clear_caches()
{
	echo "free (pre-flush):"
	free
	sync
	echo 1 > /proc/sys/vm/drop_caches
	echo "Memory caches flushed (workaround to try and get hibernation working)"
	echo "free (post-flush):"
	free
}

case $1 in
	hibernate|suspend)
		clear_caches
		;;
	resume|thaw)
		true
		;;
esac
I'm not sure if this is related, but I occasionally wake up to a black screen, where I can still see and move my mouse cursor. This happened on S3 suspend, before I added this script. If anyone else is still having this problem, and you are using Ubuntu/Compiz, then you can try the following workarounds, in order of preference.

1) ctrl-alt-1 to open tty1 and then ctrl-alt-7 to shift back. (This occasionally works.)

2) ctrl-alt-1 to open tty1; log in; type
Code:
$ unity --replace
then ctrl-alt-7 again. (Assuming you are using Unity. This rarely works, but is worth a shot.)

3) As per this commment, ctrl-alt-1 to open tty1 (log in if not logged in yet); type
Code:
$ killall -KILL compiz
$ compiz --replace --display :0s
then ctrl-alt-7 again. You will not have a working window manager, so you won't be able to alt-tab, etc., but at least you can save your files. Then, I restart to get a working computer again. FWIW I also read somewhere that you might be able to kill compiz with SIGUSR1, but I've not tried it yet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
13.1 Beta1 :: KDE SC 4.4.3 :: pm-hibernate works, KDE hibernate just locks the screen zordrak Slackware 7 05-12-2010 03:55 AM
xfce suspend and hibernate permissions yakoub Slackware 1 10-29-2009 01:54 AM
Xfce 4.6 Suspend and Hibernate Function does not work properly with my notebook. phys Slackware 2 03-09-2009 05:46 PM
Hibernate in KDE on FC 6? ashesh0326 Linux - Software 2 05-07-2007 06:44 AM
KDE hibernate? microsoft/linux Linux - Laptop and Netbook 4 09-20-2005 08:41 AM


All times are GMT -5. The time now is 11:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration