LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-26-2008, 07:10 PM   #1
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 38
KDE Bluetooth dies


Any of you have experience with KDE Bluetooth? I have installed the
Slackbuild
on Slack 12.2, but it keeps crashing.
This is what I get:
Code:
~ $ kbluetooth 
kbluetooth: [KBluetooth::DBusSignal::DBusSignal(const QString&, const
QString&, const QString&, DBusConnection*)] : org.bluez
path: /org/bluez interface: org.bluez.Manager conn: 0x80da748
kbluetooth: [DBusMessage* KBluetooth::DBusSignal::newMessage(const
QString&)] : org.bluez path: /org/bluez mInterfacE: org.bluez.Manager
method: ListAdapters kbluetooth: libkbluetooth: getStringList(): A
security policy in place prevents this sender from sending this message
to this recipient, see message bus configuration file (rejected message
had interface "org.bluez.Manager" member "ListAdapters" error name
"(unset)" destination "org.bluez") kbluetooth: [QValueList<QString>
KBluetooth::Manager::listAdapters()] 0 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth:
[KBluetooth::DBusSignal::DBusSignal(const QString&, const QString&,
const QString&, DBusConnection*)] : org.bluez path: /org/bluez
interface: org.bluez.Security conn: 0x80da748 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Security method:
RegisterDefaultPasskeyAgent kbluetooth: libkbluetooth:
setString(RegisterDefaultPasskeyAgent): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Security" member "RegisterDefaultPasskeyAgent" error name
"(unset)" destination "org.bluez") kbluetooth:
[KBluetooth::DBusSignal::DBusSignal(const QString&, const QString&,
const QString&, DBusConnection*)] : org.bluez path: /org/bluez
interface: org.bluez.Security conn: 0x80da748 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Security method:
RegisterDefaultAuthorizationAgent kbluetooth: libkbluetooth:
setString(RegisterDefaultAuthorizationAgent): A security policy in
place prevents this sender from sending this message to this recipient,
see message bus configuration file (rejected message had interface
"org.bluez.Security" member "RegisterDefaultAuthorizationAgent" error
name "(unset)" destination "org.bluez") kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth: [QValueList<QString>
KBluetooth::Manager::listAdapters()] 0 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth: [QValueList<QString>
KBluetooth::Manager::listAdapters()] 0 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez")
This... somewhat blinds me. Has anyone used this? Any ideas?
I have tried writing to the maintainer, but have not received a response - and this is unlikely to be relevant anyway, since I got the same result with a package from Slacky.
 
Old 12-27-2008, 10:20 AM   #2
ivanrajkovic
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 1
Try changing your /etc/dbus-1/system.conf file, so that the rules for accepting replies (they are somewhere in the second part of the file) would be:
--------
<!-- allow sending valid replies -->
<allow send_requested_reply="true"/>
<!-- allow receiving valid replies -->
<allow receive_requested_reply="true"/>
-----------

and without rules with 'receive_type' in them.


after this, restart messagebus (maybe hal also) and bluetooth, and then start kbluetooth again, it should work.

i.
 
Old 12-28-2008, 02:04 PM   #3
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Original Poster
Rep: Reputation: 38
Thank you very much - this solved the problem.
Are there any security or other functionality implications of changing this setting?
 
Old 12-29-2008, 04:55 AM   #4
ivanrajkovic
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 1
I am not aware of any security problems with this, but there is always a probability. Also, I think that the problem with the bluetooth was caused by using the configuration for the latest dbus with the older version of the dbus shipped with slackware.
 
Old 01-25-2009, 11:14 AM   #5
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 659

Rep: Reputation: 38
Quote:
Originally Posted by ivanrajkovic View Post
Try changing your /etc/dbus-1/system.conf file, so that the rules for accepting replies (they are somewhere in the second part of the file) would be:
--------
<!-- allow sending valid replies -->
<allow send_requested_reply="true"/>
<!-- allow receiving valid replies -->
<allow receive_requested_reply="true"/>
-----------

and without rules with 'receive_type' in them.


after this, restart messagebus (maybe hal also) and bluetooth, and then start kbluetooth again, it should work.

i.
Thanks!
Worked for me too.
 
Old 01-25-2009, 06:25 PM   #6
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
Quote:
Originally Posted by ivanrajkovic View Post
I am not aware of any security problems with this, but there is always a probability. Also, I think that the problem with the bluetooth was caused by using the configuration for the latest dbus with the older version of the dbus shipped with slackware.
Yes there is, what that does is undo part of the fix for CVE-2008-4311.

http://lists.freedesktop.org/archive...er/010769.html

You need to edit your /etc/dbus-1/system.d/bluetooth.conf to look like
this and revert your /etc/dbus-1/system.conf back to stock:

Code:
<!-- This configuration file specifies the required security policies
     for Bluetooth core daemon to work. -->

<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>
 
Old 01-26-2009, 12:38 PM   #7
ivanrajkovic
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 1
This is now also in slackware-current, but it still doesn't work for me



Quote:
Originally Posted by XGizzmo View Post
Yes there is, what that does is undo part of the fix for CVE-2008-4311.

http://lists.freedesktop.org/archive...er/010769.html

You need to edit your /etc/dbus-1/system.d/bluetooth.conf to look like
this and revert your /etc/dbus-1/system.conf back to stock:

Code:
<!-- This configuration file specifies the required security policies
     for Bluetooth core daemon to work. -->

<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>
 
Old 02-17-2009, 07:16 PM   #8
brainycat
LQ Newbie
 
Registered: Feb 2009
Location: Seattle
Distribution: Slackware
Posts: 6

Rep: Reputation: 0
As an addendum, I would like to add that making the changes in /etc/dbus-1/system.conf did not work on my 12.2 installation. Adding the rules posted by XGizzmo to /etc/dbus-1/system.d/bluetooth inside the <policy context=default> container did the trick for me.
 
Old 02-24-2009, 08:10 AM   #9
uppman
Member
 
Registered: Jul 2008
Location: Stockholm, Sweden
Distribution: Slackware 13.1 32-bit
Posts: 145

Rep: Reputation: 24
Quote:
Originally Posted by ivanrajkovic View Post
This is now also in slackware-current, but it still doesn't work for me
Try to clear out some old stuff and restart everything again.

rfcomm release all

rm -r /var/lib/bluetooth/*
 
Old 03-13-2009, 04:35 PM   #10
justusjonas
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
It seems as if bluez-3 uses org.bluez.{PasskeyAgent,AuthorizationAgent} whereas bluez-4 uses org.bluez.Agent.

The following bluetoth.conf file is working under 12.2:

Code:
<!-- This configuration file specifies the required security policies
     for Bluetooth core daemon to work. -->

<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.PasskeyAgent"/>
    <allow send_interface="org.bluez.AuthorizationAgent"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>
Greetings,

justusjonas

EDIT: I have already filed a bug report.

Last edited by justusjonas; 03-13-2009 at 04:39 PM.
 
Old 03-28-2009, 10:11 AM   #11
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Hello everyone,
I tried all the suggestions in the thread for my 12.2 installation but no luck. Any more advice out there?
 
Old 03-29-2009, 01:46 AM   #12
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 213

Rep: Reputation: 43
I also tried everything here with no luck.
But i use kde4.2 on 12.2 if that matters. (the latest kde that worked ok with 12.2 from current)

Last edited by Nille_kungen; 04-05-2009 at 03:31 PM.
 
Old 04-03-2009, 06:40 AM   #13
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Quote:
Originally Posted by brainycat View Post
As an addendum, I would like to add that making the changes in /etc/dbus-1/system.conf did not work on my 12.2 installation. Adding the rules posted by XGizzmo to /etc/dbus-1/system.d/bluetooth inside the <policy context=default> container did the trick for me.
Braynycat - I wonder if you could explain exactly what you did. I'm not having any luck out here. Thanks
 
Old 08-04-2009, 10:45 PM   #14
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
For those who are having problems still, I can get kdebluetooth working on 12.2 by using the 12.1 config file /etc/dbus-1/system.d/bluetooth.conf.
 
  


Reply

Tags
bluetooth, kde, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kde file/device protocol dies... bai_design Linux - Software 3 06-11-2008 11:13 PM
kde dies right after login santana Linux - Desktop 4 04-05-2008 07:36 AM
if qemu dies, my mouse dies with it eantoranz Linux - Software 3 11-02-2007 10:30 PM
Fedora Core 5 - Network Dies When KDE Starts gmcmaster Linux - Networking 4 04-07-2006 03:38 PM
x server dies...dies...dead! aquaboot Linux - Software 2 08-28-2005 11:54 AM


All times are GMT -5. The time now is 03:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration