LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE Bluetooth dies (http://www.linuxquestions.org/questions/slackware-14/kde-bluetooth-dies-693167/)

mjjzf 12-26-2008 08:10 PM

KDE Bluetooth dies
 
Any of you have experience with KDE Bluetooth? I have installed the
Slackbuild
on Slack 12.2, but it keeps crashing.
This is what I get:
Code:

~ $ kbluetooth
kbluetooth: [KBluetooth::DBusSignal::DBusSignal(const QString&, const
QString&, const QString&, DBusConnection*)] : org.bluez
path: /org/bluez interface: org.bluez.Manager conn: 0x80da748
kbluetooth: [DBusMessage* KBluetooth::DBusSignal::newMessage(const
QString&)] : org.bluez path: /org/bluez mInterfacE: org.bluez.Manager
method: ListAdapters kbluetooth: libkbluetooth: getStringList(): A
security policy in place prevents this sender from sending this message
to this recipient, see message bus configuration file (rejected message
had interface "org.bluez.Manager" member "ListAdapters" error name
"(unset)" destination "org.bluez") kbluetooth: [QValueList<QString>
KBluetooth::Manager::listAdapters()] 0 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth:
[KBluetooth::DBusSignal::DBusSignal(const QString&, const QString&,
const QString&, DBusConnection*)] : org.bluez path: /org/bluez
interface: org.bluez.Security conn: 0x80da748 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Security method:
RegisterDefaultPasskeyAgent kbluetooth: libkbluetooth:
setString(RegisterDefaultPasskeyAgent): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Security" member "RegisterDefaultPasskeyAgent" error name
"(unset)" destination "org.bluez") kbluetooth:
[KBluetooth::DBusSignal::DBusSignal(const QString&, const QString&,
const QString&, DBusConnection*)] : org.bluez path: /org/bluez
interface: org.bluez.Security conn: 0x80da748 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Security method:
RegisterDefaultAuthorizationAgent kbluetooth: libkbluetooth:
setString(RegisterDefaultAuthorizationAgent): A security policy in
place prevents this sender from sending this message to this recipient,
see message bus configuration file (rejected message had interface
"org.bluez.Security" member "RegisterDefaultAuthorizationAgent" error
name "(unset)" destination "org.bluez") kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth: [QValueList<QString>
KBluetooth::Manager::listAdapters()] 0 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez") kbluetooth: [QValueList<QString>
KBluetooth::Manager::listAdapters()] 0 kbluetooth: [DBusMessage*
KBluetooth::DBusSignal::newMessage(const QString&)] : org.bluez
path: /org/bluez mInterfacE: org.bluez.Manager method: ListAdapters
kbluetooth: libkbluetooth: getStringList(): A security policy in place
prevents this sender from sending this message to this recipient, see
message bus configuration file (rejected message had interface
"org.bluez.Manager" member "ListAdapters" error name "(unset)"
destination "org.bluez")

This... somewhat blinds me. Has anyone used this? Any ideas?
I have tried writing to the maintainer, but have not received a response - and this is unlikely to be relevant anyway, since I got the same result with a package from Slacky.

ivanrajkovic 12-27-2008 11:20 AM

Try changing your /etc/dbus-1/system.conf file, so that the rules for accepting replies (they are somewhere in the second part of the file) would be:
--------
<!-- allow sending valid replies -->
<allow send_requested_reply="true"/>
<!-- allow receiving valid replies -->
<allow receive_requested_reply="true"/>
-----------

and without rules with 'receive_type' in them.


after this, restart messagebus (maybe hal also) and bluetooth, and then start kbluetooth again, it should work.

i.

mjjzf 12-28-2008 03:04 PM

Thank you very much - this solved the problem.
Are there any security or other functionality implications of changing this setting?

ivanrajkovic 12-29-2008 05:55 AM

I am not aware of any security problems with this, but there is always a probability. Also, I think that the problem with the bluetooth was caused by using the configuration for the latest dbus with the older version of the dbus shipped with slackware.

adriv 01-25-2009 12:14 PM

Quote:

Originally Posted by ivanrajkovic (Post 3388529)
Try changing your /etc/dbus-1/system.conf file, so that the rules for accepting replies (they are somewhere in the second part of the file) would be:
--------
<!-- allow sending valid replies -->
<allow send_requested_reply="true"/>
<!-- allow receiving valid replies -->
<allow receive_requested_reply="true"/>
-----------

and without rules with 'receive_type' in them.


after this, restart messagebus (maybe hal also) and bluetooth, and then start kbluetooth again, it should work.

i.

Thanks!
Worked for me too. :)

XGizzmo 01-25-2009 07:25 PM

Quote:

Originally Posted by ivanrajkovic (Post 3390161)
I am not aware of any security problems with this, but there is always a probability. Also, I think that the problem with the bluetooth was caused by using the configuration for the latest dbus with the older version of the dbus shipped with slackware.

Yes there is, what that does is undo part of the fix for CVE-2008-4311.

http://lists.freedesktop.org/archive...er/010769.html

You need to edit your /etc/dbus-1/system.d/bluetooth.conf to look like
this and revert your /etc/dbus-1/system.conf back to stock:

Code:

<!-- This configuration file specifies the required security policies
    for Bluetooth core daemon to work. -->

<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>


ivanrajkovic 01-26-2009 01:38 PM

This is now also in slackware-current, but it still doesn't work for me :(



Quote:

Originally Posted by XGizzmo (Post 3421106)
Yes there is, what that does is undo part of the fix for CVE-2008-4311.

http://lists.freedesktop.org/archive...er/010769.html

You need to edit your /etc/dbus-1/system.d/bluetooth.conf to look like
this and revert your /etc/dbus-1/system.conf back to stock:

Code:

<!-- This configuration file specifies the required security policies
    for Bluetooth core daemon to work. -->

<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>



brainycat 02-17-2009 08:16 PM

As an addendum, I would like to add that making the changes in /etc/dbus-1/system.conf did not work on my 12.2 installation. Adding the rules posted by XGizzmo to /etc/dbus-1/system.d/bluetooth inside the <policy context=default> container did the trick for me.

uppman 02-24-2009 09:10 AM

Quote:

Originally Posted by ivanrajkovic (Post 3421858)
This is now also in slackware-current, but it still doesn't work for me :(

Try to clear out some old stuff and restart everything again.

rfcomm release all

rm -r /var/lib/bluetooth/*

justusjonas 03-13-2009 05:35 PM

It seems as if bluez-3 uses org.bluez.{PasskeyAgent,AuthorizationAgent} whereas bluez-4 uses org.bluez.Agent.

The following bluetoth.conf file is working under 12.2:

Code:

<!-- This configuration file specifies the required security policies
    for Bluetooth core daemon to work. -->

<busconfig>

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy user="root">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.PasskeyAgent"/>
    <allow send_interface="org.bluez.AuthorizationAgent"/>
  </policy>

  <policy at_console="true">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>

Greetings,

justusjonas

EDIT: I have already filed a bug report.

brixtoncalling 03-28-2009 11:11 AM

Hello everyone,
I tried all the suggestions in the thread for my 12.2 installation but no luck. Any more advice out there?

Nille_kungen 03-29-2009 02:46 AM

I also tried everything here with no luck.
But i use kde4.2 on 12.2 if that matters. (the latest kde that worked ok with 12.2 from current)

brixtoncalling 04-03-2009 07:40 AM

Quote:

Originally Posted by brainycat (Post 3447637)
As an addendum, I would like to add that making the changes in /etc/dbus-1/system.conf did not work on my 12.2 installation. Adding the rules posted by XGizzmo to /etc/dbus-1/system.d/bluetooth inside the <policy context=default> container did the trick for me.

Braynycat - I wonder if you could explain exactly what you did. I'm not having any luck out here. Thanks

brixtoncalling 08-04-2009 11:45 PM

For those who are having problems still, I can get kdebluetooth working on 12.2 by using the 12.1 config file /etc/dbus-1/system.d/bluetooth.conf.


All times are GMT -5. The time now is 11:27 PM.