LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-05-2009, 06:55 PM   #1
akschu
LQ Newbie
 
Registered: Dec 2007
Posts: 16

Rep: Reputation: 0
KDE 4 in slackware 13 isn't stable. Random Crashes


I just installed a fresh slackware 13 on my laptop. I got everything going without too much trouble (I've been using slackware since 99) however, KDE isn't very stable. I've had it crash on me 3 times in the last day and that just isn't going to cut it for a work computer.

I like the interface and don't want to abandon it, so the question is how do I debug it? Normally I would just switch to the console and look at the output, but this thing generates a ton of output just starting up so I'm not sure what is related to the crash and what isn't.

Can anyone point me to some information on how to debug this?

Does anyone else have stability issues with KDE 4.2.4?

Thanks,
schu
 
Old 09-05-2009, 07:09 PM   #2
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 541

Rep: Reputation: 74
What kind of card do you have on your laptop and what driver?
Generally, there are about a thousand reasons why things are not behaving stable, but the card + driver combination is one that seems to happen most of the time. (from my experience), mostly this issue seems to be with some Intel cards, and patches exist for those, the thing is: this goldfish memory didn't memorize as I don't have intel cards myself.
 
Old 09-06-2009, 02:24 AM   #3
akschu
LQ Newbie
 
Registered: Dec 2007
Posts: 16

Original Poster
Rep: Reputation: 0
It's a Nvidia GeForce Go 7300.

I suspect something to do with the video driver as well.

After the installation I tried to load a youtube video, and full screen it, which instantly crashed firefox. I found that the latest nightly build of firefox (3.5.4pre) doesn't crash so I started using it, now everything works fine.

It appears I have a similar problem with KDE, so I started snooping around for nvidia kde bugs and found a few pages like this:

http://forum.kde.org/viewtopic.php?f=111&t=33893

I have now turned off BackingStore and so far no crashes, but I'm not certain that it did anything because I didn't ever have BackingStore on, nor do I know what the default is.

I've been using linux for many years, but these issues with proprietary video drivers are getting pretty old. It used to be that nvidia was good and sure to work, I guess that isn't the case anymore.

schu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Random wallpaper or script to create symbolic links to random files cvelasquez Linux - Software 2 02-26-2007 06:48 PM
KDE desktop crashes on mepis over slackware JoeFisher57 Linux - Software 5 08-27-2006 08:10 PM
Crashes on Slackware 10 after upgrading to KDE 3.3 ambayah Slackware 9 08-31-2004 01:36 AM
xmms used to be stable, but now crashes sterrenkijker Debian 5 08-06-2004 02:00 AM
Random program crashes in Linux, is fedora not stable? xbennyboy Linux - Newbie 13 08-05-2004 11:15 AM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration