LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-11-2012, 11:11 AM   #1
Electromaniac
LQ Newbie
 
Registered: Sep 2011
Distribution: Slackware
Posts: 15

Rep: Reputation: Disabled
KDE 4.8.1 Wicd configuration and 'unnamed' bug


I have installed AlienBOB's KDE 4.8.1 packages on laptop Sony Vaio PCG-K35 with 512 MB RAM. It works very fast. Only problem is setting a wireless connection and unnamed bug, where instead of Desktop stands 'unnamed'. Wlan is recognized and led is on. When I go to wicd options, Wireless is grayed out. I can select wlan0 for wireless and eth0 and then after applying and opening wicd configuration again, interfaces are deselected. I also added wicd to tray. Applet says that wicd daemon is not running. What should I do? Maybe try networkmanager from testing folder? I use WEP encryption to connect to home network, so wpa_supplicant is not a problem.
Second problem is that instead of Desktop in upper right corner there is a button unnamed. It acts ok, I can add widgets, panels etc. But it is annoying. How to fix it?
About wlan adapter: I think it is Atheros card, it is integrated in laptop. I tried Ubuntu, it worked out of box, also for other distros, so I think that additional drivers are not needed.
Thanks in advance.

Last edited by Electromaniac; 03-11-2012 at 11:13 AM.
 
Old 03-11-2012, 11:26 AM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,253

Rep: Reputation: 181Reputation: 181
Try NetworkManager. I can't give you specifics, but I did recently try them both, going back and forth between the two, over a couple of days, and NetworkManager just does a better job. It sees more networks in the area and has less trouble making the connection. There have been times when Wicd reported there are no networks available, including the one I use, and I know for a fact that just wasn't true. At any given time there are 15 to 20 or more networks up and running 24 hours a day in my immediate area.

Last edited by cwizardone; 03-11-2012 at 11:28 AM.
 
Old 03-11-2012, 11:43 AM   #3
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Applet says that wicd daemon is not running. What should I do?
Start wicd daemon?
Quote:
But it is annoying. How to fix it?
What is annoying?
What do you want to fix?

Kind regards
 
Old 03-11-2012, 01:01 PM   #4
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 193

Rep: Reputation: 6
@Electromaniac
you have to make rc.wicd executable
chmod +x rc.wicd ( in /etc/rc.d/ )
Sorry typing from my phone
Regards
Lawrence
 
Old 03-11-2012, 01:03 PM   #5
Electromaniac
LQ Newbie
 
Registered: Sep 2011
Distribution: Slackware
Posts: 15

Original Poster
Rep: Reputation: Disabled
@repo where it should be located? I found rc.networkmanager in rc.d but there is no file named wicd.
Annoying is my second problem. Default activity Desktop is titled as unnamed, so I want to rename this. I solved a problem by creating an empty activity.
 
Old 03-11-2012, 01:09 PM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
It should be in etc/rc.d/
How did you install wicd?
Did it worked before?

Kind regards
 
Old 03-11-2012, 03:02 PM   #7
Buumi
Member
 
Registered: Dec 2010
Distribution: Slackware
Posts: 54

Rep: Reputation: 6
That might be a silly question but did you actually install Wicd?
Alienbob's KDE 4.8.1 has an applet for controlling Wicd but you need to install Wicd first from Slackware's /extra directory.

Last edited by Buumi; 03-11-2012 at 03:05 PM.
 
Old 03-11-2012, 06:06 PM   #8
Electromaniac
LQ Newbie
 
Registered: Sep 2011
Distribution: Slackware
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks for reply. I played around a little and added rc.networkmanager to rc.local. Now I have everything set up. Wicd was freezing and then it kills my wireless radio until I restart. Also networkmanager finds networks excellent, better works than wicd. Thanks everyone for replies.
Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] wicd KDE dependencies VisionIncision Slackware 1 12-24-2011 07:14 AM
WICD configuration problem DimaNovo Linux - Software 3 03-24-2010 03:21 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 01:15 PM
[SOLVED] xorg.conf configuration bug dracuss Debian 2 10-23-2009 06:00 AM
K3b Configuration Bug? sher07 Linux - Software 2 01-15-2004 03:52 AM


All times are GMT -5. The time now is 01:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration