LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-13-2009, 09:34 AM   #1
agentgrape
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Rep: Reputation: 0
KDE 4.2 testing.


I had been using the KDE 4.1 from testing and decided to install 4.2.

I used the removal scripts to remove 4.1 and added 4.2 as per the same method for 4.1 in the readme.

The problem I am having is on startup kde brings up and error log for Akonadi server Everything is fine in the log up till the 9th checkbox where it errors with Akonadi control process not registered at D-Bus.

I have looked at several other forums for this issue none seem to have a resolution that applies.

This is a very vanilla Slackware install by a novice, all that has been done is adding the nvidia drivers from the nvidia site, and installing kde 4.1, then 4.2.
 
Old 02-13-2009, 11:43 AM   #2
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
Have you followed the right tutorial and all that the README says? For example, did you delete the .kde directory? Did you back up the /etc/kde dir? Follow it again:

http://slackware.osuosl.org/slackwar...es/kde4/README

And you've to make sure that your steps are right.
 
Old 02-13-2009, 12:00 PM   #3
agentgrape
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
when doing the initial setup for kde 4.1 i removed all packages relating to KDE and QT as per the instructions using packagetool, I then also ran the included KDE3 removal script, then installed 4.1 as per the readme. I then removed the kde3 settings file, configured X to use kde and went in. 4.1 worked seemingly 100%.

For 4.2 I ran the included kde 4 removal script, as I was already running 4.1. Then installed the package as per the same command line option that the 4.1 install used, deleted the settings file as before and set X to use KDE then started it up. Have gotten the Akonadi error consistently since first run.

I have verified that I followed the instructions to a tee and still I get the same results, crash of Akonadi on start. This is the error log.

Akonadi Server Self-Test Report
===============================

Test 1: SUCCESS
--------

Database driver found.
Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration.
The following drivers are installed: QSQLITE, QMYSQL3, QMYSQL.
Make sure the required driver is installed.

File content of '/root/.config/akonadi/akonadiserverrc':
[%General]
Driver=QMYSQL

[QMYSQL]
Name=akonadi
User=
Password=
Options="UNIX_SOCKET=/root/.local/share/akonadi/db_misc/mysql.socket"
ServerPath=/usr/libexec/mysqld
StartServer=true


Test 2: SUCCESS
--------

MySQL server found.
Details: You currently have configured Akonadi to use the MySQL server '/usr/libexec/mysqld'.
Make sure you have the MySQL server installed, set the correct path and ensure you have the necessary read and execution rights on the server executable. The server executable is typically called 'mysqld', its locations varies depending on the distribution.

Test 3: SUCCESS
--------

MySQL server is executable.
Details: MySQL server found: 090213 14:33:24 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090213 14:33:24 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
/usr/libexec/mysqld Ver 5.0.67 for slackware-linux-gnu on i486 (Source distribution)


Test 4: SUCCESS
--------

No current MySQL error log found.
Details: The MySQL server did not report any errors during this startup into '/root/.local/share/akonadi/db_data/mysql.err'.

Test 5: SUCCESS
--------

MySQL server default configuration found.
Details: The default configuration for the MySQL server was found and is readable at <a href='/usr/share/config/akonadi/mysql-global.conf'>/usr/share/config/akonadi/mysql-global.conf</a>.

File content of '/usr/share/config/akonadi/mysql-global.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_use r,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes _as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 6: SKIP
--------

MySQL server custom configuration not available.
Details: The custom configuration for the MySQL server was not found but is optional.

Test 7: SUCCESS
--------

MySQL server configuration is usable.
Details: The MySQL server configuration was found at <a href='/root/.local/share/akonadi/mysql.conf'>/root/.local/share/akonadi/mysql.conf</a> and is readable.

File content of '/root/.local/share/akonadi/mysql.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp <kris@mysql.com>
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_use r,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes _as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 8: SUCCESS
--------

akonadictl found and usable
Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found and could be executed successfully.
Result:
Akonadi Control: stopped
Akonadi Server: stopped


Test 9: ERROR
--------

Akonadi control process not registered at D-Bus.
Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 10: ERROR
--------

Akonadi server process not registered at D-Bus.
Details: The Akonadi server process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.

Test 11: SKIP
--------

Protocol version check not possible.
Details: Without a connection to the server it is not possible to check if the protocol version meets the requirements.

Test 12: ERROR
--------

No resource agents found.
Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents /usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/usr/share:/usr/local/share', make sure this includes all paths where Akonadi agents are installed to.

Directory listing of '/usr/share/akonadi/agents':
distlistresource.desktop
icalresource.desktop
imaplibresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
mailthreaderagent.desktop
nepomukcontactfeeder.desktop
nepomukemailfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
strigifeeder.desktop
vcarddirresource.desktop
vcardresource.desktop
Directory listing of '/usr/share/akonadi/agents':
distlistresource.desktop
icalresource.desktop
imaplibresource.desktop
kabcresource.desktop
kcalresource.desktop
knutresource.desktop
localbookmarksresource.desktop
maildirresource.desktop
mailthreaderagent.desktop
nepomukcontactfeeder.desktop
nepomukemailfeeder.desktop
nepomuktagresource.desktop
nntpresource.desktop
strigifeeder.desktop
vcarddirresource.desktop
vcardresource.desktop

Environment variable XDG_DATA_DIRS is set to '/usr/share:/usr/share:/usr/local/share'

Test 13: ERROR
--------

Current Akonadi server error log found.
Details: The Akonadi server did report error during startup into <a href='/root/.local/share/akonadi/akonadiserver.error'>/root/.local/share/akonadi/akonadiserver.error</a>.

File content of '/root/.local/share/akonadi/akonadiserver.error':
Database process existed unexpectedly during intial connection!
executable: "/usr/libexec/mysqld"
arguments: ("--defaults-file=/root/.local/share/akonadi//mysql.conf", "--datadir=/root/.local/share/akonadi/db_data/", "--socket=/root/.local/share/akonadi/db_misc/mysql.socket")
stdout: ""
stderr: "090213 14:33:22 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090213 14:33:22 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090213 14:33:22 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

090213 14:33:22 [ERROR] Aborting

090213 14:33:22 [Note] /usr/libexec/mysqld: Shutdown complete

"
exit code: 1
process error: "Unknown error"
"[
0: akonadiserver(_Z10kBacktracev+0x35) [0x8050ba5]
1: akonadiserver [0x805107e]
2: [0xffffe400]
3: /lib/libc.so.6(gsignal+0x46) [0xb77bfc66]
4: /lib/libc.so.6(abort+0x101) [0xb77c1571]
5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x87) [0xb7b340c7]
6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc3) [0x8051f03]
7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x96) [0xb7bc0ec6]
8: /usr/lib/libQtCore.so.4 [0xb7bcc21c]
9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x68) [0xb7bcc618]
10: akonadiserver(_ZN6QDebugD1Ev+0x40) [0x804d5e0]
11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x1b7f) [0xb7ed997f]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x72) [0xb7edc732]
13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x55) [0xb7eddc15]
14: akonadiserver(main+0x25a) [0x804c96a]
15: /lib/libc.so.6(__libc_start_main+0xe0) [0xb77ab390]
16: akonadiserver [0x804c671]
]
"


Test 14: ERROR
--------

Previous Akonadi server error log found.
Details: The Akonadi server did report error during its previous startup into <a href='/root/.local/share/akonadi/akonadiserver.error.old'>/root/.local/share/akonadi/akonadiserver.error.old</a>.

File content of '/root/.local/share/akonadi/akonadiserver.error.old':
Database process existed unexpectedly during intial connection!
executable: "/usr/libexec/mysqld"
arguments: ("--defaults-file=/root/.local/share/akonadi//mysql.conf", "--datadir=/root/.local/share/akonadi/db_data/", "--socket=/root/.local/share/akonadi/db_misc/mysql.socket")
stdout: ""
stderr: "090213 14:33:22 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090213 14:33:22 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090213 14:33:22 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

090213 14:33:22 [ERROR] Aborting

090213 14:33:22 [Note] /usr/libexec/mysqld: Shutdown complete

"
exit code: 1
process error: "Unknown error"
"[
0: akonadiserver(_Z10kBacktracev+0x35) [0x8050ba5]
1: akonadiserver [0x805107e]
2: [0xffffe400]
3: /lib/libc.so.6(gsignal+0x46) [0xb779ac66]
4: /lib/libc.so.6(abort+0x101) [0xb779c571]
5: /usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x87) [0xb7b0f0c7]
6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xc3) [0x8051f03]
7: /usr/lib/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x96) [0xb7b9bec6]
8: /usr/lib/libQtCore.so.4 [0xb7ba721c]
9: /usr/lib/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x68) [0xb7ba7618]
10: akonadiserver(_ZN6QDebugD1Ev+0x40) [0x804d5e0]
11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x1b7f) [0xb7eb497f]
12: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x72) [0xb7eb7732]
13: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x55) [0xb7eb8c15]
14: akonadiserver(main+0x25a) [0x804c96a]
15: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7786390]
16: akonadiserver [0x804c671]
]
"


Test 15: SUCCESS
--------

No current Akonadi control error log found.
Details: The Akonadi control process did not report any errors during its current startup.

Test 16: SUCCESS
--------

No previous Akonadi control error log found.
Details: The Akonadi control process did not report any errors during its previous startup.

Last edited by agentgrape; 02-13-2009 at 03:35 PM.
 
Old 02-13-2009, 07:44 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,400

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
I think you should check that you have all necessary packages installed. I suggest that you try slackpkg.

First uncomment a suitable mirror for slackware-current in /etc/slackpkg/mirrors and then make these changes to your /etc/slackpkg/slackpkg.conf file
Code:
# The lines below will set the download priority. 
# Default values: /patches /slackware /extra /pasture /testing
#FIRST=patches
#SECOND=slackware
#THIRD=extra
#FOURTH=pasture
#FIFTH=testing
## My defaults for supporting KDE4 in /testing
FIRST=patches
SECOND=testing
THIRD=slackware
FOURTH=extra
FIFTH=pasture
Then run (as root):
slackpkg update
slackpkg install-new
slackpkg upgrade-all
slackpkg clean-system

This should bring your install into line with Slackware-current.
 
Old 02-14-2009, 02:52 AM   #5
KillerOfGiants
LQ Newbie
 
Registered: Feb 2004
Location: BG
Distribution: Slackware-current
Posts: 29

Rep: Reputation: 15
This is because you are running kde as root. Try with different user. I think rworkman made a statement about it in this forum that its because mysql+root=no go, for security reasons. I hope they fix it because its extremely annoying.
 
Old 02-14-2009, 03:39 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
Is dBus running ?

Just in case...

I would make sure dBus is running:
Code:
bash-3.1$ ps ax|grep dbus
 3257 ?        Ss     0:00 /usr/bin/dbus-daemon --system
 4128 pts/0    S+     0:00 grep dbus
bash-3.1$
If not, of course:
Code:
/etc/rc.d/rc.messagebus start
 
Old 02-14-2009, 04:26 PM   #7
agentgrape
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by KillerOfGiants View Post
This is because you are running kde as root. Try with different user. I think rworkman made a statement about it in this forum that its because mysql+root=no go, for security reasons. I hope they fix it because its extremely annoying.

Starting akonadictl from command line kind of confirms that is the problem, it errors out and at some point in the message says something about running mysql as root.

This sucks, it means I am kind of stuck living with it since our software development made the scripts I need to use on my Slackware machine in such a way that using a root account is a must to execute them.

Since I am not even going to go there trying to get them to rewrite them I guess I will have to live with broken akonadi unless there is a way to make it and mysql all copacetic on a root account.

Unless now that I think of it... I only need to run those scripts from command line so perhaps I could use a terminal to log in as root and set up a standard user account to run X.

I am kind of a neophyte to Linux in general, is it possible to use a konsole terminal window from within KDE on a standard user account as root? Or will it be necessary to actually use a terminal IE ctrl alt f2. The problem is the scripts in question call up resources that are stored under /

I would just try it out but it will have to wait till tuesday to be back at work.

Last edited by agentgrape; 02-14-2009 at 04:32 PM.
 
Old 02-14-2009, 09:20 PM   #8
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 211

Rep: Reputation: 43
You should never run kde as root.
If you run it as user then you kan open an terminal in kde and 'su -' to become root in that shell/session.
 
Old 02-15-2009, 03:14 AM   #9
KillerOfGiants
LQ Newbie
 
Registered: Feb 2004
Location: BG
Distribution: Slackware-current
Posts: 29

Rep: Reputation: 15
Let me quote a fellow slacker from this forum:

P.S. Oh and puhleeze: Don't preach to me or share your religion about running X as root. Take a long walk on a short pier. Kiss off. FOAD. GTFO. Blow smoke. Stick it where the sun doesn't shine. In your ear with a can of beer. Etc., etc. If I had mental issues about running as root I would not be using Slackware. I'd use Ubuntu and sudo myself into the insane asylum. But thanks for caring.

I dont mean to offend anyone, but running as root is my choice.
 
Old 02-15-2009, 03:23 AM   #10
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
The option is yours of course but please don't trivialise the important security implications of running as root.

We give this advice for very good reasons and such a gung-ho approach to security should be discouraged.
 
Old 02-15-2009, 03:58 AM   #11
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 160Reputation: 160
Quote:
Originally Posted by KillerOfGiants View Post
I dont mean to offend anyone, but running as root is my choice.
Firstly, running as root has nothing to do with this problem. I had the exact same problem running KDE 4.2 from a clean user account set up especially for this purpose on a clean installation of Slackware 12.2.

Secondly, there is no need to run as root unless you can't figure out how to add a user or have some weird political bias carried forward from Windows 98.

Thirdly, where is it written that Slackware encourages use of the root account? I think it's quite the opposite, actually:

Quote:
Originally Posted by Patrick Volkerding in the Slackware-HOWTO on your installation CD
"6.4 User Accounts

You should make a user account for yourself. Using "root" as your
everyday account is dangerous, and is considered bad form (at the very
least) since you can accidentally damage your system if you mistype a
command. If you're logged in as a normal user, the effects of bad
commands will be much more limited. Normally you'll only log in as root
to perform system administration tasks, such as setting or changing the
root password, installing, configuring, or removing system software, and
creating or deleting user accounts.

To make an account for yourself, use the 'adduser' program."
 
Old 02-15-2009, 04:46 AM   #12
KillerOfGiants
LQ Newbie
 
Registered: Feb 2004
Location: BG
Distribution: Slackware-current
Posts: 29

Rep: Reputation: 15
Quote:
Originally Posted by rkelsen View Post
Firstly, running as root has nothing to do with this problem. I had the exact same problem running KDE 4.2 from a clean user account set up especially for this purpose on a clean installation of Slackware 12.2.

Secondly, there is no need to run as root unless you can't figure out how to add a user or have some weird political bias carried forward from Windows 98.

Thirdly, where is it written that Slackware encourages use of the root account? I think it's quite the opposite, actually:
Firstly i had the exact same problem witch solved with running KDE as a different user. PV made a statement about it. I don't remember much of it but it ended saying something like (KDE should not be ran as root anyway)
Quote:
So, this is kde-4.2 rc 1. Testing so far has shown few problems, and it
looks to us like KDE 4.2 will be a very good and stable release, and will
more than likely be merged into the main Slackware tree. The only gotcha
noticed so far is that akonadi will not work properly until D-Bus has been
restarted (either reboot, or run "/etc/rc.d/rc.messagebus restart" after
installing these packages with upgradepkg --install-new. Also, akonadi will
not run for the root user due to security concerns with MySQL, but KDE
probably should not be run as root anyway. I mention it here because the
error message about "QtSQL" is rather cryptic and does not make it all that
clear what the reason is that akonadi does not start.
Yes there is a need. I'm LAZY. I don't want to type root password 10 times a day.

Thirdly. Slackware encourages non use of root. Now, I'm not a native speaker, but encourages it is not a strong form. And in the quote you made from PV, there is nothing saying about security, its about misspelling commands. Now I KNOW ITS LESS SECURE. MUCH LESS. OK? I lot of people are running windows. Go kill em.

Last edited by KillerOfGiants; 02-15-2009 at 04:56 AM.
 
Old 02-15-2009, 11:16 AM   #13
agentgrape
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
You do have to run as root when your companies software development tells you that you have to because their stuff is written in such a way that you must.

I wasn't however looking for a debate as to whether running as root is good or bad I was looking for a solution to my issue.

If anyone has that and has actually experienced this problem running on a non root user account as well, it would be far more appreciated to hear the solution than a lecture about running as root.
 
Old 02-15-2009, 12:59 PM   #14
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 241

Rep: Reputation: 86
Quote:
Originally Posted by KillerOfGiants View Post
I don't want to type root password 10 times a day.
This line as /etc/suauth makes amy su to root without password:

Code:
root:amy:NOPASS
 
Old 02-15-2009, 01:18 PM   #15
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
Run as root is dangerous, and I can tell you why it's so dangerous.


1-Some commands you might type with some values could be dangerous for a beginner and for an expert.
2-If you run the D.E. as root and so the programs too, it's probable you start the browser as root, and if there are malicious coded which work on linux too, you'll get them without any problem, causing problems(big ones sometimes).
3-Browsing the PC, looking at Hard Disks, looking at other resources you might delete important system's files inside the hard disks.
4-Editing important docs and configuration files as root could be very dangerous, if you wrongly save them forgetting a thing you had to do(it could happen, I'm here ).
5-If you leave PC for a while and you have a joker friend he could fuck your PC(and excuse me for the bad word). Could happen, why not LOL(it came out in my mind right now, sincerely I had a problem like this but not with PC, but with my iPhone, leaving it with the terminal open as root he removed me everything(how I'm unfortunate?)
6-There could be dangerous scripts or programming errors, such as the fact of the slackware package in the ubuntu's repository who contained the rm -rf $CACHE command which has the same power of "rm -rf /", any way, if you already know that the script wants super-user powers you run it as root and the problem is not solved, this is not a good excuse but it can count.

However, if he wants to run as root, he can do it, without any problem for me and for you, just for him.

Last edited by metrofox; 02-15-2009 at 03:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Testing Fedora 10 KDE Edition LXer Syndicated Linux News 0 12-02-2008 04:40 AM
KDE (system) notifications not working (KDE 3.5.8)(Debian:Testing Branch)) kevinbenko Linux - Desktop 2 03-30-2008 12:15 PM
Can xfce4 and kde play together on testing/etch? arobinson74 Debian 5 08-20-2006 07:14 PM
KDE and Gnome freezes at startup (testing) Ephracis Debian 2 01-07-2006 04:20 PM
Gnome menu mixed with KDE in Debian Testing Underhill Debian 1 09-14-2005 06:15 PM


All times are GMT -5. The time now is 07:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration