LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE 4.10 screensaver shows blank screen! (http://www.linuxquestions.org/questions/slackware-14/kde-4-10-screensaver-shows-blank-screen-4175450834/)

mattallmill 02-19-2013 01:34 PM

KDE 4.10 screensaver shows blank screen!
 
As I have mentioned in this thread, I have installed the new KDE 4.10 packages, and now I have another problem. When I turn off XScreensaver, and configure KDE's screensaver to display, the screen only blanks, and does not display what it's supposed to. Anyone have any idea why this is happening?

ppr:kut 02-22-2013 12:45 AM

What Qt widget style are you using? I got the same when I tried oxygen-transparent. Apparently the screenlocker doesn't take transparency too well, so if your theme used it too, you can try switching to one that doesn't.

mattallmill 02-22-2013 04:32 PM

Quote:

Originally Posted by ppr:kut (Post 4897229)
What Qt widget style are you using? I got the same when I tried oxygen-transparent. Apparently the screenlocker doesn't take transparency too well, so if your theme used it too, you can try switching to one that doesn't.

I thank you for your input, but I believe I have found what I believe to be the superior solution, albeit not in a way which I would have preferred. Pat pushed some updates to X in slackware-current. After utilizing slackpkg to download and upgrade these files, I found that my installation was totally hosed. X would not start, period. Fortunately, I made an image backup of my root partition (/dev/sda2) using dd, and was able to restore most of what I had lost, just minor stuff. As it turns out, KDE 4.9.5 was in that image, and I know that it does not suffer from the screen locker issue nor blanking. I think I'll stick with this setup until the outstanding bugs in 4.10.x are fixed to my satisfaction.


All times are GMT -5. The time now is 07:25 AM.