LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-16-2013, 12:46 PM   #1
a4z
Member
 
Registered: Feb 2009
Posts: 526

Rep: Reputation: 188Reputation: 188
KDE 4.10 alien on Slackware 14 dependency to cmake, a note


I write this more for a documentation purpose than as a bug report


I just found out that

/usr/share/apps/cmake/modules/FindKDE4Internal.cmake

which comes with kdelibs-4.10.0-x86_64-1alien

contains the line

cmake_minimum_required(VERSION 2.8.9 FATAL_ERROR)

and this makes it difficult (impossible) to build some kde applications that makes use of the module.
for example rekonq, what made me finding this problem

this is not a problem on slackware current or if no builds are done.

do not know what the kde guys thinking by doing this
looking at the cmake file makes me think that this is legacy code that is keep alive by adding what ever is needed for the current version, but of course this is just a personal impression after a first look into the file.

will see what happens if I patch the file to work also with cmake 2.8.8
 
Old 03-16-2013, 05:21 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,384

Rep: Reputation: Disabled
That is why in the KDE 4.10.1 tree I also added the newer cmake package which you need to compile these on Slackware 14.
http://taper.alienbase.nl/mirrors/al.../x86_64/tools/ (64-bit)
http://taper.alienbase.nl/mirrors/al...0.1/x86/tools/ (32-bit)

The cmake of slackware-current is new enough by the way, this update is only needed for Slackware 14.

Eric
 
Old 03-17-2013, 02:53 AM   #3
a4z
Member
 
Registered: Feb 2009
Posts: 526

Original Poster
Rep: Reputation: 188Reputation: 188
great , havn't seen that 4.10.1 exists also for Slackware 14.
thought I read that 4.10.1 it is only for current
thanks!
 
Old 03-17-2013, 04:32 AM   #4
a4z
Member
 
Registered: Feb 2009
Posts: 526

Original Poster
Rep: Reputation: 188Reputation: 188
did the update to 4.10.1 now and everything works like charm again.

thanks a lot for providing those packages!

you may want to add
upgradepkg --reinstall --install-new x86_64/tools/*.t?z
to the install/upgrade instructions in the readme file
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Building One KDE Component with CMake Trip in VA Programming 2 06-22-2011 01:46 AM
cmake: Using find_package(Boost) when FindBoost.cmake is not in the default location damien_d Programming 3 10-27-2010 04:40 PM
[SOLVED] Tovid and dependency (x264) - will it conflict alien bob's VLC dc_eros Slackware 2 06-10-2010 09:22 PM
KDE, Phonon, and CMake ryerke Slackware 11 11-18-2009 09:42 PM
LXer: The Road to KDE 4: CMake, a New Build System for KDE LXer Syndicated Linux News 0 02-22-2007 10:31 AM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration