LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE 4.1.3 on laptop and hibernate (http://www.linuxquestions.org/questions/slackware-14/kde-4-1-3-on-laptop-and-hibernate-698577/)

allend 01-20-2009 06:59 AM

KDE 4.1.3 on laptop and hibernate
 
I recently installed KDE 4.1.3 from /testing on my laptop and wanted to get suspend to disk working with Guidance Power Manager.
I had already had this working with pm-utils and was able to run pm-hibernate as a normal user using sudo.
I found that I can get hibernate to work by editing /usr/share/apps/guidance-power-manager/powermanage.py and changing:
Quote:

SUSPEND_USE_HAL = True to SUSPEND_USE_HAL = False
S4_COMMAND = "/usr/local/bin/hibernate" to S4_COMMAND = "sudo /usr/sbin/pm-hibernate"
I then renamed the /usr/share/apps/guidance-power-manager/powermanage.pyc file and logged out. After logging in as root so that the powermanage.pyc file was recreated, then logging out and logging in as my normal user I can now hibernate from the Guidance Power Manager.

This is OK for my needs, but I am wondering whether there is an alternative scheme that I should be using rather than disabling HAL?

rworkman 01-20-2009 10:26 AM

Hrm, all of that shouldn't have been necessary :/
Does suspend/hibernate work correctly from the "Leave" menu?

If the HAL methods aren't working, make sure your user account is a member of the "power" group. If it is already, then I have another (far-fetched) idea, but let's start with the simple stuff... :)

allend 01-21-2009 06:26 AM

Doh! I would have sworn that I had set up the "power" group, but no, I hadn't. So of course I reversed my changes and hibernate works out of the box. Why does it take a second pair of eyes to see the blindingly obvious sometimes? (That was rhetorical).
I do not see any suspend/hibernate options in the "Leave" menu though.
Anyway, thanks for taking the time to answer Robby. Please feel free to loudly guffaw at this rueful drongo!

rworkman 01-21-2009 07:55 AM

Quote:

Originally Posted by allend (Post 3416057)
Doh! I would have sworn that I had set up the "power" group, but no, I hadn't. So of course I reversed my changes and hibernate works out of the box. Why does it take a second pair of eyes to see the blindingly obvious sometimes? (That was rhetorical).

Okay, then I won't answer ;-)
Seriously, it's not just you - it happens to all of us from time to time: trust me :)

Quote:

I do not see any suspend/hibernate options in the "Leave" menu though.
Hrm, ignore that - it's only in a newer kde4, I think ;-)


All times are GMT -5. The time now is 07:44 PM.