LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2011, 04:14 PM   #1
ranko_6
Member
 
Registered: May 2009
Distribution: Slackware 13.1
Posts: 43

Rep: Reputation: 15
KDE's shutdown button and it's need for widgets


Bought laptop recently which came with Windows OS. Few days of working on it and it made me realize why I even switched to Linux on my desktop so I decided to install Slackware on my laptop too.

First question, probably not related to Slackware as much with KDE but still. Does anyone know how to get rid of this... I guess dummy widget that makes those weird borders that don't make much sense on KDE.
I didn't do anything out of order to get them, it was clean, full installation of Slackware. When I started KDE there was already one widget running and I closed it. Everything was fine. I restarted computer, started KDE again and I got those borders.
After remembering that I had same problem on my desktop and that one day it just got resolved I thought it might be connected to the widgets, so I added a widget, exited KDE and started it again and problem solved, no borders. Closing widget and restarting KDE results in those borders again. Now I'm interested if I really NEED to have some kind of widget to get rid of them or I actually can have nice clean desktop?

Second question. How to get shutdown option in KDE's Kickoff's Application Launcher?
I tried searching for the problem on internet but most of the solutions were either to run some commands as root in console or to make a script that would do that for me.
Someone mentioned that the problem was in Session Management but I can't see anything there out of order. I have ticked "Offer shutdown options".
Someone said that maybe I don't have the privileges, and although some of you will say that I'm not supposed to do it, I ran KDE as root too to check it and I didn't have the shutdown option there either.

Since I installed Slackware using current image file thought that maybe someone who made it forgot something considering that current image has about 2.5 gigs less than the Slackware-13.37 image file so I dl'ed 13.37 too, reinstalled everything and got everything the same.
Since it works fine on my desktop, although it wouldn't make much sense is it possible that for some weird reason it's because it's installed on laptop?

Maybe I'm just forgetting something so I'd be grateful if someone can point me to some slackBuild/package/option that I maybe forgot that I did a long time ago to get those options on my desktop computer.

I'm not in line of business of fixing computers but I do get requests from acquaintances who use Windows and now since I have laptop I can "flash" around them with Linux OS, how easy it actually is to use, all programs free, pretty looking, no worries about viruses, oh and shutting down?
Quote:
"Easy", alt+F2, konsole, su, root password, poweroff and that's it
Kind of kills the mood
 
Old 08-22-2011, 04:18 PM   #2
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,515

Rep: Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700
Hi there,

1) The shadow is a KDE 4.5.5 bug with some graphic cards. I made it disappear by simply disabling desktop effects.

2) To enable shutdown, you have to boot into KDE via KDM. Set initdefault to 4 in /etc/inittab and reboot (or type 'init 4' to go there directly).

2a) There's a little shutdown plasmoid, enabling you to shutdown/reboot/disconnect with fewer clicks.

3) Enjoy Slackware and KDE.
 
1 members found this post helpful.
Old 08-22-2011, 04:44 PM   #3
ranko_6
Member
 
Registered: May 2009
Distribution: Slackware 13.1
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks that works but... do you maybe know how do I have it then on my desktop computer since I don't have that set up there?
Code:
id:3:initdefault:
I mean, I've seen this on Kubuntu and thought it makes some things easier but on my desktop I always logged in thru console as normal user and did "startx", didn't even know I could do that. So now I'm bit intrigued on why do I even have it if I'm not supposed to have it without init-ing to 4.
 
Old 08-23-2011, 01:45 AM   #4
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,515

Rep: Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700
Simply replace this line:

Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
by this line:

Code:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
A default Slackware installation boots you into init 3, that is, multi-user without X. My "orthodox" way to do things when installing a desktop is to install it, configure X, see if X runs OK using TWM, change the desktop WM to something less ugly than TWM (run 'xwmconfig') and then either reboot into init 4 or issue the following command:

Code:
# init 4
Ubuntu and Debian - as well as Red Hat Enterprise and Fedora - handle the init thing differently.
 
Old 08-23-2011, 03:51 AM   #5
ranko_6
Member
 
Registered: May 2009
Distribution: Slackware 13.1
Posts: 43

Original Poster
Rep: Reputation: 15
Sorry maybe I should have tried to explain it better. I did edit it on my laptop to set it to 4.

My "question" was more that, if that is only way to do it, then how come I don't have it set up on my desktop computer and I still have shutdown option?
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
is from my desktop's /etc/inittab
Also I never started X with
Code:
init 4
on my desktop but with
Code:
startx
Not that I complain I actually like it started with KDM more but was just wondering
 
0 members found this post helpful.
Old 08-23-2011, 04:01 AM   #6
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
There is no requirement for kde to be started from kdm to have shutdown in the K menu.

If your missing the shutdown menu then either the problem lies with polkit or a problem with the kernel and your hardware.
 
0 members found this post helpful.
Old 08-23-2011, 09:00 AM   #7
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64 14.0
Posts: 981

Rep: Reputation: 88
Are you in the "power" group? That will enable you to shutdown.
 
Old 08-23-2011, 10:15 AM   #8
ranko_6
Member
 
Registered: May 2009
Distribution: Slackware 13.1
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by wildwizard View Post
If your missing the shutdown menu then either the problem lies with polkit or a problem with the kernel and your hardware.
Well not sure what it might be, I do have it if I go init 4.

Quote:
Originally Posted by SqdnGuns View Post
Are you in the "power" group? That will enable you to shutdown.
Yea, I am member of the "power" group
 
Old 08-23-2011, 12:22 PM   #9
trademark91
Member
 
Registered: Sep 2009
Distribution: Slackware -current x64
Posts: 372

Rep: Reputation: 72
Quote:
Originally Posted by wildwizard View Post
There is no requirement for kde to be started from kdm to have shutdown in the K menu.

If your missing the shutdown menu then either the problem lies with polkit or a problem with the kernel and your hardware.
I think you're wrong on that one. On my machine, I have the shutdown menu in runlevel 4, and don't have it in 3.
 
Old 08-23-2011, 11:15 PM   #10
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,324
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
I will agree with the above poster, from my thinkpad x220. runlevel 4 fixes it for me. On another note, starting x from runlevel 3, although it doesn't have it as a normal user; as root it does. I always thought it was because originally unix was only supposed to able to be shut down by the administrator. One last thing, i get that annoyingly frustrating shadow thing sometimes too, i manage to fix it by ctrl+alt+backspace, and then rebooting the system.
 
Old 08-24-2011, 03:45 AM   #11
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Running using startx showing the shutdown menu :-

http://wildwizard.abnormalpenguin.co.../snapshot1.png
 
Old 08-24-2011, 05:08 AM   #12
ranko_6
Member
 
Registered: May 2009
Distribution: Slackware 13.1
Posts: 43

Original Poster
Rep: Reputation: 15
In my first post I posted a screenshot where I have shutdown button just by running it with startx on my desktop computer since that was the only way I knew how to get GUI. Guess it could be some problem with one of the things that you stated considering that even when I ran startx as root, I didn't have the shutdown button on my laptop.

But if it is a problem with kernel/hardware, don't see why I would have it in runlevel 4, or why it would even work, so maybe it's polkit, but then again... haven't made any changes to it, and I did download image files and installed slackware -current then slackware 13.37 and slackware -current just in case that something was wrong with slackware -current image, and after all of those, don't think that polkit could be corrupt or something like that
 
Old 08-24-2011, 05:36 AM   #13
fatalfrrog
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 43

Rep: Reputation: 15
4.5.5 from the disc, for me, does not have shutdown when started with startx, but does have shutdown when started from kdm.
Alien's 4.7 build has shutdown available when started from either method. If I remember correctly, his instructions for his KDE packages involve removing polkit. Maybe he can shed some light on why shutdown appears in his builds and not from the official ones (assuming that it's an issue with the builds, rather than just a 4.5.5 issue).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make widgets for KDE? whishkah Linux - General 4 03-09-2014 01:01 PM
logout before shutdown with shutdown button in XFCE ta0kira Ubuntu 2 06-25-2011 04:57 AM
KDE Shutdown Button MTK358 Linux - Desktop 6 07-29-2010 08:02 AM
opensuse 11 and kde 4 widgets? scarryharry Suse/Novell 2 09-03-2009 07:21 AM
Shutdown button on kde logoff gone arubin Slackware 9 11-20-2006 01:58 AM


All times are GMT -5. The time now is 02:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration