LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-26-2005, 04:19 AM   #1
apinta10
Member
 
Registered: Nov 2004
Location: Croatia, Hrvatska
Distribution: Slackware 10.1 + Debian Sarge 3.1 (testing)
Posts: 35

Rep: Reputation: 15
Kaffeine (DVB menu) not showing.


I installed kafeine in Slack.

the DVB menu won't show.

Drivers installed correctly.

FlexcorpII (as modules)

kernel - 2.6.13.2
kernel2 - 2.6.11.2

Tryed a lot to solve this. Simply won't show. Xine works ok.

channels.conf that was made with SZAP.

Thank you.
 
Old 09-28-2005, 06:31 PM   #2
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
If you compiled from source (it's the only way I've installed it) and you have the kernel source installed, check the output of when you run the configure command: has it located the dvb header files in your kernel source directory eg. frontend.h, if not you can put a symbolic link in /usr/include/linux

i.e ln -s /usr/src/linux/include/linux/dvb /usr/include/linux/dvb

that's the way I got dvb support to work when compiling from source
 
Old 09-29-2005, 07:59 PM   #3
krassyo
LQ Newbie
 
Registered: Sep 2003
Posts: 20
Blog Entries: 1

Rep: Reputation: 0
If you are starting this app as an user you have to set the correct permissions of the /dev/dvb/adapterX/* devices. You may also need to edit some conf files concerning udev (if you are using udev at all).
 
Old 10-01-2005, 01:51 AM   #4
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 567

Rep: Reputation: 45
I'm running the latest kaffeine with dvb in slack-10.2

I'm using the stock 2.6.13 kernel in slack-10.2 with a dvico fusion dvb-t card and as krassyo says above I had to set up udev. I had this working in 10.1 with a patched 2.6.11.9 kernel but needed to set up udev as well.

I'll past in my notes:

#################################################
11. CONFIGURING FOR DVB CARD

I've run lspci and lsmod as root to check and see that my dvb card is recognised and that the correct modules hae been loaded. Everything looks OK but I need to make some changes in /etc/udev if I want the correct devices set up in /dev/dvb/adaptor0. I don't understand all of the whys about what I'm going to do but it is necessary and it worked in my current workstation. Udev is fairly new and maybe it will get simpler with time.

This script has to be copied into /etc/udev/scripts:

#!/bin/sh
/bin/echo $1 | /bin/sed -e 's,dvb\([0-9]\)\.\([^0-9]*\)\([0-9]\),dvb/adapter\1/\2\3,'
#end of script

Previously I would also have to add this to /etc/udev/rules.d/udev.rules:

# dvb devices
KERNEL="dvb*", PROGRAM="/etc/udev/scripts/dvb.sh %k", NAME="%c"

but when I take a look I find that in slack-10.2 this line is already in udev.rules:

# dvb devices
KERNEL="dvb*", PROGRAM="/etc/udev/scripts/dvb.sh %k", NAME="%c", GROUP="video", MODE="0660"

This seems to be doing the same thing plus setting some permissions.

In slack-10.1 /etc/udev there was a subdirectory /etc/udev/permissions.d which is not here in 10.2 so I'm thinking that there has been some changes since when I had to add

# DVB devices
dvb/*:$root:video:0660
dvb:$root:video:0660
dvb/adapter*:$root:video:0660

to /etc/udev/permissions.d/udev.permissions and I think I'll leave everything as it is now with the exception of copying in the missing dvb.sh and I'll see if I get the correct devices created at the next boot.

On reboot I now have a /dev/dvb/adapter0. There are four devices in adapter0 which is what I should have and the permissions are as per the dvb line in udev rules:

rick@rick:~$ ls -l /dev/dvb/adapter0/
total 0
crw-rw---- 1 root video 212, 4 2005-09-17 20:33 demux0
crw-rw---- 1 root video 212, 5 2005-09-17 20:33 dvr0
crw-rw---- 1 root video 212, 3 2005-09-17 20:33 frontend0
crw-rw---- 1 root video 212, 7 2005-09-17 20:33 net0

so its quite clear that I'll have to make rick a member of the group video if I'm going to access my dvb related devices. I'll be lazy and do it in kuser but since I need to make the chnges as root I'll do the following:

[Alt F2] will open up a little window in KDE which will allow me to type in the command [[kdesu kuser]. After I hit Enter I will be prompted for the root password and after entering that kuser will open up allowing me to make changes as root.


#################################################
12. SETTING UP KAFFEINE FOR DIGITAL TV

Now that I know everything is in order for accessing/using my dvb card I'll setup Kaffeine for viewing digital TV programs. Kaffeine is also a good dvd viewer and has plugins for viwing other video type files as well.

The most recent is kaffeine-0.7.1 and I'll download the source and compile with ./configure, make and checkinstall which will create a slackpack. In slack-10.1 I could not get checkinstall to work right even though I followed Pat's instructions but checkinstall works fine this time around.

Kaffeine will also require libdvdcss for encrypted dvds.
 
Old 10-01-2005, 05:24 AM   #5
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Maybe I interpreted the first post wrong but I thought they said Xine was working fine which I took to mean they could use dvb using another xine user interface but not using kaffeine which would indicate the device settings/permissions and all that are fine, of course that's if I've interpreted what they said right.
 
Old 10-01-2005, 03:20 PM   #6
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 567

Rep: Reputation: 45
AFAIK Kaffeine will be looking for demux0, dvr0, frontend0 and net0 in /dev/dvb/adapterX/. If they are not there it will not display the DVB menu/options. Xine may pick up dvb and v4l devices elsewhere in the /dev tree.

Maybe what I contributed was redundant but then again it might give apinta10 a better understanding of what he needs to do.

BTW, once you get kaffeine up with dvb available, kaffeine has allot of channel listings for major cities and will run its own channels scan and create its own channel config. You can do it all from the scan option in the dvb pulldown menu.
 
Old 10-04-2005, 01:17 AM   #7
krassyo
LQ Newbie
 
Registered: Sep 2003
Posts: 20
Blog Entries: 1

Rep: Reputation: 0
It will not be a bad idea to also try VDR (Video Disk Recorder). I find it even better for digital tv and radio broadcasts reception. To use it with Flexcop II chip you need to also install the softdevice plugin (because there is no hardware mpeg2 decoder build in this type of pci/usb card).
 
Old 10-11-2005, 04:11 AM   #8
apinta10
Member
 
Registered: Nov 2004
Location: Croatia, Hrvatska
Distribution: Slackware 10.1 + Debian Sarge 3.1 (testing)
Posts: 35

Original Poster
Rep: Reputation: 15
Kaffeine

Udev is in use.

I inserted a script dvb.sh as you wrote.
and chmod +x so its executable like others.

in /dev/dvb/ devices are made on reboot.

xinelib 1.0.2 is installed
win32 codecs not yet
dvdlibcss - not yet

Kaffeine should show the DVB menu. And I gave root (groups : video and a normal user)

still no dvb menu. i dont know what i'm missing.

however VDR is asking me DVB API =>3

Thank you.
 
Old 10-11-2005, 02:28 PM   #9
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 567

Rep: Reputation: 45
Have you checked to see if the four devices were/are created in /dev/dvb/adapter0 ?

Is the user running kaffeine a member of the group video? Can that user cd into /dev/dvb/adapter0 or alternatively navigate in with a file manager?

If they are (and this may sound lame but...) try uninstalling and then reinstalling kaffeine. Make sure that the app and conf files for kaffeine in ~/.kde have been renamed (if you want to keep them for reference) or deleted. Then reinstall. Note that there is also a /opt/kde/share/apps/kaffeine/ with a file named kaffeinui.rc but that all should go when you uninstall kaffeine

I had trouble setting up on another box this weekend and after I had udev working properly, kaffeine wouldn't show DVB menu until a reinstall. It seems that when it first starts up it probes to see whats installed.

When you first run it a little window will pop up with a sort of viewable checklist saying whether or not you have things like DVB card, libdvdcss installed, etc. This is probably when kaffeine is setting up it's first configuration files and probably when it decides to give you a dvb menu if it finds a workable dvb card installed and setup properly.

Hopefully if you have permissions, groups, and udev working right the next time you start a clean install of kaffeine it works as it should.

It is the viewer of preference in our house and the only one I use for DVB-T.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I set up DVB - T with Kaffeine? Apappasmurf Linux - Software 0 11-27-2005 05:47 AM
Kaffeine: DVB icon remains dim, unusable Ekkume Linux - Software 1 11-16-2005 08:26 AM
boot menu no longer showing tedivm Linux - Newbie 2 08-23-2004 06:09 PM
Enlightenment menu text not showing up! Aman9090 Linux - Software 0 05-09-2004 02:08 PM
start menu not showing up twilightened Linux - Software 0 11-09-2003 07:20 AM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration