LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   just upgraded slackware from kernel 2.4.22 to 2.6.6 (http://www.linuxquestions.org/questions/slackware-14/just-upgraded-slackware-from-kernel-2-4-22-to-2-6-6-a-187831/)

postal26 05-30-2004 09:17 PM

just upgraded slackware from kernel 2.4.22 to 2.6.6
 
Just upgraded Slackware 9.1 from 2.4.22 to 2.6.6 it boots up great. Networking is fine, etc.....

Just one problem, no sound. i ran lspci:

00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 04)
00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 11)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 11)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 11)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 11)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 11)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 11)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 420] (rev a3)
02:0b.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
02:0d.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)

It even found my C-media soundcard above. I compiled alsa support into the 2.6 kernel. I ran alsaconf and I received the no isa or pci cards found. Here are my lsmod results:


snd_cmipci 32244 0
snd_opl3_lib 9248 1 snd_cmipci
snd_hwdep 7456 1 snd_opl3_lib


amazingly theres hardly anything in there?? What should I do. I'm very happy to have slackware with the 2.6.6 kernel but without sound i'm doomed. Please help me.

usercsr 05-30-2004 09:22 PM

This has been told sooooo many times. Anyways, if you have compiled ALSA support into the kernel, try to compile it as a module rather 'into' the kernel. This should mostly fix the problem.

postal26 05-30-2004 09:39 PM

Thank you
 
Thank you for your reply. Does this mean i have to run make menuconfig again? Is there anything I need to do b4 running make menuconfig? :-)

Nichole_knc 05-30-2004 10:10 PM

Yep, you must redo the kernel from the start...

As for myself I have had ZERO luck with 2.6 level kernels. I just cannot seem to get them to work at all.
I can do 2.4.# and 2.5.# with my eyes closed..... So that ain't the issue...

postal26 05-30-2004 11:22 PM

try this link to upgrade to 2.6
 
I finally have 2.6.6 kernel working great on slackware 9.1. Follow this article step by step:

http://www.geocities.com/jtarin47/linux

Look for the tutorial in a txt file

If youre using slackware 9.1 you only need to upgrade module-init-tools to current version 3.0.

I download the module-init-tools source untarred it and ran these commands to set it up:

./configure --prefix=/
make moveold
make
make install

Good luck! If I can do it you can :-)

spurious 05-30-2004 11:32 PM

Your link is no longer valid; here's the google cache for http://www.geocities.com/jtarin47/linux/kernel_2.6_tutorial.html

postal26 05-30-2004 11:36 PM

try it now
 
try it now i changed the link. Look for the tutorial in a text file

Nichole_knc 05-31-2004 06:54 AM

Interesting....
This is the first I had seen about upgrades of anything on slack to use the 2.6.# kernels.
I had assumed since the docs stated that 9.1 was "kernel 2.6 ready" that it was updated for the kernel.
Better fine print is needed...
I would assume now that this has come to light that this may be why we see so many post in the forum about kernel 2.6.# compile and running issues.
Also noted during an investigation of this I saw that even slack current was only using kernel version 2.4.26. That would indicate to me slack is "not" 2.6.# stable nor ready. Which could explain the problems encountered using 2.6.# and the number of off slack upgrades needed.
I have seen within the forum a mention of a 2.6.# kernel by Pat out there somewhere though I have not seen the src myself...
As I have stated elsewhere in the forum "I would use kernels above 2.4.26 with slack with caution" If you desire a totally stable system and/or running a secure server you should NOT use slack-current nor kernels outside the slack levels (2.4.26).
IMO

pave_spectre 05-31-2004 07:49 AM

The newer version of module-init-tools must only be required by 2.6.6, (and maybe later).
I've been running 2.6.5 for a while now and all I had to modify was my fstab, (no longer needed umask), and I'm still running version 0.9.14 of module-init-tools.

bengo 05-31-2004 03:37 PM

im running Slack - Current with Kernel 2.6.6-mm5 with no problems


All times are GMT -5. The time now is 06:34 AM.