LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-26-2006, 01:23 PM   #1
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Rep: Reputation: 30
Exclamation Just upgraded, now nothing in /dev !!


Hello,
just upgraded my slackware system to current (well most of it, I didn't bother with X11 packages)
Now my boot process gets stuck at fsck. It says it can't find /dev/hda3 (in my /etc/fstab, /dev/hda3 is /), and offers me the choice to login as root and fix the problem.
I logged in, and discovered that there was nothing in /dev at all! I'm no expert on the boot process, but this is somewhat troubling... Does anyone know how to resolve this?

thanks in advance.
 
Old 08-26-2006, 01:55 PM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
From which version did you upgrade, which kernel are you using and last but not least: Did you install the udev package and chmod the /etc/rc.d/rc.udev to execute during boot?
 
Old 08-26-2006, 11:22 PM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
have you renamed rc.udev.new to rc.udev?
 
Old 08-27-2006, 01:36 PM   #4
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
titopoquito:
1) I upgraded from whatever was "current" back in May or June (I haven't done a "complete" install of a slackware version since, hmmm 2 years ago? Ever since then I just upgrade whatever packages to "current" that I want, which is usually most of them)
2)I'm using Kernel 2.6.15.4 (I'm pretty sure, I'll double check when I get home)
3) Yeah I probably installed udev, and I probably did not chmod the /etc/rc.d/rc.udev to execute during boot. I guess I should try that when I get back home. Who should have execute permissions on it?

Willysr: I don't think I did, maybe the package installed it like that? Should I rename it like this?
 
Old 08-27-2006, 01:51 PM   #5
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
You should rename the rc.udev.new (if any) to rc.udev and make it executable so that it can create the /dev entries when booting.
 
Old 08-28-2006, 03:41 AM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
Pat puts rc.udev.new so it won't overwrite the original rc.udev in case people have modified the original rc.udev for their needs
 
Old 08-28-2006, 08:42 PM   #7
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
titopoquito: Well, it turns out I have BOTH of these files, and they're both set to executable. Now what??
I noticed that rc.udev has a line at the begining:
. /etc/udev/udev.conf
IS it trying to execute this file? /etc/udev/udev.conf doesn't have execute permissions, but should I add them?
 
Old 08-28-2006, 08:55 PM   #8
pbhj
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware 12; Ubuntu 7.10
Posts: 358

Rep: Reputation: 31
I've had similar problems (no eth0) doing this in the last day or two. I used Kdiff3 and went through all the updates in /etc/rc.d/ .

I thought I'd got them all and things weren't right still ... I'd missed an update to rc.S.

So, for me at least, I had to update a lot besides just chmod-ing the rc.udev.
 
Old 08-28-2006, 08:58 PM   #9
major.tom
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Slackware (current); Gentoo (newbie)
Posts: 142

Rep: Reputation: 15
I would replace rc.udev with rc.udev.new (the newer one is probably the one you want anyway).

I would also make sure that rc.udev is executable.

either
chmod +x /etc/rc.d/rc.udev
or
chmod 744 /etc/rc.d/rc.udev

You can then start udev with
/etc/rc.d/rc.udev start

and check /dev

Garry
 
Old 08-28-2006, 10:50 PM   #10
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
hello,
Yes, I can execute rc.udev and it doesn't work (returns an error, I forget) , but when I execute rc.udev.new, everything works! My /dev/ is full of...the stuff it should be full of!

Now, the problem is that I cannot replace or rename any of the files. My system gets booted as read-only and remains this way, even AFTER I execute rc.udev.new. So now I need some way to make my system read-write, wihtout rebooting (because of course when I reboot, I'm back to the begining again).
 
Old 08-28-2006, 11:17 PM   #11
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
replace over *all* the .new files in the rc.d directory over the originals, unless you made some specific changes to them (which I'm assuming you didn't).

Sounds like the rc.S is not remounting as rw during the boot.

And is your rc.udev (after you over write it from rc.udev.new) executable, or did you just execute it manually with 'sh ...'. There's a difference.

If none of this works, post the output from 'dmesg'

regards,
...drkstr
 
Old 08-28-2006, 11:37 PM   #12
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
drkstr:
replace all my original rc.d files with the *.new files? See, when I try to do that I get the "read-only filesystem" error.

"And is your rc.udev (after you over write it from rc.udev.new) executable, or did you just execute it manually with 'sh ...'. There's a difference."
I executed it as "./rc.udev.new", and YES it has execute permission.


rc.S not mounting as rw... umm... I guess something's wrong with this file, but as to how to fix it, I'm not sure since I can't save any changes...

I'll go reboot and check dmesg. I can't get the exact text since I can't save it anywhere, but I'll try to remember any lines that stick out!
(I'm posting from a Windows box, btw, not the messed up linux installation)
 
Old 08-28-2006, 11:44 PM   #13
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Boot using Slackware CD 1 or some Live CD, mount the partition and change the files.

Last edited by gbonvehi; 08-28-2006 at 11:46 PM.
 
Old 08-28-2006, 11:49 PM   #14
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
look for something after it says "Remounting root device with read-write enabled after you boot your computer." (If you don't know this allready, you can scroll up in the terminal with shift+PgUp)

And uppgrading was all you changed right? Nothing in the fstab? I just wanted to make sure we can rule this out as a possability.

...drkstr
 
Old 08-29-2006, 12:25 AM   #15
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
I fixed the read-only problem: I executed "/etc/rc.d/rc.udev.new" to get the devices, then executed "/etc/rc.d/rc.S.new" to remount the system as read-write. Then I just copied all the rc.*.new files to be just rc.*...
The system seems to be booting fine now, KDE loads, etc... the only problem NOW is that the mouse doesn't work. At all. As if it weren't plugged in (but it is). The output of dmesg and /var/log/Xorg.0.log both look normal (well, I was tired so I just grepped them for "mouse")...
I'll have another stab at this tomorrow.

oh, and artsd seems to be running the CPU at full load for a bit after KDE logs in, then failing. There was an artsd package in that monster upgrade I did too, so that also probably has some issues...
 
  


Reply

Tags
alsa, boot, fsck, fstab, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive... /dev/sda1 doesn't show unless I try mounting /dev/sda as vfat finite Linux - Hardware 8 03-10-2009 01:52 AM
/dev/tty0, /dev/tty1, /dev/tty10...and so on...which should be used for a device ??? b0nd Slackware 2 04-02-2006 09:14 AM
I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom! Dmalic Linux - Hardware 13 11-18-2005 08:11 PM
Sandisk USB card Reader not linking /dev/sg0 to /dev/sda acidraven Linux - Hardware 1 06-19-2004 04:56 PM
mounting 2 ide-scsi devices /dev/cdrom and /dev/cdrom1 issue penguin123 Linux - Hardware 3 09-26-2003 09:36 PM


All times are GMT -5. The time now is 03:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration