LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-26-2007, 10:23 PM   #1
spaceballs
Member
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Slackware-current
Posts: 248

Rep: Reputation: 30
Just reinstalled Slackware 11...sound doesn't work in KDE


I just reinstalled Slackware 11. I had a problem earlier, and I just decided this was the best way to fix it. Now...I don't have sound. Amarok doesn't fire up, and it seems to lock up when I try and test the sound.

I am relatively unfamiliar with KDE. Can someone help me out?

EDIT: Sound works in GXine, and it worked from alsamixer and alsactl. So sound works. It just seems like amarok and none of the other media players want to work...

Last edited by spaceballs; 03-26-2007 at 10:31 PM.
 
Old 03-26-2007, 10:47 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
ive never had the problem that your experiencing.

in amarok, go to Settings -> Configure Amarok -> Engine. play around with the 'Sound System' and the engine settings. or try playing with the Sound System settings in the KDE Control Center.

since sound works in other programs, it makes sense to guess that its a problem with amarok specifically, right?

hope it helps.

Last edited by nadroj; 03-26-2007 at 10:49 PM.
 
Old 03-26-2007, 10:50 PM   #3
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Did you put your user in the audio group?
 
Old 03-26-2007, 10:57 PM   #4
spaceballs
Member
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Slackware-current
Posts: 248

Original Poster
Rep: Reputation: 30
When I try and run amarok I get the amarok banner, and then nothing... Then I try and run it from a term and I get this:
Code:
$ /opt/kde/bin/amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
None of the music players will start, and when I try and start the sound system from the control panel, it freezes up.

Right now, artsd is taking up 99.9% of my processor in top. Do I need to change the permissions on something?

Now, I had upgraded amarok on this same computer, before ruining something else and reinstalling from the vanilla 11 disk. Are there any configurations from amarok that I need to erase? Where are they?
 
Old 03-26-2007, 10:59 PM   #5
spaceballs
Member
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Slackware-current
Posts: 248

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by masonm
Did you put your user in the audio group?
I sure did...
Code:
$ groups
wheel floppy audio video cdrom users
 
Old 03-26-2007, 11:05 PM   #6
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
you said in your initial post that GXine sound works. later you said no music players will start. i know gxine is mostly for video, but it can play mp3s--are you able to do that?
 
Old 03-26-2007, 11:07 PM   #7
spaceballs
Member
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Slackware-current
Posts: 248

Original Poster
Rep: Reputation: 30
OK...I got it figured out. There must have been some conflicting setting. I just searched for a folder named amarok in my .kde folder and deleted it. Problem solved!
 
Old 03-26-2007, 11:23 PM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
'.kde' is such a pain ... it causes so many problems ... what I would recommend is making cron or at delete it systematically ... you'll have a lot less problems
 
Old 03-28-2007, 07:46 PM   #9
spaceballs
Member
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Slackware-current
Posts: 248

Original Poster
Rep: Reputation: 30
Another question...that I think is related. I keep getting this error message saying:
Code:
Error - artsmessage
Sound server fatal error:
cpu overload, aborting
Then, immediate afterwards, I get another message saying:
Code:
aRts had to restart!
How do I get rid of these? They come back even if I restart KDE. When I run top, I see that aRts is taking up something like 98% of my processor.
 
Old 03-31-2007, 05:41 PM   #10
spaceballs
Member
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Slackware-current
Posts: 248

Original Poster
Rep: Reputation: 30
This is really slowing down my computer. Does anyone have any ideas on how to keep artsd from restarting?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reinstalled WinXP -> dual boot w/ RedHat9 doesn't work Toshi3 Linux - Newbie 3 06-22-2004 10:26 AM
Reinstalled Slackware 9.1 no SBLive Shr00mBoXx Slackware 3 06-20-2004 10:46 PM
Just reinstalled Mandrake 9.2 and I have no sound chumley115 Linux - Newbie 1 03-22-2004 03:45 AM
Just reinstalled Mandrake 9.2 and no printers won't work chumley115 Linux - Newbie 2 03-22-2004 12:40 AM
Reinstalled SDL, no sound hydro Linux - Newbie 0 08-01-2003 11:45 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration