LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-26-2013, 04:33 PM   #46
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190

Thanks for the info. Please complete your answer though, as I added questions to my previous post while you were answering it.
 
Old 09-26-2013, 04:35 PM   #47
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Didier Spaier View Post
Thanks for the info. Please complete your answer though, as I added questions to my previous post while you were answering it.
done
 
Old 09-26-2013, 05:00 PM   #48
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
I had a look at the source package b43-fwcutter_015-14.1.debian.tar.gz for Wheezy and in file firmware-b43-installer.postinst, for your card [14e4:4328] it says to use firmware broadcom-wl-5.100.138.tar.bz2, which is exactly the same used to build the package on Slackware. So I still don't understand this difference in behaviors.
 
Old 09-26-2013, 05:24 PM   #49
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
In this page you device is told to have a PHY version N (r2).

In the same page I see as Feature "not working yet":
5GHz for N-PHY cards

So I'd suggest you try again to use the braodcom sta/wl driver instead. Other than that some people recommend to pass the options pio=0 and qos=0 to the driver but I'm not sure that will help for your device.

If you want to try you could use this command as root:
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.conf/b43.conf
Correction: I should have written
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.d/b43.conf
PS Re-reading this thread I don't see a full output of "lsmod". please provide it (with the card plugged-in, of course).

PPS When you had the "exec format error", are you sure you built the wl module for your ARCH (32bit vs 64bit)?

Last edited by Didier Spaier; 09-27-2013 at 04:05 AM. Reason: Correction of a command
 
Old 09-26-2013, 06:08 PM   #50
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Didier Spaier View Post
In this page you device is told to have a PHY version N (r2).

In the same page I see as Feature "not working yet":
5GHz for N-PHY cards

So I'd suggest you tray again to use the braodcom sta/wl driver instead.
Hm. perhaps I had the wl module in debian then. I could have sworn it was the b43, because I followed that page's instructions for the b43 and fw cutter. I'm not sure what would have happened.

Quote:
Originally Posted by Didier Spaier View Post
Other than that some people recommend to pass the options pio=0 and qos=0 to the driver but I'm not sure that will help for your device.

If you want to try you could use this command as root:
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.conf/b43.conf
Tried that, didn't net any noticeable result.

Quote:
Originally Posted by Didier Spaier View Post
PS Re-reading this thread I don't see a full output of "lsmod". please provide it (with the card plugged-in, of course).
Thought I had provided that. Oh well, here it is.

Quote:
Originally Posted by Didier Spaier View Post
PPS When you had the "exec format error", are you sure you built the wl module for your ARCH (32bit vs 64bit)?
I am positive. I can rebuild a wl module for 32bit though, see what happens.
 
Old 09-26-2013, 06:46 PM   #51
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
Quote:
Originally Posted by slacker_ View Post
I can rebuild a wl module for 32bit though, see what happens.
Yes.
 
Old 09-26-2013, 08:31 PM   #52
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Didier Spaier View Post
Yes.
I can't load the module before I blacklist things. Problem is, blacklisting didn't do anything. I set up the file the way it said it should be on the slackbuilds site and it didn't work. File is in /etc/modprobe.d/blacklist and this is what it looks like:
Code:
blacklist b43
blacklist b43legacy
blacklist brcmsmac
blacklist bcma
blacklist ssb
It's a good bit longer than it should be but it shouldn't interfere with wl.ko should it?

Last edited by slacker_; 09-26-2013 at 08:34 PM.
 
Old 09-27-2013, 03:27 AM   #53
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
Quote:
Originally Posted by slacker_ View Post
File is in /etc/modprobe.d/blacklist
Files in /etc/modprobe.d should have a name ending in .conf to be scanned. So rename it /etc/modprobe.d/blacklist.conf (or /etc/rc.d/blacklist_b43.conf if you prefer, whatever :-) To know more: "man modprobe.d"

Last edited by Didier Spaier; 09-27-2013 at 03:39 AM. Reason: Better wording.
 
Old 09-27-2013, 03:53 AM   #54
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Didier Spaier View Post
Files in /etc/modprobe.d should have a name ending in .conf to be scanned. So rename it /etc/modprobe.d/blacklist.conf (or /etc/rc.d/blacklist_b43.conf if you prefer, whatever :-) To know more: "man modprobe.d"
Yeah I can't believe I over looked that one. It's almost 0400 on the east coast of North America, so I'll be testing the wl once more later on today and will update the thread accordingly.

Last edited by slacker_; 09-27-2013 at 03:58 AM.
 
Old 09-27-2013, 04:01 AM   #55
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
Erratum

Sorry, in a previous post instead of:
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.conf/b43.conf
I should have written:
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.d/b43.conf

Last edited by Didier Spaier; 09-27-2013 at 04:03 AM.
 
Old 09-27-2013, 02:57 PM   #56
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Didier Spaier View Post
Sorry, in a previous post instead of:
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.conf/b43.conf
I should have written:
Code:
echo "options b43 pio=1 qos=0" > /etc/modprobe.d/b43.conf
That's fine, I knew what you meant.

Tried to build the wl module but it kicked back an error. I can't understand the error, so I'll be posting it *HERE* in just a moment. If you don't see it hyperlinked, try again in a few minutes.

Last edited by slacker_; 09-27-2013 at 04:09 PM.
 
Old 09-27-2013, 03:40 PM   #57
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Main - Slackware 14.1, Others - Gentoo, Fedora
Posts: 150

Rep: Reputation: Disabled
If it's for kernel 3.10.x then you'll need to patch the wl code. See this thread.
 
Old 09-27-2013, 04:16 PM   #58
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
what file am I patching? It's kicking back "can't find file to patch at input line 4"

Edit** nevermind, I had to use -p2... my mistake.
 
Old 09-27-2013, 04:19 PM   #59
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
When I try to load the module it says
Code:
Error: could not insert module wl.ko: Unknown symbol in module
Haven't seen that before, any inight?

Edit: Also, I'm using the latest version of the driver which is 6.30.223.141

Last edited by slacker_; 09-27-2013 at 04:21 PM.
 
Old 09-27-2013, 04:21 PM   #60
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,542

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
You could spare yourself some hassle simply using the kernel shipped with Slackware-14.0. I did that and had no problem building the driver and inserting it.

But don't forget to run as root "depmod -a" after installation.

Last edited by Didier Spaier; 09-27-2013 at 04:23 PM.
 
  


Reply

Tags
broadcom-sta, broadcom43xx, networking, slackware 14


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux mint 12 will not connect to wifi internet or android wifi tethers wilspeak Linux - General 4 06-06-2012 01:40 AM
[SOLVED] Never installed a driver yet in linux and i just got a EUB9603H long range wifi adapt koolaidwayde Linux - Newbie 3 02-02-2012 01:05 AM
what linux driver do i need in order to get internet using a WiFi-AP Solo solution spinksc Linux - Newbie 3 05-02-2008 09:03 PM
wifi driver installed, but not working on Ubuntu Gutsy gvp87 Linux - Hardware 3 02-05-2008 04:42 PM
Wireless network driver installed cant configure internet deadenduser0666 Linux - Wireless Networking 19 08-31-2004 04:28 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration