LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-27-2013, 05:13 PM   #1
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Rep: Reputation: 2
Just installed wifi driver, internet is really choppy and I'm not sure why.


I just installed Slackware 14 on my T42 thinkpad laptop, which has no on-board wifi because mine is 6mos older than the first model that does... But it was a gift, and I'm not one to scoff at free things. So to fix the need for wifi I bought this pcmcia card and installed the appropriate driver (downloaded b43-cutter and used the b43 driver). The device is recognized but only the 2.4Ghz range is available. I had debian on the laptop before with the same driver and it worked on both frequencies. Being that I'm new to slack I don't know what I might have missed or what I need to do to troubleshoot this.

Thanks in advance for the help!

Important Update: I wound up installing broadcom-sta from slackbuild on a clean slackware 14 install, patched it with the included patch, now when I try to modprobe wl it kicks back the following:

Code:
ERROR: could not insert 'wl': Exec format error
I have no idea what this means. Can anyone provide some insight?

Last edited by slacker_; 09-01-2013 at 04:32 AM. Reason: New information.
 
Old 08-27-2013, 05:31 PM   #2
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
Having used a desktop version of a similar card, the Linksys WMP600N, I believe the problem is the kernel version you're using. Slackware 14 comes with an older kernel, 3.2.29, where the wifi driver was still in a poor state. To verify this, check for dropped packets on the wlan0 interface with:
Code:
ifconfig -a
Here are your options:
  • Upgrade your kernel. I'm currently running kernel 3.9.11 and get good performance and also 5GHz support.
  • Download the closed-source driver for your card from Broadcom. It will work well for kernels up to 3.4 or so. I don't remember getting 5 GHz support with it and I stopped using it after realizing the rt2800pci driver worked better.
  • Stay with the same kernel version and utilize backports to use a newer driver with an older kernel. See here: https://backports.wiki.kernel.org/index.php/Main_Page.

Last edited by vik; 08-27-2013 at 05:34 PM.
 
1 members found this post helpful.
Old 08-27-2013, 06:37 PM   #3
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Well I just tried to connect to my network but it won't connect. I'm using wicd-gtk because I can't figure out the cli for wicd. I also don't know how to go about upgrading the kernel on this OS. Would there be any detriment to upgrading to the latest kernel version?
 
Old 08-27-2013, 09:09 PM   #4
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 280

Rep: Reputation: 74
slacker,
Have you tried just uninstalling the b43 stuff and trying to use "broadcom-sta" from
slackbuilds.org instead?
Broadcom is notoriously crap for Linux support. Some chips work best with the b43-cutter
thing and some only work with the broadcom-sta.

The CLI interface for wicd: just run "wicd-curses" in a terminal.

Last edited by STDOUBT; 08-27-2013 at 09:12 PM. Reason: aditional info
 
Old 08-27-2013, 09:17 PM   #5
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
Yeah, that can be tricky sometimes: you can use wicd, or Network Manager (kind of bloated), or try a manual configuration like this: http://alien.slackbook.org/dokuwiki/...ckware:network. I set my connection manually as it always connects faster that way. If you need some help I can try to give you a step-by-step guide.

An easy way to test if the latest kernel drivers will fix your problem: try running a live CD like Arch that uses the latest kernel and see if you can connect to your network with no dropped packets. If it works, you should be able to replicate that in Slackware.

As far as upgrading the kernel, there can be some downsides. First, if you have an Nvidia card and use proprietary drivers sometimes the binary drivers won't build on the latest kernel without patching. AMD proprietary drivers sometimes have problems with too new of a kernel. Also, you can come across kernel regressions or just new bugs if you're too cutting edge. I usually stay a few revisions behind the latest and let the Arch guys test out the latest kernel. Hopefully this will help if you want to update your kernel: http://docs.slackware.com/howtos:sla...kernelbuilding.

Last edited by vik; 08-27-2013 at 09:31 PM.
 
Old 08-27-2013, 09:32 PM   #6
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
STDOUBT:
Quote:
just run "wicd-curses" in a terminal
Oh my... I can't believe I never saw anyone mention that! This makes it sooo much easier! Thank you!

I haven't tried broadcom-sta, because I honestly don't know the difference between it and b43.

vik:
Quote:
try a manual configuration
I would be fine with that for my home network, but once this is up and running, I'm going to be using this laptop for on-site troubleshooting (I'm an IT tech by trade, mostly residential Windows/networking stuff) so I'll need to be able to connect to a multitude of networks and manually setting up each one just isn't feasible.
STDOUBT mentioned wicd-curses and I never knew that was a thing so I'm quite pleased with that.

What keeps happening is the connection with wicd gets to the "Obtaining IP address" then it just quits or dies or stops or something. Not really sure where to go with that except to try the broadcom-sta that STDOUBT suggested.

As far as kernel things, I was using this laptop as a trial run type thing before loading it up on my desktop so that's when proprietary drivers would become an issue. This laptop is pretty basic. Never heard of kernel regressions though, could you explain that for me?
 
Old 08-27-2013, 09:39 PM   #7
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 723

Rep: Reputation: 114Reputation: 114
Quote:
Originally Posted by slacker_ View Post
What keeps happening is the connection with wicd gets to the "Obtaining IP address" then it just quits or dies or stops or something. Not really sure where to go with that except to try the broadcom-sta that STDOUBT suggested.
In my (admittedly limited) experience with Broadcom chips, that is caused by the kernel module, so yeah, try the broadcom-sta, and if that doesn't work, I would try a newer kernel.
 
Old 08-27-2013, 09:42 PM   #8
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
That could be a driver problem but it sounds like it might be a wireless config setting problem. Honestly I never had much luck with wicd. Try NetworkManager and see if that works for you. It is installed by default with Slackware 14 so you should just be able to do
Code:
chmod +x /etc/rc.d/rc.networkmanager
/etc/rc.d/rc.networkmanager start
.
If you're using KDE there should be a network configuration option in the menu somewhere. If you're using another Desktop Environment install network-manager-applet from SlackBuilds.org. Once you get it working, go to a website and see if you're getting dropped packets.

By regressions I mean bugs that were fixed in previous versions of the kernels that somehow creep up again in later kernels.

Last edited by vik; 08-27-2013 at 09:50 PM.
 
Old 08-28-2013, 12:42 AM   #9
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Try NetworkManager
I have NetworkManager, but I'm primarily using a cli interface. How does one use NetworkManager from cli?
 
Old 08-28-2013, 12:53 AM   #10
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 280

Rep: Reputation: 74
root:~# NetworkManager --help
 
Old 08-28-2013, 04:56 AM   #11
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Quote:
Originally Posted by slacker_ View Post
STDOUBT:

What keeps happening is the connection with wicd gets to the "Obtaining IP address" then it just quits or dies or stops or something. Not really sure where to go with that except to try the broadcom-sta that STDOUBT suggested.
This might happen if you haven't set your wpa key in wicd-curses. Run wicd-curses as root, use the right arrow on your router and set the wpa key there. Then run wicd-curses again as user.
 
Old 08-28-2013, 06:35 AM   #12
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by jostber View Post
This might happen if you haven't set your wpa key in wicd-curses. Run wicd-curses as root, use the right arrow on your router and set the wpa key there. Then run wicd-curses again as user.
I made sure to check that, my key is set, the key type is correct, everything is right. Also, networking can only be managed by root on my system, I can't even get wicd-gtk to do anything without root level permissions.

Quote:
Originally Posted by STDOUBT View Post
root:~# NetworkManager --help
Well, that didn't do much but it got me in the right direction... sort of. I went through the man pages and read everything there, but I still don't know how to use it to actually scan for and connect to a network from cli. nmcli is the tool I need I think, but can't figure out how to use it to scan and connect to anything, even after RTFM.
 
Old 08-28-2013, 06:54 AM   #13
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71
I had to uninstall wicd and install NetworkManager and reboot to have NetworkManager actually be the working app. I had installed NM and rebooted (just because) and wicd remained 'in charge', so the reason I uninstalled it.
 
Old 08-28-2013, 07:37 AM   #14
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Can you run this?

Code:
cat /var/log/wicd/wicd.log
 
Old 08-28-2013, 12:32 PM   #15
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Rep: Reputation: Disabled
Quote:
Originally Posted by irgunII View Post
I had to uninstall wicd and install NetworkManager and reboot to have NetworkManager actually be the working app. I had installed NM and rebooted (just because) and wicd remained 'in charge', so the reason I uninstalled it.
In addition to turning on NetworkManager as mention above you also need to turn off wicd with "chmod -x /etc/rc.d/rc.wicd".

Brian
 
  


Reply

Tags
broadcom-sta, broadcom43xx, networking, slackware 14


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux mint 12 will not connect to wifi internet or android wifi tethers wilspeak Linux - General 4 06-06-2012 01:40 AM
[SOLVED] Never installed a driver yet in linux and i just got a EUB9603H long range wifi adapt koolaidwayde Linux - Newbie 3 02-02-2012 01:05 AM
what linux driver do i need in order to get internet using a WiFi-AP Solo solution spinksc Linux - Newbie 3 05-02-2008 09:03 PM
wifi driver installed, but not working on Ubuntu Gutsy gvp87 Linux - Hardware 3 02-05-2008 04:42 PM
Wireless network driver installed cant configure internet deadenduser0666 Linux - Wireless Networking 19 08-31-2004 04:28 PM


All times are GMT -5. The time now is 01:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration