LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-29-2010, 03:23 PM   #1
Ubunoob001
Member
 
Registered: Feb 2010
Location: New Orleans, LA
Distribution: Mint 16 RC, Elementary OS Luna, Crunchbang
Posts: 166

Rep: Reputation: 16
Smile just installed Slackware....Lilo>Select "Ubuntu">>> "Ubuntu is in low graphics mode"?


Hi all!
So im new to Slackware and new-ish to Linux. I have practiced an install or two of Slackware before but never used it. Anyhow...


Situation: I just installed Slackware in a multi-boot situation with Ubuntu and Vista. I used "expert" install of Lilo only because I had done it before (with just Slackware and Vista during a practice install) and it worked fine. Anyhow, selecting Vista or Slackware works/boots great...however Ubuntu tried to load and says that "Ubuntu is running in Low grahpics mode" etc

Question: can someone suggest a newbie-friendly solution? thanks!
 
Old 08-29-2010, 07:09 PM   #2
merciful
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 13.1 / GSB / Compiz | Slackware 12.1 KDE
Posts: 15

Rep: Reputation: 0
Isn't ubunty using grub as loader? Just see in the grub config from your ubuntu setup what parameters are passed by the loader and add these in the lilo config.

Eabe
 
Old 08-30-2010, 11:22 AM   #3
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu
Posts: 110
Blog Entries: 1

Rep: Reputation: 17
I would try to get Grub to boot the three OS , once you are in ubuntu you could try to reinstall Grub; it is good at detedting other systems although i am not familiar with Vista.

I just installed Ubuntu besides Slackware (which was booting with Grub) and once i rebooted i could boot both systems.

Then again i had previously installed Grub on my Slackware....Linux requires a lot of tweaking sometimes , part of the fun...good luck....Buzz
 
Old 08-30-2010, 12:29 PM   #4
basheer
Member
 
Registered: Mar 2009
Location: Bangalore, India
Distribution: CentOS6.5, CentOS7, Ubuntu14.04
Posts: 178

Rep: Reputation: 29
Smile

Try to install grub.
Try a live cd of ubuntu 10.04.
open a terminal
#sudo su
#grub-install /dev/sda (MBR of first hard drive.)

U can boot into anyone of the three systems.
 
Old 08-31-2010, 09:43 AM   #5
Ubunoob001
Member
 
Registered: Feb 2010
Location: New Orleans, LA
Distribution: Mint 16 RC, Elementary OS Luna, Crunchbang
Posts: 166

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by basheer View Post
Try to install grub.
Try a live cd of ubuntu 10.04.
open a terminal
#sudo su
#grub-install /dev/sda (MBR of first hard drive.)

U can boot into anyone of the three systems.

Okay I will try this. When I install Grub, what will I need to do to have it recognize my partitions, or will it auto detect? Is there a comparable "grubconfig" command as in liloconfig? thanks!
 
Old 08-31-2010, 09:55 AM   #6
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
yes there is grubconfig but its for grub legacy I think

heres the info for grub2/ubuntu
https://wiki.ubuntu.com/Grub2
 
Old 09-01-2010, 03:40 AM   #7
merciful
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 13.1 / GSB / Compiz | Slackware 12.1 KDE
Posts: 15

Rep: Reputation: 0
Just see in your grub config what parameters are given to the kernel. Copy this to the lilo config. You can pas parameters to the kernel with lilo using "append = "
 
Old 09-01-2010, 01:47 PM   #8
igadoter
Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: slack 12.2, debian-Trinity , openbsd
Posts: 729

Rep: Reputation: 56
Did you upgraded ubuntu lately? Or did you change your graphic card settings? I had the similar situation when I stopped to use nvidia GPU and installed Ati. Ubuntu was unable to set up properly - I had the same error 'running gnome in low graphic mode'.
Here is my post, maybe it will help a little
http://www.linuxquestions.org/questi...ration-827242/

Last edited by igadoter; 09-01-2010 at 01:51 PM. Reason: added link
 
Old 09-13-2010, 06:50 PM   #9
Ubunoob001
Member
 
Registered: Feb 2010
Location: New Orleans, LA
Distribution: Mint 16 RC, Elementary OS Luna, Crunchbang
Posts: 166

Original Poster
Rep: Reputation: 16
Smile

Quote:
Originally Posted by merciful View Post
Just see in your grub config what parameters are given to the kernel. Copy this to the lilo config. You can pas parameters to the kernel with lilo using "append = "
being a VERY noobinoob..... can you please suggest a course of action for doing this? Thanks!
 
Old 09-14-2010, 09:43 AM   #10
Ubunoob001
Member
 
Registered: Feb 2010
Location: New Orleans, LA
Distribution: Mint 16 RC, Elementary OS Luna, Crunchbang
Posts: 166

Original Poster
Rep: Reputation: 16
Hey All,
Due to added documentation etc, ive decided to install Grub2. Having a bit of an issue with it, but will refer to that in a separate thread.
Thanks for all the help!
 
Old 09-15-2010, 02:49 AM   #11
merciful
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 13.1 / GSB / Compiz | Slackware 12.1 KDE
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by Ubunoob001 View Post
being a VERY noobinoob..... can you please suggest a course of action for doing this? Thanks!
RTFM

man lilo.conf on the commandline!
 
0 members found this post helpful.
Old 09-15-2010, 09:53 AM   #12
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Originally Posted by merciful View Post
RTFM
How merciful....
 
Old 09-16-2010, 04:36 AM   #13
merciful
LQ Newbie
 
Registered: Jun 2006
Distribution: Slackware 13.1 / GSB / Compiz | Slackware 12.1 KDE
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by damgar View Post
How merciful....
On the commandline: man lilo.conf

In google srearch for: man lilo.conf

See here: http://www.linux.gr/cgi-bin/man/man2html?lilo.conf+5
 
Old 09-16-2010, 03:00 PM   #14
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,297

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Sometimes a man page is too long and confusing to be useful when you just need a quick start -- especially if you're not used to reading man pages. And I thought the "RTFM!" elitist nonsense was diminishing in the Linux community...but you've just done it twice. Plus, Ubunoob001 was asking about where to look to get the correct bootable information from GRUB to use in lilo.conf. You could have at least suggested some good grub man page to look at as well, but your comment (twice) was all but useless. You just provided information on how to access 639 lines of information that is largely not applicable to this situation, and the problem has been 'solved' (more avoided) by switching to Grub2. But it's OK, you got your little elitist quip in (twice!). Good job.
 
Old 09-16-2010, 05:47 PM   #15
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
Personally, I use Ubuntu 10.04 64bit and Slackware 64 13.1 in a dual boot.

I use Ubuntu's grub2 instead of lilo, because of the same issue the OP was having. I hate to say it (being a LONG time SW/lilo user), but Ubuntu's grub2 and tools are just better at this (except my text is fugly when booting SW..Ah, well, at least X works..)

The way you get grub2 to work systemwide (using Ubuntu LiveCD):
  • Boot the live CD..Wait the 45 min it seems to take to get you to a running gnome session
  • Open a terminal (I use Applications > Accesories > Terminal)
  • Next, type in the terminal:
    Code:
    sudo grub-install /dev/sda
  • Next:
    Code:
    sudo update-grub
  • That's about it
Reboot, and you'll see all those nifty OS's listed. Along with SW might be listed 4-5 times..This is because grub detected all those old kernels you have. I usually just choose the last on the list to boot SW

Now to figure out HOW to get a better rez in cli when SW boots with grub2...
 
  


Reply

Tags
multiboot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 11:35 AM
what is "sticky bit mode" , "SUID" , "SGID" augustus123 Linux - General 10 08-03-2012 05:40 AM
[SOLVED] When I type "sudo grub" it says "command not found" in Ubuntu 9.10 Live CD. msbstar Linux - Newbie 7 01-30-2010 12:05 PM
intrepid, PS3, update sources list from "ubuntu" to "ports-ubuntu" evdv Linux - Newbie 7 08-18-2009 11:52 AM
Ntfs-Fuse copy error Debian "Sid" / Ubuntu "6.06" animefriik Linux - General 0 10-06-2006 10:28 AM


All times are GMT -5. The time now is 03:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration