LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2002, 03:39 PM   #1
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Rep: Reputation: 30
Just installed Slack, now startx problems


I just installed Slackware 8.1 and i'm unable to startx, presumably because of my mouse.

Here's my error after typing startx...
(==) usingconfig file: "/etc/X11/xf86config"
(ee) xf86Openserial" cannot open device /dev/mouse
(EE) mouse1: cannot open input device
(EE) preinit failed for input device "mouse1"
no core pointer

Fatal server error
failed to initialize core devices

XIO: fatal IO error 104...

my mouse is a usb logitech i feel mouse. i've done mouseconfig and set that to a usb mouse, didn't work. i think that i need to edit my xfree86config file, heres and excerpt ...
Identifier Mouse1
Driver mouse
option "protocol" "mouse"
option "device" "/dev/mouse"


firstly, can i fix this by using the xf86config command? and which mouse option should i use for a usb mouse, is it a bus mouse? i put in option 2, but cannot remember what it is.

how can i find out which mouse device mine is ie tty??? or /dev/usb/mouse#

finally can i edit the xf86config file in the command line? ive cd'd to the files ditectory and did "view xf86config" i then changed the file to hopefully work for my system but do not know how to save and then exit the file.

thanks
 
Old 07-14-2002, 03:46 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Yeah by default Slack doesn't configure X during install, you'll need to type xf86config at the command to configure X.
 
Old 07-14-2002, 05:06 PM   #3
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
Do an "ls -l /dev/mouse" and see what it is linked to. Chances are it is linked to your PS2 mouse port if you have one. You need to delete /dev/mouse and relink ("ln -s xxxxx /dev/mouse", where xxxxxx is the device fifo where your usb mouse really is) to your USB mouse fifo file. I don't know the name of it since I don't have such an animal and am to lazy to look it up. Maybe it will show up in log file somewhere.
 
Old 07-14-2002, 05:10 PM   #4
GoremanX
LQ Newbie
 
Registered: Jul 2002
Location: Quebec, Canada
Distribution: Slackware 8.1
Posts: 13

Rep: Reputation: 0
As mentioned above, Slackware doesn't do any auto-configuration for X. I use XFree86 -configure to auto-set everything. But my Logitech USB cordless mouse is never enabled by default, so I have to install inwheel and set the protocol to imps/2 in the XF86Config file manually. Then my Logitech USB mouse works fine.

Also, it's important to have gpm running right from boot-up. For some reason, my USB mouse never works unless gpm is running. You can run one of the setup scripts (using pkgtool) to tell gpm that your mouse is a USB mouse. If you can move the cursor with your mouse on the console, then gpm is running right and all you need to do is install imwheel and change the protocol in your XF86Config file (I also use imwheel because it makes it super-easy to setup the scroll wheel).

Last edited by GoremanX; 07-14-2002 at 05:13 PM.
 
Old 07-14-2002, 05:37 PM   #5
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
how do i edit the xfconfig file manually in command line?
 
Old 07-14-2002, 06:33 PM   #6
Praetorian
Member
 
Registered: Jun 2002
Distribution: Ubuntu
Posts: 31

Rep: Reputation: 16
SU to root

mcedit /etc/X11/XF86Config
or
vi /etc/X11/XF86Config
 
Old 07-14-2002, 07:49 PM   #7
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
Do a "man XF86Config" to learn how.

(Note what letters are capitalized)
 
Old 07-14-2002, 08:20 PM   #8
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
ive been able to get into xwindows by plugging in a ps2 mouse so i can edit the xf86 file but i dont know where to find the imwheel program, is it on the slackware install cd? apparently i do not have it installed.

also, where do i find the usb fifo file for my mouse?
 
Old 07-14-2002, 09:57 PM   #9
GoremanX
LQ Newbie
 
Registered: Jul 2002
Location: Quebec, Canada
Distribution: Slackware 8.1
Posts: 13

Rep: Reputation: 0
I don't know if imwheel is on the Slackware CD, I don't think it is. You can find it at http://jcatki.dhs.org/imwheel/ (you'll need to download and compile it, takes all of 5 minutes in all).

I don't know why you'd need the usb fifo file. That's not necessary at all to get your mouse to work. As I mentioned earlier, all you have to do is run the setup script where you tell Slackware you have a USB mouse and enable gpm.
 
Old 07-14-2002, 11:59 PM   #10
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
I can't remember what advantage imwheel has over simply placing:

Option "ZAxisMapping" "4 5"

In the pointer section of my XF86Config file. The later seems simpler, and doesn't require starting yet another process.

On the USB mouse thing: Since I've never set one up, I don't really know what I'm talking about. The process of getting it working in gpm, then having XFree86 get it's settings from gpm (which I think will do automatically) is a good one. I just thought that /dev/mouse ought to point to a mouse, so does XFree86.
 
Old 07-15-2002, 07:40 PM   #11
GoremanX
LQ Newbie
 
Registered: Jul 2002
Location: Quebec, Canada
Distribution: Slackware 8.1
Posts: 13

Rep: Reputation: 0
just placing that line in jy XF86Config does not work for me unless imps/2 is the protocol. I spent AGES trying to figure out why, but never managed to.
 
Old 07-15-2002, 09:33 PM   #12
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
I don't think I've ever got my scroll mouse in any capacity unless I did use the IMPS2 protocol. This is just one of the places where those Xfree86 autoconfigure utilities always screw up for me.
 
Old 07-15-2002, 10:02 PM   #13
GoremanX
LQ Newbie
 
Registered: Jul 2002
Location: Quebec, Canada
Distribution: Slackware 8.1
Posts: 13

Rep: Reputation: 0
am I wrong in assuming that the imps/2 protocol comes from the imwheel app? That was my impression anyways, but I could be dead wrong. If I don't install imwheel, will the imps/2 protocol still work?
 
Old 07-16-2002, 12:57 AM   #14
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
i've seen imps/s listed in the mouseconfig screen, it's a mouse type option
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed Slack 10.1 Fine | Please help with kde and gnome problems ComputerGeek Slackware 6 05-11-2005 02:33 PM
Cant startx (newbie just installed Suse 9.2) coolbreeze7000 Suse/Novell 12 01-29-2005 12:33 PM
I installed FreeBSD 5.2 and have a few problems regarding startx Optyx *BSD 26 03-12-2004 07:00 AM
Installed Slack 9.1 Now I have 2 problems Luantum Slackware 4 11-01-2003 06:45 PM
Installed Debian, can't startx? nutshell Linux - General 8 07-01-2002 06:15 AM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration