LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-01-2013, 04:53 AM   #1
Stephen Morgan
Member
 
Registered: Feb 2011
Location: England
Distribution: Slackware
Posts: 147

Rep: Reputation: 15
Java doesn't display i2p installer properly


Slackware64-current, using the OpenJDK from AlienBob's repo (binary package). Version 7u17_b02.

I was installing the most recent i2p .jar from their website, and the programme displays in a very warped and unreadable manner. Unusable, in fact. Luckily there's an option to install through the console without the GUI, but still. I tried it in Crunchbang, and it installed fine on that, and I also tried in both E17 and KDE to make sure that wouldn't change it. Works on Crunchbang, doesn't on Slackware.
 
Old 04-01-2013, 07:21 PM   #2
padeen
Member
 
Registered: Sep 2009
Location: Perth, W.A.
Distribution: Slackware 14, Debian 7, FreeBSD, OpenBSD
Posts: 175

Rep: Reputation: 34
It may be unrelated, but just yesterday I installed IntelliJIDEA and they warn about running it under OpenJDK as, according to them, it can have corruption issues with the display. They recommend the Oracle JDK. IntelliJIDEA did run fine for me under OpenJDK, but you may try installing the Oracle JRE or JDK and see if that fixes your problem.
 
Old 04-02-2013, 11:41 AM   #3
Stephen Morgan
Member
 
Registered: Feb 2011
Location: England
Distribution: Slackware
Posts: 147

Original Poster
Rep: Reputation: 15
The trouble is that it works fine on Crunchbang, which also uses:
Code:
java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.4) (6b27-1.12.4-1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME shell doesn't display properly TomCJeagle Ubuntu 1 07-16-2010 07:23 PM
Desktop doesn't display properly via VNC sidra Linux - Software 6 05-16-2008 03:28 PM
php with css doesn't display properly htamayo Programming 3 04-15-2008 06:35 PM
Java doesn't work properly Alien_Hominid Slackware 17 05-13-2007 04:41 PM
installer doesn't display hda1 paddy Linux - Newbie 5 02-13-2006 12:25 AM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration