LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Jack audio connection kit problems, Slackware 13 - 37 (http://www.linuxquestions.org/questions/slackware-14/jack-audio-connection-kit-problems-slackware-13-37-a-885934/)

zeelog 06-12-2011 03:23 PM

Jack audio connection kit problems, Slackware 13 - 37
 
I have installed the Jack audio connection kit from
SlackBuilds.org The two listed dependencies, libsndfile
and libsamplerate are installed and everything seemed
to go well, except it's not listed in the KDE menus.
But that's Ok. I can start it from /usr/bin/jackd
But no I can't because I get these error messages:

oot@ed:/# jackd -R -d alsa
jackd 0.116.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
cannot load driver module alsa

I do not have an /etc/modules.conf file. I've no idea why.
It seems that jackd needs something from it. How do I get
a /etc/modules.conf file ?
I searched for alsa_pcm. I can't find it anywhere.
Where is it suppose to be ? How do I get one ?
I've got alsamixer and I've installed all kinds of alsa
files. It really surprised me that alsa_pcm is missing.
Any advice would be welcome !

zasavage 06-12-2011 03:36 PM

@zeelog

Ok is it a 64 bit 32 bit or multilib system ?

I have jack and use it every day

What sound card do you have ect ..

Regards

Lawrence

specialized 06-12-2011 03:42 PM

try this


jackd -d alsa -d hw:the name of your card that yous #cat /proc/asound/cards

or try qjackctl

good luck

zeelog 06-13-2011 10:11 AM

Jack audio connection kit problems, Slackware 13 - 37
 
Solved ! Thanks for you help. I used the command:
jackd --driver alsa --device hw:1

I have disabled a motherboard sound circuit in
the BIOS, but it still comes up as card 0 using
cat /proc/asound/cards
I use an M Audio Audiophile 24/96 under the
ICE1712 driver. It is listed as card 1
That is why I use --device hw:1
Now jackd runs. I checked it by running
top in a gnome terminal and saw jackd listed.
Thanks again. I wouldn't have go it
without your help.

tdos20 06-14-2011 04:43 AM

Glad to hear you sorted your issues, could you edit the subject of the thread adding [SOLVED] to the beginning. Many thanks.

zeelog 06-15-2011 10:03 AM

[SOLVED] Jack audio connection kit problems, Slackware 13 -37
 
The problem with jack audio connection kit, Slackware 13 -37,
has been solved.

Gerardo Zamudio 06-15-2011 11:35 AM

Quote:

Originally Posted by zeelog (Post 4386438)
The problem with jack audio connection kit, Slackware 13 -37,
has been solved.

At the very top of the thread you should see an option that says "Thread Tools". Click on that and you should see another option to mark the thread as solved.

zeelog 09-13-2012 10:25 AM

Jack audio connection kit problems, Slackware 13 - 37
 
Just want to say that both zasavage and specialized gave good advice.
Latter on I discovered that I was running a 32-bit OS and installing
64-bit applications on it. Didn't work ! One of the 64-bit apps was
jack. So, zasavage was correct as well as specialized.
Thanks to you all !


All times are GMT -5. The time now is 09:53 AM.