LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-28-2010, 07:46 PM   #1
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Rep: Reputation: 20
It can't see JDK (Slackware64 13)


I get an error while installing go_office from slackbuilds:

Code:
checking whether to build with Java support... yes
checking for java... no
checking the installed JDK... configure: error: JAVA not found. You need at least jdk-1.5, or gcj-4
make: *** [stamp/build] Error 1
As far as I can see I've got the latest JDK from /extra.
I'm running Slackware64 13.

Code:
bash-3.1$ ls /var/log/packages | grep jdk
jdk-6u16-x86_64-1

I'd be grateful for any help.
 
Old 01-28-2010, 07:58 PM   #2
koenigdavidmj
Member
 
Registered: Oct 2009
Posts: 73

Rep: Reputation: 25
It looks like you are running in a non-login shell (or you just like REALLY boring prompt strings). Try saying 'source /etc/profile' before running the SlackBuild.

Good luck!
 
Old 01-29-2010, 02:47 AM   #3
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Original Poster
Rep: Reputation: 20
Excellent.
I did two things:
1. source /etc/profile
2. Installed seamonkey2 from /patches

It works now. Thanks

How can I source the profile automatically? I guess I'd have to copy the stuff from it to ~/.bashrc?

btw, sourcing profile did not help on my laptop with slackware64-current - still says no jdk.
 
Old 01-29-2010, 02:56 AM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
Looking at that prompt I wonder if your problem is connected to this issue.

http://www.linuxquestions.org/questi...10#post3663810

Quote:
If you want to change this behavior of konsole go to "Settings->Manage Profiles->Edit Profile" with the profile "Shell" selected change the command from "/bin/bash" to "/bin/bash -l" to force a login shell. When I looked my Slackware 12 worked the same as 13 in this respect. Running konsole from the menu adds the "-l" to the command line so a login shell appears.
 
Old 01-29-2010, 03:08 AM   #5
portia
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 112

Original Poster
Rep: Reputation: 20
Actually, it worked on the 64-current as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to get JDK 1.5.0_08 and JDK 1.6.0_10 for Linux Redhat Itanium servers java_ascii Linux - Software 1 09-22-2009 11:17 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 06:50 PM
[SOLVED] Slackware64-C client wont detect Slackware64-C Samba server slackass Slackware 5 08-07-2009 11:23 PM
Jdk onelung02 Linux - Software 5 07-14-2006 03:43 PM
how to use Jdk 1.3.1 in RH 9 Egyptian_Isis Linux - Newbie 1 11-06-2003 04:15 AM


All times are GMT -5. The time now is 12:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration