LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-02-2004, 01:10 PM   #1
Necronomicom
Member
 
Registered: Jun 2004
Distribution: Slackware, Solaris
Posts: 127

Rep: Reputation: 15
Is there any way to turn off the computer power without pushing the button?


In the other distros when i choose to shut down the system the computer automaticaly turns it self off, however in slackware when i halt the computer it turn off the system but the eletric power is still left on.
 
Old 08-02-2004, 01:16 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
1) add;

apm=power-off

to your append line in the Slackware stanza in lilo.conf - ie for example

append="devfs=mount hdc=ide-scsi acpi=off quiet apm=power-off"

then type

/sbin/lilo

to make the changes take effect

Then use

halt

or if your using KDM you'll get the normal gui option.


2) Uncomment this line in /etc/rc.d/rc.modules

#/sbin/modprobe apm

to

/sbin/modprobe apm
 
Old 08-04-2004, 01:39 AM   #3
shmude
Member
 
Registered: Aug 2003
Distribution: Fedora, DSL, LAS, Knoppix
Posts: 83

Rep: Reputation: 15
got a slight problem....i dont seem to have the "append" area in my /etc/lilo.conf file. this is what i have

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 10
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x64k
vga = 791
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Slackware
read-only
# Linux bootable partition config ends


where should i put it? also while we are on the subject i get the undefined mode passed at startup and if i just push the spacebar it goes by fine...how do i get rid of that?

thanks
 
Old 08-04-2004, 01:54 AM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 52
vga = 791
commentt out that line

add the append after the image=
line
 
Old 08-04-2004, 02:03 AM   #5
shmude
Member
 
Registered: Aug 2003
Distribution: Fedora, DSL, LAS, Knoppix
Posts: 83

Rep: Reputation: 15
thanks...worked like a charm!
 
Old 08-04-2004, 03:03 AM   #6
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Not to split hairs, but the proper way to do this would have been to uncomment the APM line in rc.modules like Skyline said:

Code:
#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
#/sbin/modprobe apm
Uncomment that last line to enable APM.

Adding it to lilo.conf wasn't necessary.

Last edited by MS3FGX; 08-04-2004 at 03:05 AM.
 
Old 08-04-2004, 04:07 AM   #7
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
I don't see the reason to comment vga=791 in lilo.conf but anyway if the problem was fixed, why not
 
Old 08-04-2004, 05:17 AM   #8
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 52
Quote:
Originally posted by Cedrik
I don't see the reason to comment vga=791 in lilo.conf but anyway if the problem was fixed, why not

he was getting undefined video mode. end of second post.
 
Old 02-26-2006, 04:33 AM   #9
DdOs
LQ Newbie
 
Registered: Feb 2006
Location: Sydney, Australia
Distribution: Slackware 10.2
Posts: 21

Rep: Reputation: 15
Wink Thanx MS3FGX

Quote:
Originally Posted by MS3FGX
Not to split hairs, but the proper way to do this would have been to uncomment the APM line in rc.modules like Skyline said:

Code:
#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
#/sbin/modprobe apm
Uncomment that last line to enable APM.

Adding it to lilo.conf wasn't necessary.

You r Rite MS3FGX!!! I am a newbie too.. I had the same problem... and i get rid of the problem through your suggestion!! it was easy!! Thank You and all who are helping us by providing very good and different suggestions...

Thank You all Thank you very much..

DdOs

--------------------

I Want to Know!!
 
Old 02-26-2006, 07:06 AM   #10
Oinopion
Member
 
Registered: May 2005
Location: Kraków, PL
Distribution: Slackware
Posts: 33

Rep: Reputation: 15
APM is AFAIK mainly for laptops and co., but it can manage on desktops. The proper way is with ACPI and acpid. First is kernel driver for power managment, second is a daemon. I'm not sure, but I think ACPI is not compiled in default kernel in Slack, but it's a good think to make kernel all by youre self!
 
Old 02-26-2006, 09:26 AM   #11
Bjerrk
Member
 
Registered: Aug 2005
Location: Denmark
Distribution: Debian, Slackware
Posts: 70

Rep: Reputation: 19
Aye, ACPI is the sequel to APM in many areas. But if it works with APM, fine, it's just a waste to have support for both APM and ACPI in your kernel .config.
 
Old 02-27-2006, 04:50 AM   #12
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Pull the power plug!

hehehe lets go break something.

Last edited by /bin/bash; 02-27-2006 at 04:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Press power button can't turn down the computer shadkong Linux - Hardware 2 05-04-2005 10:50 PM
Power button shuts down computer? kaega2 Linux - Software 0 01-08-2004 07:32 PM
power button turns computer off kaega2 Linux - Hardware 8 12-15-2003 09:59 AM
ACPI: shutdown computer by pushing power button... elluva Mandriva 10 12-15-2003 04:57 AM
how to get mandrake 9.0 shut down the computer without pushing the power button? sirpelidor Mandriva 8 11-25-2003 01:11 PM


All times are GMT -5. The time now is 12:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration