LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-06-2011, 04:03 PM   #1
Bowlslaw
LQ Newbie
 
Registered: Aug 2011
Posts: 12

Rep: Reputation: Disabled
Is there a slackware equivalent of AMD's Cool 'n Quiet driver?


About 4 months ago, I switched from being a lifetime Windows user (blech) to Ubuntu. After Ubuntu 11.04, I disliked many of the changes they made.

One of my friends, a lifelong computer and linux lover, told me to switch to Slackware. I must say, after switching, it seems as though Ubuntu is the Windows of the Linux world. Slackware is...fairly overwhelming, currently.

Anyway, I have an ASUS M3A78 MB, and I desperately wish to install the cool 'n quiet driver so that my PC isn't so loud.

Any suggestions?
 
Old 08-06-2011, 05:02 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,622

Rep: Reputation: 498Reputation: 498Reputation: 498Reputation: 498Reputation: 498
The AMD cool & quiet is enabled in the bios on asus motherboards, my system has it
 
Old 08-06-2011, 06:32 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Moved: This thread is more suitable in <SLACKWARE> and has been moved accordingly to help your thread/question get the exposure it deserves.
 
1 members found this post helpful.
Old 08-06-2011, 06:51 PM   #4
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
Yes, there is the "powernow-k8" kernel module.

But CPU frequency scaling is only enabled by default on laptops in Slackware.
To enable on a desktop:

Open /etc/rc.d/rc.modules in a text editor

Look for this section:
Code:
### CPU frequency scaling support
#
# Below, set CPUFREQ to enable CPU frequency scaling to save system power.
#
# To always try to use CPU frequency scaling, set to:  on
# To never use CPU frequency scaling, set to:  off
# To use it only when the battery module is loaded (this will cause it to
# be used by default with most laptops), set to:  battery
#
CPUFREQ=battery
Change it to:
Code:
### CPU frequency scaling support
#
# Below, set CPUFREQ to enable CPU frequency scaling to save system power.
#
# To always try to use CPU frequency scaling, set to:  on
# To never use CPU frequency scaling, set to:  off
# To use it only when the battery module is loaded (this will cause it to
# be used by default with most laptops), set to:  battery
#
CPUFREQ=on
and reboot

Last edited by piratesmack; 08-06-2011 at 06:54 PM.
 
2 members found this post helpful.
Old 08-06-2011, 08:09 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Slackware 13.1 and 13.37 come with a package called cpufrequtils. After enabling the powernow-k8 module, use the cpufreq-info command as a quick way to verify the CPU is running at a slower idle speed.

Additionally, ensure the BIOS Q-Fan option is enabled. That will allow controlling speeds of any pulse-width modulated (PWM) fans. The lm-sensors packages comes with two shell scripts called fancontrol and pwmconfig. The latter script will help create an /etc/fancontrol configuration file. The fancontrol script can be run automagically from rc.local or from an rc.d startup script.

You can read more here:

Green Computing
 
Old 08-06-2011, 10:19 PM   #6
Bowlslaw
LQ Newbie
 
Registered: Aug 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
Interesting...

I tried all of that, and none of it worked.
 
Old 08-07-2011, 03:14 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hello Bowlslaw, welcome to LQ and welcome to Slackware

I have the following lines in my /etc/rc.d/rc.local file
Code:
modprobe powernow_k8
cpufreq-set --cpu 0 --governor conservative
cpufreq-set --cpu 1 --governor conservative
On my desktop/homeserver. Then governor conservative manages the cpu-frequency to be as low as possible at the given workload. Normally when surfing the internet it is at 800MHz.

Markus
 
2 members found this post helpful.
Old 08-07-2011, 10:34 AM   #8
Bowlslaw
LQ Newbie
 
Registered: Aug 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
Unfortunately, I still cannot get it to work with slackware. Quite irritating...I've got the chipset CD for my MB, if that helps anything...
 
Old 08-07-2011, 10:36 AM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by Bowlslaw View Post
Unfortunately, I still cannot get it to work with slackware. Quite irritating...I've got the chipset CD for my MB, if that helps anything...
No, unfortunately this won't help. But please post the output of
Code:
uname -a
and
Code:
/sbin/lspci
and
Code:
lsmod | grep power
Markus
 
1 members found this post helpful.
Old 08-07-2011, 03:01 PM   #10
Bowlslaw
LQ Newbie
 
Registered: Aug 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
Linux dormant 2.6.37.6-smp #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686 AMD Athlon(tm) Dual Core Processor 4850e AuthenticAMD GNU/Linux

00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:06.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port C)
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB7x0 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB7x0 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9600 GT] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

There was no output for lsmod | grep power
 
Old 08-07-2011, 03:17 PM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, you should load the module powernow_k8 with the command
Code:
modprobe powernow_k8
and afterwards you may check the current settings with
Code:
cpufreq-info
and you can execute the commands which I posted above (the entries in my rc.local).

Yet it isn't working for you because you're missing the module powernow_k8.

Markus
 
2 members found this post helpful.
Old 08-07-2011, 03:22 PM   #12
Bowlslaw
LQ Newbie
 
Registered: Aug 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
for lsmod | grep power

freq_table 2039 1 powernow_k8
mperf 923 1 powernow_k8
powernow_k8 12160 2
processor 23158 1 powernow_k8
 
Old 08-07-2011, 03:38 PM   #13
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, and what does cpufreq-info show?

Now that the module is loaded, everything should work for you.

Markus
 
Old 08-07-2011, 04:03 PM   #14
Bowlslaw
LQ Newbie
 
Registered: Aug 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
driver: powernow-k8
CPUs which run at the same hardware frequency: 0 1
CPUs which need to have their frequency coordinated by software: 0 1
maximum transition latency: 109 us.
hardware limits: 1000 MHz - 2.50 GHz
available frequency steps: 2.50 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1000 MHz
available cpufreq governors: userspace
current policy: frequency should be within 1000 MHz and 2.50 GHz.
The governor "userspace" may decide which speed to use
within this range.
current CPU frequency is 2.50 GHz (asserted by call to hardware).
analyzing CPU 1:
driver: powernow-k8
CPUs which run at the same hardware frequency: 0 1
CPUs which need to have their frequency coordinated by software: 0 1
maximum transition latency: 109 us.
hardware limits: 1000 MHz - 2.50 GHz
available frequency steps: 2.50 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1000 MHz
available cpufreq governors: userspace
current policy: frequency should be within 1000 MHz and 2.50 GHz.
The governor "userspace" may decide which speed to use
within this range.
current CPU frequency is 2.50 GHz (asserted by call to hardware).
 
Old 08-07-2011, 04:09 PM   #15
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
As you can see, your processor is running with the highest frequency. Now you may try the commands
Code:
cpufreq-set --cpu 0 --governor conservative
cpufreq-set --cpu 1 --governor conservative
and check what happens, at least the fan should slow down because of the lower temperature when the frequency of the cpus is lower.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atholon 64 Cool'n'Quiet arubin Slackware 1 01-15-2008 06:39 AM
AMD Cool'n'Quiet Four Pin Fan Crito Linux - Hardware 3 11-28-2006 06:47 AM
athlon64 cool and quiet driver linuxmandrake Debian 1 10-19-2005 10:22 AM
AMD Cool&Quiet Support in Fedora Core 4 Gwydion The Quick Linux - Hardware 3 09-08-2005 03:06 PM
enabling amd cool 'n' quiet on mandrake 10.1 guy24x Mandriva 3 03-24-2005 10:01 AM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration