LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-05-2009, 03:15 AM   #1
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
Is PKG_CONFIG_PATH set wrong in slackware64-current??


Is this environment variable set wrong for slackware64-current and multilib compatibility?

It appears the variable is set in /etc/profile.d/pkgconfig.?sh and does not include either /usr/lib64/pkgconfig or /usr/local/lib64/pkgconfig

This didn't seem to affect any of my compiles until I installed the slamd64 slackware64-current 32bit compatibility packages. Now it seems some packages I have to either use an extra configure variable/flag to specify one or two dependency libs or use PKG_CONFIG_PATH=/usr/lib64 for bother configure and in some cases, make.


Either way, this seems like one of the downfalls to a multilib environment. That is, you have to default the PKG_CONFIG_PATH to either search your lib64 first or your lib first. Then it will just use the first one. I suppose it's nice to assume that most users will want to build only 64 bit libs and should specify extra PKG_CONFIG_PATH only when they need 32bit libs... But at the moment this seems to be reversed.


Also, what then is the proper solution to slackbuilds? should they take this into account and force proper PKG_CONFIG_PATH for problematic packages? or rely on the environment to be properly set up when running the script?

Last edited by lumak; 06-05-2009 at 03:21 AM.
 
Old 06-05-2009, 08:14 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,751

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Are the *.pc files for the 64-bit packages in /usr/lib/pkgconfig or /usr/lib64/pkgconfig?
 
Old 06-05-2009, 09:51 PM   #3
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Original Poster
Rep: Reputation: 109Reputation: 109
Yes. The /usr/lib/pkgconfig and /usr/lib64/pkgconfig directories are separate and have the expected *.pc files in them. pkgconfig files for 32bit libs are are the first and 64 in the latter.

This is from a fresh, up-to-date, and separate install of slackware64-current.

It just seems like a bug to me that the /etc/profile.d/pkgconfig.?sh files set PKG_CONFIG_PATH to only be the 32bit directories instead of the 64 bit with the 32bit second.
 
Old 06-06-2009, 01:42 AM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,751

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Yeah, I think you should report this to Eric (AlienBob).
 
Old 06-06-2009, 10:34 AM   #5
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474
Blog Entries: 28

Rep: Reputation: 34
I hope this is an answer to my questions...

Quote:
Originally Posted by gnashley View Post
Yeah, I think you should report this to Eric (AlienBob).
I hope this turns out to be the reason why I haven't been able to build packages here. Because things keep acting as though they don't exist on my system. And this would make sense. I've wondered about this. Because I've just about exhausted every other option I could think of.

Shingoshi
 
Old 06-06-2009, 11:57 AM   #6
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,751

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
"echo $PKG_CONFIG_PATH" should give you the answer.
Use "export PKG_CONFIG_PATH=/usr/lib64/pkgconfig" to reset it. It won't hurt to set this as well:
export PKG_CONFIG_LIBDIR=/usr/lib64/pkgconfig so that when building aources the *.pc files get installed to the right place in your packages.
 
Old 06-06-2009, 01:00 PM   #7
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Original Poster
Rep: Reputation: 109Reputation: 109
Quote:
Originally Posted by gnashley View Post
"echo $PKG_CONFIG_PATH" should give you the answer.
Use "export PKG_CONFIG_PATH=/usr/lib64/pkgconfig" to reset it. It won't hurt to set this as well:
export PKG_CONFIG_LIBDIR=/usr/lib64/pkgconfig so that when building aources the *.pc files get installed to the right place in your packages.
That's why you should always check the file list outputted right before the package script finishes

Either way, the potential issue has been reported now.

Last edited by lumak; 06-06-2009 at 01:24 PM.
 
Old 06-06-2009, 04:58 PM   #8
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474
Blog Entries: 28

Rep: Reputation: 34
Wow! You're onto something here...!!!

Quote:
Originally Posted by gnashley View Post
"echo $PKG_CONFIG_PATH" should give you the answer.
Use "export PKG_CONFIG_PATH=/usr/lib64/pkgconfig" to reset it. It won't hurt to set this as well:
export PKG_CONFIG_LIBDIR=/usr/lib64/pkgconfig so that when building aources the *.pc files get installed to the right place in your packages.
I just ran the command above. And none of the lib directories had the 64-bit suffix attached to them.

Shingoshi
 
Old 06-06-2009, 05:02 PM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
This has been fixed here, and should go out in the next batch of updates.

Eric
 
Old 06-06-2009, 05:11 PM   #10
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474
Blog Entries: 28

Rep: Reputation: 34
I hope this is the solution that was needed...

Quote:
Originally Posted by Alien Bob View Post
This has been fixed here, and should go out in the next batch of updates.

Eric
I hope this resolves all concerns here. But I'm also creating a script to use sed to add the $LIBSUFFIXDIR to each instance of lib found in PKG_CONFIG_PATH.

Shingoshi
 
Old 09-11-2009, 05:47 PM   #11
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
I'm having a related problem where my PKG_CONFIG_PATH is set correctly however some apps I installed from the GSB Slackware64 installation are not visible eg.

pkg-config --modversion libcurl [ this is from the base slack install ]
is fine ...

pkg-config --modversion libbonoboui [ this is from the gsb install ]
is not fine and returns "Package libbonoboui was not found in the pkg-config search path"

PATH is /usr/lib64/pkgconfig by the way

I've checked the PATH and the libbonoboui.pc file is definitely there. I need bonobo for the gtk-qt package and this has thrown a spanner in the works. Any help would be appreciated.

Regards, Robby
 
Old 09-11-2009, 06:00 PM   #12
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
Ok I've just found the issue, by chance, although I don't understand it properly:

The pkgconfig path includes:

libbonobo-2.0.pc
libbonoboui-2.0.pc

But the slackbuild ( or should I say the cmake ) for gtk-qt-engine is looking for:

libbonobo.pc
libbonoboui.pc

Very strange - any ideas are welcome ...

Regards, Robby
 
Old 09-11-2009, 06:14 PM   #13
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474
Blog Entries: 28

Rep: Reputation: 34
Good luck with getting help on this...

Quote:
Originally Posted by rpedrica View Post
I'm having a related problem where my PKG_CONFIG_PATH is set correctly however some apps I installed from the GSB Slackware64 installation are not visible eg.

pkg-config --modversion libcurl [ this is from the base slack install ]
is fine ...

pkg-config --modversion libbonoboui [ this is from the gsb install ]
is not fine and returns "Package libbonoboui was not found in the pkg-config search path"

PATH is /usr/lib64/pkgconfig by the way

I've checked the PATH and the libbonoboui.pc file is definitely there. I need bonobo for the gtk-qt package and this has thrown a spanner in the works. Any help would be appreciated.

Regards, Robby
It'll be interesting to see how some react to the comment of your running GSB. I'm running the same thing. But as has been stated so often, it's not official, and therefore not supported. So good luck on any results here that you can't solve yourself.

Shingoshi
 
Old 09-11-2009, 06:19 PM   #14
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
I agree with you that it's not official, therefore not supported; however I've been using the GSB set for a long time now without issue. Perhaps I've found one where the install files from GSB are either named incorrectly or the gtk-qt-engine is looking for the wrong files. I will add that I didn't have this issue under GSB 2.26 for slack 12.2 ...

I've just created soft links to the files in the meantime to get going, but I'd be interested in a fix - will put this on the GSB mailing list.

Regards, Robby
 
Old 09-11-2009, 06:45 PM   #15
Shingoshi
Member
 
Registered: Oct 2006
Location: Cochise County, Arizona
Distribution: Gentoo-AMD64 / Slackware64-Current
Posts: 474
Blog Entries: 28

Rep: Reputation: 34
You're not alone...

Quote:
Originally Posted by rpedrica View Post
I agree with you that it's not official, therefore not supported; however I've been using the GSB set for a long time now without issue. Perhaps I've found one where the install files from GSB are either named incorrectly or the gtk-qt-engine is looking for the wrong files. I will add that I didn't have this issue under GSB 2.26 for slack 12.2 ...

I've just created soft links to the files in the meantime to get going, but I'd be interested in a fix - will put this on the GSB mailing list.

Regards, Robby
I have the GSB installed to support my Vislab installation. Vislab requires that the GSB packages be installed. I never had any trouble with anything until moving up to 64-bit. And it definitely has to do with the pkgconfig. Could you post a link to the GSB mailing list here?

Shingoshi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64 -current made public! bsdunix Slackware 289 06-19-2009 12:15 AM
Slackware64-Current / slackpkg slackass Slackware 31 06-06-2009 10:51 PM
[SOLVED] what's that directory (slackware64-current) sycamorex Slackware 3 05-30-2009 09:03 AM
Slackware64 -current and KDE mlangdn Slackware 7 05-29-2009 08:57 AM
Slackware64-current ATI, and few more proprietary questions dolphin77 Linux - Newbie 1 05-22-2009 06:57 PM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration