LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Is it safe to Ignore EFI warning during install? (http://www.linuxquestions.org/questions/slackware-14/is-it-safe-to-ignore-efi-warning-during-install-4175484159/)

Gerardo Zamudio 11-10-2013 11:30 PM

Is it safe to Ignore EFI warning during install?
 
Hi,

I was about to install 14.1 64bit on my machine when GRUB loaded automatically and the installer warned me I had an EFI system and I had to create an EFI boot partition. I have a custom built desktop and since I'm not using EFI I went into my motherboard's settings and explicitly set to boot in legacy mode.

When I boot from the Slackware disk it boots with GRUB and I get the same warning again. Is it safe to ignore this and install like usual? LILO to MBR, not using gpt, no EFI, etc. I read README_UEFI.TXT and it says

Quote:

Unless your computer came with a preinstalled version of Windows that
requires UEFI, switching to Legacy Boot (aka, traditional BIOS) is an
option. Just switch to Legacy Boot in the UEFI menus. With most systems
you can get into the UEFI menu by pressing the ESC key as the system
boots. Then boot the Slackware installer and remove any existing
partitions using cgdisk to start over. You may use either the GPT
partitioning scheme, or the traditional MBR partitioning scheme, but
there's really no advantage to switching back to MBR if your system
already has a GPT partitioned hard drive
I have Windows 7 installed on this machine and it's not using EFI/UEFI either. It seems its possible to do what I want but I don't really understand what it means to 'remove any existing partitions and start over'. What partitions? My motherobard is a ga-z77-d3h if that helps.

Didier Spaier 11-11-2013 03:35 AM

There shouldn't be any issue. And if you want to keep Windows 7 yo can avoid touching the MBR putting LILO's boot loader on Linux' root partition.

To make sure, just boot the installer, then don't type 'setup' but "fdisk -l" and post results here.

jtsn 11-11-2013 06:04 AM

Quote:

Originally Posted by Didier Spaier (Post 5062373)
There shouldn't be any issue. And if you want to keep Windows 7 yo can avoid touching the MBR putting LILO's boot loader on Linux' root partition.

It should be noted, that the Windows 7 boot partition must have the boot flag set in the partition table, or otherwise various Windows stuff will break. So for a multi-boot system LILO inside the MBR is the best solution. Putting LILO on the /boot or root partition and correctly chainload Windows from there (using change partition=/dev/sdax activate) will make Windows boot by default all the time and LILO will not show up anymore.

Didier Spaier 11-11-2013 06:28 AM

Quote:

Originally Posted by jtsn (Post 5062459)
It should be noted, that the Windows 7 boot partition must have the boot flag set in the partition table, or otherwise various Windows stuff will break. So for a multi-boot system LILO inside the MBR is the best solution. Putting LILO on the /boot or root partition and correctly chainload Windows from there (using change partition=/dev/sdax activate) will make Windows boot by default all the time and LILO will not show up anymore.

Here is my configuration:
Code:

bash-4.2# cat /etc/fstab
/dev/sda6        swap            swap        defaults        0  0
/dev/sda3        /                ext4        defaults        1  1
/dev/sda5        /current        ext4        defaults        1  2
/dev/sda2        /windows        ntfs-3g    fmask=133,dmask=022 1  0
#/dev/cdrom      /mnt/cdrom      auto        noauto,owner,ro,comment=x-gvfs-show 0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
tmpfs            /dev/shm        tmpfs      defaults        0  0
[...]
bash-4.2# LANG=en_EN fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x43c69dc0

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848    73142271    36467712    7  HPFS/NTFS/exFAT
/dev/sda3  *    73143945  267707159    97281607+  83  Linux
/dev/sda4      267708416  312576704    22434144+  5  Extended
/dev/sda5      267710464  304189439    18239488  83  Linux
/dev/sda6      304190838  312576704    4192933+  82  Linux swap
[...]
bash-4.2# cat /etc/lilo.conf
[...]
boot = /dev/sda3
[...]
default = Linux
[...]
image = /boot/vmlinuz
  root = /dev/sda3
  label = Linux
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins 
image = /current/boot/vmlinuz
  root = /dev/sda5
  label = Current
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends

I have no problems so far with these settings.

But I must admit that I use Windows 7 only once in a while, so could you please elaborate about the possible problems?

I just had once to remove the boot flag on the / Linux partition to install a Windows service pack.

jtsn 11-11-2013 06:56 AM

Quote:

Originally Posted by Didier Spaier (Post 5062471)
I have no problems so far with these settings.

But I must admit that I use Windows 7 only once in a while, so could you please elaborate about the possible problems?

I know the WFM argument, but it is not a supported configuration, so it is not a good recommendation (if you want to keep a working Windows 7 configuration). Windows XP works just fine without an active partition, that changed on the later versions.

Quote:

I just had once to remove the boot flag on the / Linux partition to install a Windows service pack.
Bootloader updates are one example, they can happen anytime, not only on Service Packs. Other examples are Windows Backup, System Image and various recovery functions. It will just break without telling you, what the issue is, it may even overwrite data on the active partition (in your case the Linux partition).

Didier Spaier 11-11-2013 07:48 AM

Understood, thanks jtsn.

Gerardo Zamudio 11-11-2013 08:19 AM

My partition scheme is nothing special, something like

Code:

/dev/sda1 - Windows ntfs
/dev/sda2 - Slackware ext4
/dev/sda3 - Swap

I've already got my partitions set up formatted and swap turned on. Windows 7 is installed first to drive with no gpt. Up to Slackware 14.0, I've always been able to boot the installer and choose the defaults (no need to use fdisk) and that's with my motherboard in EFI mode. This time around, however, the installer's wording makes it seem like just because my motherboard supports EFI I must use it and my drive has to use gpt.

I don't want to ignore the warning and have the installer go through thinking I've done what it told me to do.

jtsn 11-11-2013 08:39 AM

You have to boot the Slackware DVD in legacy mode to be able to install it onto a MBR disk. Select a different entry from your Firmware boot menu (or try them all) until ISOLINUX (and not GRUB) shows up. Then install Slackware again.

Gerardo Zamudio 11-11-2013 09:16 AM

1 Attachment(s)
Quote:

Originally Posted by jtsn (Post 5062536)
You have to boot the Slackware DVD in legacy mode to be able to install it onto a MBR disk. Select a different entry from your Firmware boot menu (or try them all) until ISOLINUX (and not GRUB) shows up. Then install Slackware again.

Thanks! You were right. It wasn't enough to set my motherboard to boot in legacy mode, I had to do it for the DVD drive too. After setting my DVD drive to boot in 'legacy' now I have the option to boot the drive as UEFI or normal. I selected SATA and ISOLINUX came up :) Going to finish the installation later today. I've attached an image to help anyone else having this problem. Marking this as solved.

ReaperX7 11-11-2013 08:47 PM

Was your Windows system installed by an OEM or a retail disk?

Gerardo Zamudio 11-11-2013 09:31 PM

Quote:

Originally Posted by ReaperX7 (Post 5062878)
Was your Windows system installed by an OEM or a retail disk?

It's a desktop I built, so no OEM. I bought a retail boxed copy of Windows 7 Ultimate.

ReaperX7 11-11-2013 10:48 PM

Windows 7 should have given you the option upon initial installation to partition the disk using GPT style partitioning with a UEFI system rather than MBR. If it had have, when you ran fdisk or cfdisk at installation of Linux it would have spit out an error stating the drives were partitioned in GPT or an MBR partition was not detected, and you would have had to use gdisk or cgdisk to partition for GPT.

Windows 7 installer also would have created a small FAT32 partition for the EFI bootloader, a standard 100MB partition for System Reserved boot and BitLocker, and reserved the remaining space for Windows 7.

jtsn 11-12-2013 05:22 AM

Windows 7 doesn't give you options. If you boot the UEFI installer, it creates a GPT, if you boot the legacy installer, you get a MBR partitioned disk. So it works the same as Slackware 14.1.

ReaperX7 11-12-2013 02:50 PM

Good question, when you installed Windows did you have Legacy BIOS mode enabled?

Gerardo Zamudio 11-12-2013 02:55 PM

Quote:

Originally Posted by ReaperX7 (Post 5063330)
Good question, when you installed Windows did you have Legacy BIOS mode enabled?

Nope, I did not. I never had to change anything until I popped in the Slackware install DVD and it kept saying I had an EFI system. I think the default option in the motherboard is something like "use EFI but fallback to BIOS just in case". I can't afford a reboot right now so I'll check in a few hours.


All times are GMT -5. The time now is 12:43 AM.