LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-15-2009, 09:49 AM   #1
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Is anyone succesfully running 2.6.32 with the proprietary NVIDIA driver?


I've been trying to figure out the cause of system hangs with slack 13 for a a week or so. I get random total freezes with the keyboard LED's blinking at me and the only solution is to do a hard-reset. I was using a self-compiled 2.6.31.6 kernel on 32bit Slack with similar results, but thought it had more to do with several bad starts as I got used to Slack's way of doing things... eventually I decided I'd made enough bad starts with that installation and after reading a bit about _current fixing some stability issues added another installation to my machine using Slackware64 and upgrading to _current. It worked great, then I installed the NVIDIA proprietary driver. The system hangs are back.

Sometimes they happen quickly, sometimes they take hours, sometimes while I'm working, sometimes when the machine has been idle for hours. For a couple of days I've been going back and forth between the NVIDIA propreitary and the nv driver. I've run memtest86 for 4.5 hours and not a single error, I'm running this on a new HD, I even upgraded the case fan (the old one was starting to complain!).

I've also installed different versions of the driver 185.x.x, 190.42.x. I've used slackbuilds, I've used "sh NVIDA.xxx.RUN" I've said "yes" to everything the installer asked, I've said "no".

So far no hangs with the nv driver. I've been leaving one or the other running at all times and no hangs with the nv driver, but within hours with the proprietary driver.

All that is to say I'm confident the issue is with the NVIDIA proprietary driver, OR something in my kernel options that only shows up when I'm using the NVIDIA driver.

Is anyone else running this successfully?

SLACKWARE64 kernel 2.6.32 (same behavior on 32bit with 2.6.31.6)
compiled kernel with "make oldconfig" then "make localmodconfig" BEFORE the NVIDIA driver was installed.
ext3 filesystem (same behavior with ext4 on previous installation)
 
Old 12-15-2009, 09:53 AM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
I am using the same as you atm..
Quote:
Kernel - 2.6.32
Arch - x86_64
FS - Ext3
NVIDIA 190.42
It works fine.
Did you removepkg the slackbuilds driver before installing the Nvidia-XX.run driver?
EDIT: Just patched to 2.6.32.1 and works here too.

Regards

Last edited by ~sHyLoCk~; 12-15-2009 at 10:22 AM.
 
Old 12-15-2009, 10:11 AM   #3
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
No since Slackbuilds was the most recent attempt. My method has been to
PHP Code:
sh NVIDIA.X.X.run --uninstall
rm 
(or mv) /etc/X11/xorg.conf
startx 
after a failed attempt with the driver then scratch my head while googling for a clue.
 
Old 12-15-2009, 12:43 PM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,473

Rep: Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901
I think you NEED an xorg.conf (despite youe X version) for nvidia driver, at least these lines
Code:
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option     "Protocol"      "Auto"
    Option "Device"      "/dev/mouse"
    Option        "ZAxisMapping"       "4 5"
EndSection

Section "Device"
    Identifier  "NVIDIA"
    Driver      "nvidia"
EndSection

Section "Monitor"
    Identifier  "My Monitor"
    Option       "DPMS" "true" 
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA"
    Monitor     "My Monitor"
    DefaultDepth 24
    Subsection "Display"
        Depth       8
    EndSubsection
    Subsection "Display"
        Depth       16
    EndSubsection
    Subsection "Display"
        Depth       24
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Last edited by ponce; 12-15-2009 at 12:47 PM.
 
Old 12-15-2009, 01:12 PM   #5
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Not having a xorg.conf only works with opensource drivers. That means all the xf86-video-*'s
 
Old 12-15-2009, 06:07 PM   #6
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Not having a xorg.conf only works with opensource drivers. That means all the xf86-video-*'s
Understood. When I've installed the driver, I then set an xorg.conf file in order to load the NVIDIA driver. When I getanother system freeze and I realize that I still have not fixed the issue, then I use the above method to do away with whatever NVIDIA driver that I was using so that I can startx with the nv driver since I never know if I'm 2 minutes or 12 hours from a system freeze with the NVIDIA driver.
 
Old 12-15-2009, 11:08 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 13,215

Rep: Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772
if you are running Gnome it might be the nvidia/kernel/gnome bug
Running kde fixes that
 
Old 12-16-2009, 01:39 AM   #8
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Rep: Reputation: 34
Yep I also have kernel 2.6.32 running with Nvidia driver.
Just installed by running the installer. Works great
 
Old 12-16-2009, 07:15 AM   #9
x94qvi
LQ Newbie
 
Registered: Dec 2005
Distribution: Slackware 13.37
Posts: 26

Rep: Reputation: 16
I'm not sure if this will help you or not, but I had some weird problems with older versions of the kernel & the proprietary driver - many random freezes (sometimes when I was on, sometimes when I wasn't using the system), and the freezes always happened in X.

I was able to find some relief through a tip or two posted by a rep from NVidia here:
http://www.nvnews.net/vbulletin/showthread.php?t=58498

In my case, I took the suggestions about adding pci=nommconf & idle=poll kernel parameters, and that seemed to do the trick for me. (My system is dual core)

I know it's an older post, but it may be worth trying anyhow.
 
Old 12-16-2009, 01:20 PM   #10
flayzernax
Member
 
Registered: Jul 2004
Location: FL
Distribution: Slackware
Posts: 37

Rep: Reputation: 16
I think the NVIDIA-XXXXXX-pkg-run script from their site is good for fixing your xconfig (it will back up the old one), it will also search for and replace /disable the old nvidiafb modules and it also does a very good job at removing any wierd opengl/mesagl libs/dependencies and replacing them with nonconflicting ones.... their installer code is pretty awseome. I do not recommend using a pre-built package of the NVIDIA drivers.

just grab the kernel source and unpack it to /usr/src/linux-kernelversion (or if you install it from a repository/package it will do it for you) then run the nvidia installer from runlevel 3 (X, or Xlogin like KDM not started)

don't have to worry about much configuration then. In like 4 years i never had a problem doing it this way...

also there were some command line arguments to pass to the PKG-run script from NVidia that would unpack that and put a folder with some docs and let you make/compile your own module for your kernel, in those docs is just about everything you can check to see what could be causing your probs...

I'm currently running 2.6.32.1 KDE4 no problems

Last edited by flayzernax; 12-16-2009 at 01:22 PM.
 
Old 12-16-2009, 02:04 PM   #11
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Thanks for all of the replies. I'm not sure where things stand at the moment as I'm testing again. I'm trying passing kernel options from the post above at the moment. I am fairly sure that my problems arise from 1 of 2 sources: I'm missing something when I configure my own kernels or perhaps the video card is experiencing a slow and at least for me PAINFUL death! LOL

On the bright side I've earned some good experience with compiling/recompiling kernels
setting up dkms
getting around without X
how to pass kernel options at boot
editing grub
editing xorg.conf
AND I haven't had to redo a Slackbuild on this entire installation (hey, it was a slow start with slack LOL)
 
Old 12-16-2009, 11:46 PM   #12
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Originally Posted by ~sHyLoCk~ View Post
I am using the same as you atm..


It works fine.
Did you removepkg the slackbuilds driver before installing the Nvidia-XX.run driver?
EDIT: Just patched to 2.6.32.1 and works here too.

Regards
I have to ask.....what path did you take to your current kernel? Were there intermediate kernels between the stock kernel and current? What make target did you use? I've tried 2.6.32.1 and 2.6.32. and I've tried multiple builds. Most recently I did
PHP Code:
make oldconfig 
from the 2.6.29.6 that doesn't fail and just held enter at the new options.
I've followed alien BOB'S slackware kernel roll to the letter, even a seperate build directory at /kernelbuild. I am just stumped. I have yet to get 2.6.29.6 to hang, and I can't get 2.6.32 to hang when I run without the NVIDIA proprietary driver.

Last edited by damgar; 12-16-2009 at 11:55 PM.
 
Old 12-17-2009, 12:25 AM   #13
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 106Reputation: 106
I just compiled 2.6.32.1 and I'm running the latest nvidia drivers with no problems. One thing that I always do when compiling a new kernel, I copy the .config file from the stock Slackware kernel into the new one. For example:
Code:
cp /usr/src/linux-2.6.29.6/.config /usr/src/linux-2.6.32.1
Then, I run:
Code:
make oldconfig
Then follow the rest of Alien Bob's tutorial:
Code:
make bzImage modules
make modules_install
...etc
 
Old 12-17-2009, 01:03 AM   #14
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
damgar

I patched 2.6.32 source.

Regards
 
Old 12-19-2009, 10:24 AM   #15
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Original Poster
Rep: Reputation: 201Reputation: 201Reputation: 201
Thanks to PTrenholme at http://www.linuxquestions.org/questi...cpugpu-776169/ pointing me towards the bios again.
I am running on the latest stable kernel with no crashes for 15 hours now! I feel like I should have caught this 2 weeks ago when I looked in the bios but the setting "pci express frequency = auto" looked innocuous enough, but setting it manually seems to have been the answer all along.

I'm still not sure what changed between 2.6.30.10 and 2.6.31.6 that caused the bios setting to no longer work, any ideas or pointers on figuring that one out are appreciated.

On the bright side I am a much smarter noob today than I was 2 weeks ago with all the things I learned that DIDN'T WORK! LOL

THANKS TO EVERYONE FOR YOUR REPLIES.

PHP Code:
USER@dtest:~# uname -r
2.6.32.1 
WOOHOO!

Last edited by damgar; 12-19-2009 at 10:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVidia proprietary driver + suspend to ram (Slackware 12.1) El Nigromante Slackware 6 10-15-2008 12:16 PM
nvidia driver 'missing' after ~current and running sh NVIDIA soylentgreen Slackware 13 03-26-2007 10:17 PM
LXer: NVIDIA Proprietary Linux Display Driver 1.0-9755 LXer Syndicated Linux News 0 03-09-2007 07:17 PM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 07:51 AM
Here is how to get the nvidia driver running on Suse and keep it running!!! darkhatter Suse/Novell 4 01-03-2006 04:32 PM


All times are GMT -5. The time now is 06:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration