LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-16-2008, 01:27 AM   #1
xerio
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Rep: Reputation: 0
ipw2200 wireless slackware 12 wpa-eap


Ok. I just installed slackware 12 on my laptop which has a built in Intel Pro Wireless 2200 card in it. I did
Code:
dmesg | grep "ipw"
to find out about my wireless card and found out the firmware wasn't installed. So I downloaded the firmware and copied the correct files to /lib/firmware/ and rebooted. Did the whole dmesg and grep thing again and got
Quote:
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.0kmprq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
So I assume my wireless card is detected and all. Now here's my problem(I think). My school uses some type of WPA encryption for students to log on to the wireless network. I know it's not WPA-PSK because in the pdf for how to set it up under Windows it says specifically to not choose WPA-PSK. It also says to set the encryption method to AES and to use Protected EAP(whatever those are). My wpa_supplicant.conf file is still in the default state.
Quote:
# See /usr/doc/wpa_supplicant-0.5.7/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
scan_ssid=0
ssid="your_essid_here"
proto=WPA
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
psk=your_psk_here
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
# You'll need a recent version of wireless-tools for this!
network={
ssid="any"
key_mgmt=NONE
priority=2
}
So my question is this: What would I need to do to configure my wireless card to connect to the network? Sorry if this is a stupid question. But I've search google for the past three days and I can't find an answer. Thanks in advanced for any help.

Xerio

P.S. I just looked through the wpa_supplicant.conf.sample file. And I think what I would need to do would be to add another network={} entry that reads something like
Quote:
network={
scan_ssid=0
ssid="msu1x"
proto=WPA
key_mgmt=WPA-EAP
eap=PEAP
identity=username
password=password
phase2="auth=MSCHAPV2"
}
Any help is greatly appreciated.
 
Old 01-16-2008, 02:27 AM   #2
xerio
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Nevermind! The network={} thing was correct. And I used the wpa_supplicant command from this post and got it all working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ipw2200 WPA-PSK pyre Linux - Wireless Networking 2 08-07-2007 04:02 AM
Slackware 12 - wireless with 2200bg and wpa Slackovado Slackware 7 07-22-2007 03:20 AM
[ipw2200 & WPA] Need help to connect to WPA enabled router. Hyakutake Slackware 2 03-02-2007 09:58 AM
WPA-TKIP ipw2200 havelino Linux - Wireless Networking 0 04-24-2005 10:24 AM
WPA & ipw2200 havelino Linux - Wireless Networking 5 03-26-2005 06:57 PM


All times are GMT -5. The time now is 04:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration