LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2003, 03:56 PM   #1
kiddyo
LQ Newbie
 
Registered: Feb 2003
Location: U.K
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
Internet connection


My Linux running pc is connect to a router with another 2 WindozeXP pc's and i'am having problems connecting to the internet, i have run netconfig with out success.

my netcofig settings:
IPADDR:192.1.1.101
NETMASK:255.255.255.0
NETWORK:192.1.1.0
BROADCAST:192.1.1.255
GATEWAY:192.168.1.1 - IP address of router?

Please note i'am a new user to both Linux and slackware.

Cheers!

Last edited by kiddyo; 02-24-2003 at 04:32 PM.
 
Old 02-24-2003, 03:59 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Do you have /etc/resolv.conf with DNSes?
 
Old 02-24-2003, 04:12 PM   #3
kiddyo
LQ Newbie
 
Registered: Feb 2003
Location: U.K
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
checked my /etc/resolv.conf file just says 'search home'?

also when setting up netconfig i chose static IP with no named server was this correct?

Last edited by kiddyo; 02-24-2003 at 04:30 PM.
 
Old 02-24-2003, 06:56 PM   #4
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
You will probably need to run netconfig again and set your DHCP to the gateway server name and ip--even though you'll have a static IP of 192.1.1.101. This way, it looks for the proper location to get its IP and will be able to obtain its static IP. I could be totally wrong here, but I think this should work.

Either way, you'll have to run netconfig again, and edit your /etc/resolv.conf to add the proper DNS entries:

search (domain name--most likely your gateway server)
nameserver xxx.xxx.xxx.xxx primary DNS IP
nameserver xxx.xxx.xxx.xxx secondary DNS IP

Since you're connecting to a gateway server, you should use your gateway's IP address here. Like I said, I'm not 100% sure on this, but that's how I would start. Hope this helps
 
Old 02-24-2003, 07:48 PM   #5
kiddyo
LQ Newbie
 
Registered: Feb 2003
Location: U.K
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Cheers all just went through netconfig again this time using DHCP clicked O.K and every thing seems to be working fine!

So thanks again!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 12:48 PM
Messed up my internet settings (NO internet connection) :( Almazick Linux - Networking 2 09-08-2004 01:05 PM
My internet apps cannot detect my internet connection esthon_wood Mandriva 5 08-30-2004 09:38 PM
i can get internet connection in windows but in LINUX there is no connection ruzvay Linux - Networking 2 06-08-2004 08:02 PM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration