LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-05-2012, 03:11 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,276

Rep: Reputation: 49
Internet conexion slowed down, but only for linux.


Hi:

Sorry for a poor description of the problem, but my knowledge about LAN and internet is zero. My internet conexion has suddenly slowed down. But Windows XP connectivity has not been affected. Linux is the O.S. that seems to have a problem. I never experienced an issue like this before!

The modem is straightforwardly connected to my machine, no hub. The conexion is DHCP, if I do not misspell it, the most common nowadays. Normally Google loads instantly, now it takes as long as 5 seconds. Any data I can send to help solve the issue please let me know.


Kernel 2.6.21.5
Slackware 2.6.21.5

Last edited by stf92; 08-05-2012 at 04:10 AM.
 
Old 08-05-2012, 03:37 AM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
cat /etc/resolv.conf
ip addr show
ip route show
 
Old 08-05-2012, 04:09 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,276

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by wildwizard View Post
cat /etc/resolv.conf
ip addr show
ip route show
Code:
semoi@darkstar:~$ cat /etc/resolv.conf
# Generated by dhcpcd for interface eth0
search fibertel.com.ar
nameserver 200.49.130.44
nameserver 200.42.4.207
nameserver 172.20.2.26
semoi@darkstar:~$
Code:
root@darkstar:~# ip addr show
1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,NOTRAILERS,UP,10000> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:e6:49:b4:be brd ff:ff:ff:ff:ff:ff
    inet 190.244.61.85/24 brd 255.255.255.255 scope global eth0
    inet6 fe80::20a:e6ff:fe49:b4be/64 scope link
       valid_lft forever preferred_lft forever
root@darkstar:~#
 
Old 08-05-2012, 04:27 AM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
I don't know if its just your ISP blocking outside connections or not but try these in resolv.conf

nameserver 8.8.8.8
nameserver 8.8.4.4

delete the other ones for the time been and test, just remember that your file will be overwritten by dhcp if the connection is restarted for any reason.

EDIT Those are Google's servers
 
Old 08-05-2012, 04:40 AM   #5
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 770

Rep: Reputation: 94
You might want to disable ipv6 (use ipv6.disable=1) as a kernel boot option. And reduce your eth0 mtu rate to 1458.
 
Old 08-05-2012, 05:26 AM   #6
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
The scope link ipv6 address will not cause problems, any other sort of ipv6 address would.

A quick test to see is the MTU needs changing is start a large download and see if the transfer rate suffers. A slow start but good data flow means the MTU is not the problem.
 
Old 08-05-2012, 06:21 AM   #7
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 770

Rep: Reputation: 94
It's well know that win XP does not support ipv6 out of the box. It is not unusual, indeed it seems to be the preferred advice that when a network link exhibits slow response in Linux, where it does not under Win XP that ipv6 is generally the culprit. Not saying that is the case here, but it is a good starting point, and in an attempt to try as much as possible to emulate the networking stack that Win XP is using, then disabling ipv6 in Linux is the start point to aim for. As for the mtu test, it really depends on the ISP. Hence the suggestion to drop it to 1458. Again a starting point which probably will benefit from fine tuning, but a good starting point nonetheless.
 
Old 08-05-2012, 07:06 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,276

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by wildwizard View Post
I don't know if its just your ISP blocking outside connections or not but try these in resolv.conf

nameserver 8.8.8.8
nameserver 8.8.4.4

delete the other ones for the time been and test, just remember that your file will be overwritten by dhcp if the connection is restarted for any reason.

EDIT Those are Google's servers
I did it and things are now as before: quick. But this is not a permanent solution. Is it?

EDIT: I do not quite understand:
(a) Is then my ISP guilty?
(b) I rebooted and, however, I now have normal speed!

Last edited by stf92; 08-05-2012 at 07:14 AM.
 
Old 08-05-2012, 07:32 AM   #9
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,276

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by vdemuth View Post
You might want to disable ipv6 (use ipv6.disable=1) as a kernel boot option. And reduce your eth0 mtu rate to 1458.
I also booted with ipv6 disabled but now the connection is slow again. How do I reduce eth0 mtu rate?

Last edited by stf92; 08-05-2012 at 08:19 AM.
 
Old 08-05-2012, 08:25 AM   #10
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
If by changing the DNS servers things changed then it's possible your ISP is having issues with it's DNS servers.

You can check that the ipv6.disable works by looking at the output from "ip addr show" there should not not be any inet6 addresses listed on any interface.

If your using the standard Slackware rc.inet1.conf then you can keep the google DNS servers by using the DHCP_KEEPRESOLV[1]="yes" directive.

If things have improved without playing with the MTU then don't worry about it, just concentrate on what has been changed as the answer lies there.

My money is on your ISP having a bad day, this is also the time of the week when they like to push updates out to their networks.
 
Old 08-05-2012, 06:09 PM   #11
Pixxt
Member
 
Registered: May 2008
Distribution: Slackware, Debian,
Posts: 108

Rep: Reputation: 25
Have you tried to use other browsers and/or other programs that use your connection to rule out a misbehaving program?
 
Old 08-05-2012, 06:42 PM   #12
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Try to upgrade Firefox as well to see if that helps, and check if some extensions can cause the slowness.
 
Old 08-06-2012, 07:18 PM   #13
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,276

Original Poster
Rep: Reputation: 49
If any of you guys is curious to know what happened then see this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet slowed down big, and I've turned into a German? lugoteehalt Linux - Security 3 11-25-2009 11:46 PM
internet connection slowed down in extended star network AeonX Linux - Networking 5 09-14-2009 05:28 PM
Two NIC's to share an Internet Conexion abenavar Linux - Networking 0 08-26-2007 11:57 AM
Linux slowed my system way down des33 Linux - Newbie 1 03-08-2005 03:44 PM
internet connection slowed down israel Linux - Software 4 10-07-2003 10:12 PM


All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration