LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-17-2007, 09:51 AM   #1
beartooth91
LQ Newbie
 
Registered: Feb 2006
Posts: 27

Rep: Reputation: 15
Question Intermittent "Server Not Found" Problem


Hi All,

Long time Linux user here and using Slack for the last 2-3 years. I have a pesky little problem that I can't seem to figure out -

While surfing the internet; Firefox has intermittent problems finding webpages - I get the "Server Not Found" display.
This particular PC is dual boot - Slack or WinXP. I do not have the problem in XP. I do, however, have the problem with both Slack 11 and Slack 12 versions. I'm currently running Slack 11 (huge26.s) with Dropline 2.16.1. It occurs the same regardless of whether or not Dropline is installed. I have my ISP's name servers listed in resolv.conf. Ifconfig eth0 seems to reveal no obvious problems and I am able to ping other IP's even when the problem occurs. It seems to be totally intermittent. Other than DLG; the only other potentially-related change I've made is disabling ipv6 (alias net-pf-10 off in modprobe.conf and blacklist ipv6 in blacklist). The PC is connected to a Linksys WRT54GS Broadband Router. I'm using a static IP address for the PC.

Can anyone point me in the right direction as to troubleshooting this ?
Thanks,

Mark
 
Old 09-17-2007, 10:20 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,022
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Hi,

If it is an ISP DNS problem you could include a third level DNS in your '/etc/resolv.conf' file.

Code:
Verizon has;

4.2.2.1
4.2.2.2
4.2.2.3
4.2.2.4
You could include these or just one to the top of the config file to test an see if the problem is with your ISP DNS.

BTW, show us the '/etc/resolv.conf' file.
 
Old 09-17-2007, 10:36 AM   #3
beartooth91
LQ Newbie
 
Registered: Feb 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks for the reply, Onebuck:

/etc/resolv.conf:

nameserver 192.168.1.1 #router
nameserver 69.145.248.50
nameserver 69.145.232.4
nameserver 69.145.248.4
search hosts.bc1.bresnan.net
 
Old 09-17-2007, 11:42 AM   #4
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
You might want to remove the router from the list (I don't think Linksys routers -- at least the ones I have -- are DNS servers).

You might also want to try:
Code:
search com
nameserver 69.145.248.50
<others>
Are you sure that all those domain names are actually name servers?
 
Old 09-17-2007, 03:50 PM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,022
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Quote:
Originally Posted by tronayne View Post
You might want to remove the router from the list (I don't think Linksys routers -- at least the ones I have -- are DNS servers).

You might also want to try:
Code:
search com
nameserver 69.145.248.50
<others>
Are you sure that all those domain names are actually name servers?
Hi,

Most routers do have DNS tables.
 
Old 09-17-2007, 04:37 PM   #6
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,995

Rep: Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737Reputation: 737
Quote:
Most routers do have DNS tables.
Well, I'll be danged and taken out and hanged... looks like at least my Linksys' do. Sorry about that.
 
Old 09-17-2007, 09:43 PM   #7
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,452

Rep: Reputation: Disabled
Never-the-less, I would try the solution of removing the router's ip from resolv.conf. I had a similar problem and that's what worked for me. (If this does work, you'll need to configure so the router doesn't reset your resolv.conf every time you connect).

Brian
 
Old 09-18-2007, 07:37 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,022
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Quote:
Originally Posted by BCarey View Post
Never-the-less, I would try the solution of removing the router's ip from resolv.conf. I had a similar problem and that's what worked for me. (If this does work, you'll need to configure so the router doesn't reset your resolv.conf every time you connect).

Brian
Hi,

If the router is used for dhcp then the table would be presented to the request. The '/etc/resolv.conf' would not be updated by the router, the information is passed because of the query for IP from dhcp server. The dhcp allows a host(s) on a TCP/IP network to request and be assigned a IP and to get information about the network they are attached too.

You can usually disable the router DNS table but you would have to present the DNS to the user requesting an IP somehow.
 
Old 09-18-2007, 09:05 AM   #9
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,452

Rep: Reputation: Disabled
In my case, the router was configured with two dns servers. When connecting to the router with dhcp, the router passed back it's own address and one of the dns servers (that's what ended up in resolv.conf). This led to intermittent "server not found" errors in firefox. Manually replacing the resolv.conf with the two "correct" dns servers and removing the ip of the router resolved (no pun intended) the problem. I had to create a script that automatically replaced resolv.conf when connected to that particular ssid.

Brian
 
Old 09-18-2007, 07:55 PM   #10
beartooth91
LQ Newbie
 
Registered: Feb 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Thumbs up

Yesterday (Monday) I added "nameserver 4.2.2.4" to the top of and deleted the router entry from /etc/resolv.conf. The rest of the file is the same. That appears to have solved the problem - I have not had one problem with finding a webpage since. Many thanks to everyone's replies.

Mark
 
Old 09-19-2007, 06:01 AM   #11
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,022
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Quote:
Originally Posted by beartooth91 View Post
Yesterday (Monday) I added "nameserver 4.2.2.4" to the top of and deleted the router entry from /etc/resolv.conf. The rest of the file is the same. That appears to have solved the problem - I have not had one problem with finding a webpage since. Many thanks to everyone's replies.

Mark
Hi,

Then it looks like the router or the ISP DNS was the problem. Move the '4.2.2.4' down one tier in the'/etc/resolv.conf' file to see if the problem was the router. The reason to do this is propagation. Your ISP DNS should be faster than the Verizon DNS.

If you can tolerate the delay then leave it as you have it now.
 
Old 09-19-2007, 10:21 PM   #12
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
Hi,

I had a few probs (not very often) either inaccess of a www page or extremely slow loading of a www page. This is Slackware 12.0 with its generic-smp kernel.

/etc/resolv.conf had
search localdomain
nameserver 192.168.1.254

That's (nameserver line) my at&t 2wire dsl home gateway (it's a combo dsl modem, router, firewall all in one)

I've a static IP on this Slack box so resolv.conf doesn't get modified again once I've changed it.

My /etc/resolv.conf now has
search localdomain
nameserver 00.00.000.1
nameserver 00.00.000.2
nameserver 192.168.1.254

Above I changed the first two to fictitious but in my real resolv.conf is my ISP's nameservers

That sped things up some for me (now I cut direct to ISP nameservers rather than having 2wire relay the info like when 2wire was the only nameserver).

I'd been watching this thread also somehow the other evening I ended up at a www site of the Linux Network Administrator's Guide on some of its pages under the heading of "resolver"

At there, I discovered that /etc/host.conf has an order in which to query multiple sources so as to resolve (resolve a name into an IP address).

al@AB60R:~$ cat /etc/host.conf
order bind, hosts
multi on

Oop, I thought my hosts file was empty until now. my hosts file only has

127.0.0.1 localhost
192.168.1.10 AB60R.localdomain AB60R

I wonder if that is a problem above in host.conf where I swapped the order of hosts and bind.

Works great on the www. Haven't tried to network with any LAN boxes yet. I suppose it might go to my ISP's name servers looking to resolve for a box on my LAN (wouldn't resolve). Anyways I use IP's, I don't use names on my LAN -- so maybe I'm ok with it as it is? If not, I'll fix the order in host.conf

Comments, suggestions, similar experiences?

--
Alan.
 
Old 09-20-2007, 10:42 PM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,022
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Hi,

You say that you have other host(s) on your LAN. Why don't you have them in your '/etc/hosts' file?

The order within the '/etc/hosts.conf' file is just that;
Quote:
excerpt 'man hosts.conf'

order This keyword specifies how host lookups are to be performed. It
should be followed by one or more lookup methods, separated by
commas. Valid methods are bind, hosts, and nis.
You should 'man hosts', 'man hosts.conf' and 'man resolv.conf'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Fatal server error: no screens found" in gentoo andrewshen123 Linux - Distributions 33 01-21-2007 05:57 PM
"Successful install" results in "Boot device not found" slackr007 Fedora 2 06-21-2005 04:05 PM
"Successful install" results in "Boot device not found" slackr007 Linux - Newbie 2 05-31-2005 08:02 PM
"fatal server error no screens found" eslimc Linux - Newbie 2 10-13-2003 12:51 AM
XFree86: "Fatal server error: no screens found" warkrime Linux - Newbie 9 09-23-2003 07:07 PM


All times are GMT -5. The time now is 03:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration