LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-05-2004, 01:49 PM   #1
ssb
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Intellimouse Explorer USB doesn't work


Today i've installed Slack 9.1 but i have problem using Intellimouse (v4) USB in X.
In fact dev/mouse is correct as cat it returns mouse movements. The problem is that when X starts, mouse cursor only moves vertically when i move it horizontally.
Tried other protocol settings without success.
Of course gmp is disabled.

Any idea ?

Thanks
 
Old 04-06-2004, 04:26 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
edit /etc/X11/XF86Config
change your mouse protocol to ExplorerPS/2, should look like this

Option "Protocol" "ExplorerPS/2"
 
Old 04-06-2004, 04:53 AM   #3
dhbiker
Member
 
Registered: Dec 2003
Location: Bristol
Distribution: Slackware 10.2
Posts: 196

Rep: Reputation: 30
I had exactly the same problem, and clicking the buttons moves the cursor right accross the screen?

I tried every mouse protocol, eventually gave up and bought a logitech which is much nicer than the intellimouse. It might be worth trying to upgrade to the latest version of XFree86 (4.4.0), that might solve the problem
 
Old 04-06-2004, 05:07 AM   #4
mpb98
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 3

Rep: Reputation: 0
I also had this problem, and found that removing the 'usbmouse' module solved the issue.

My protocol is 'IMPS/2' by the way.
Hope this helps!

Cheers.
 
Old 04-10-2004, 10:59 PM   #5
GM287
LQ Newbie
 
Registered: Apr 2004
Location: Sydney - OZ
Distribution: Slackware 9.1
Posts: 16

Rep: Reputation: 0
errr... dumb question but how do you remove the usbmodule?
 
Old 04-11-2004, 06:47 AM   #6
dhbiker
Member
 
Registered: Dec 2003
Location: Bristol
Distribution: Slackware 10.2
Posts: 196

Rep: Reputation: 30
type
Code:
rmmod usbmouse
in a terminal (you need to be su before it'll let you do it)
 
Old 04-11-2004, 09:31 AM   #7
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
Mine works fine. I do not use hotplug. I went into /etc/rc.d/rc.modules and uncommented out the modules that I wanted to run. On mine, I uncommented hid, mousedev, keybdev, usb-uhci. Then run mouseconfig and pick the usb mouse. I then edit the /etc/X11/XF86Config file and put for Protocol , the IMPS/2 entry listed above. For Device, I put /dev/input/mice. Another option you probably want "ZAxisMapping" "5 4" for scrolling. HTH
 
Old 10-21-2006, 12:07 AM   #8
18thBronzeman
LQ Newbie
 
Registered: Oct 2006
Distribution: slackware
Posts: 18

Rep: Reputation: 0
is there a way to run the rmmod command permanently? modprobe -r?
 
Old 10-21-2006, 01:07 AM   #9
18thBronzeman
LQ Newbie
 
Registered: Oct 2006
Distribution: slackware
Posts: 18

Rep: Reputation: 0
i wanted to clarify my question. the issue was solved by running the command 'rmmod usbmouse', as posted by dhbiker. this solves the issue for the current boot. if the system is rebooted the issue returns. if you run this and your box stays up for a year you might be in trouble when you finally do reboot. this brings up two questions:

01. how would you make this change permanent? remove the usbmouse module from the bootup process.

02. i looked in the rc.modules file and the usbmodules line was commented out. i also looked in the '/lib/modules/2.4.31' directory and don't see any reference to the usbmouse module (bundled?). so what is launching this and how do i stop this and other modules from loading?
 
Old 10-22-2006, 06:46 AM   #10
dhbiker
Member
 
Registered: Dec 2003
Location: Bristol
Distribution: Slackware 10.2
Posts: 196

Rep: Reputation: 30
I presume it's being loaded by hotplug. The way to prevent it from ever being loaded is to add the module to the blacklist file (IIRC it's in /etc/hotplug/blacklist)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intellimouse Explorer Doesn't work (Suse 9.3) Murdoc Linux - Hardware 1 11-05-2005 01:52 PM
MS intellimouse explorer USB wireless Wont work Mandrake 9.1 mattv2kx Linux - Hardware 6 11-04-2003 12:53 PM
Can't make USB Intellimouse explorer work Johnnie Walker Slackware 2 08-10-2003 12:42 AM
MS Wireless USB intellimouse Explorer nitewulf50 Linux - Hardware 2 11-23-2002 05:20 PM
MS Wireless Intellimouse Explorer will not work with Mandrake 8.2 PSB Linux - Newbie 2 10-20-2002 11:32 AM


All times are GMT -5. The time now is 11:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration