LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-12-2008, 05:34 PM   #1
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
Intel G33 chipset integrated onboard video and Slackware 12.1 refresh HZ too low crt


Hi,

BTW, I'm glad I've been using Slackware ever since Slackware 10.0 was released.

(as far as my video goes) all I want to do is to run a virtual machine ie KVM, virtualbox, etc.) -- no gaming, no movies, no video editing, nothing that places a high demand on video)

But if you tell me that, per my below listed hardware, such listed video is not so Linux compatible then I'd consider to get a PCI express video card.

Otherwise, what can I do to get my onboard integrated video working better?

1. Did a fresh install of Slackware 12.1 onto

2. Already tried xorgsetup also tried xorgconfig

3. Now have got X works but *only* at 60 HZ refresh 1024x768 (far too flickery for me)

Monitor is a CRT, a Viewsonic A90f+ (it is 1280xwhatever at 75 HZ capable)


My goal is:
I need to make available some higher refresh rates and also another res. size, just one res. size above the 1024x768.

**So, (*perhaps*??) all I need to do is, in my xorg.conf, 1. add a displaysize= 2. add in some horiz. and vertical refresh rates

Though I still do have a copy of (I guess it's Patrick V's xorg.conf ie has his name inside it - BTW which it also has the same prob of 60 HZ refresh) xorg.conf -- my currently in use xorg.conf came from running one of the listed setup/config

And, the evidence suggests/appears the correct Intel driver being loaded.

My hardware is: ECS G33T-M2 motherboard; using (or trying to use) the motherboard's onboard intel video; 1 sata HD on the first sata controller; a pci Promise IDE controller card in the first pci slot with a PATA dvd burner hooked to it; more than enough ram; cpu is Intel Core 2 duo - I forget what GHZ - somewhere near 2.4 GHZ

BTW, xdpyinfo returned "unable to open display "".

xorg.conf
http://acummingsus.googlepages.com/xorg.conf.cat.txt

Xorg.0.log
http://acummingsus.googlepages.com/Xorg.0.log.txt

Hardware, lspci, output:

Code:
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IB (ICH9) 2 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
07:02.0 Mass storage controller: Promise Technology, Inc. PDC20268 (Ultra100 TX2) (rev 01)
xorg.conf that I'm currentl using:

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/share/X11/rgb"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
	Load  "extmod"
	Load  "record"
	Load  "xtrap"
	Load  "GLcore"
	Load  "dbe"
	Load  "glx"
	Load  "dri"
	Load  "type1"
	Load  "freetype"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option       "XkbModel"  "pc101"
	Option       "XkbLayout"  "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "DRI"                	# [<bool>]
        #Option     "NoDDC"              	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "82G33/G31 Express Integrated Graphics Controller"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
--
Alan.
 
Old 10-12-2008, 05:52 PM   #2
jumapeg
Member
 
Registered: Jul 2006
Location: Spain
Distribution: Slackware current
Posts: 32

Rep: Reputation: 15
Hello!

Try this command (as normal user):
Code:
xrandr -s 1280x1024 -r 75
If that code hasn't helped search more info about xrandr tool and intel driver (both have man pages).
 
Old 10-13-2008, 06:19 AM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 49
Got it flying nice! 75 refresh rate. Smooth.

(xrandr reported 75 that refresh rate is not avilable)

Then I stole the next bit from my 12.0 installation on different hardware and used it on my 12.1 with Intel G33 and integrated graphics controller

Replaced the above (in code tags) listed monitor section of xorg.conf with the next monitor section. And also use the next startx command to startx (nice, for my old eyes), xpdyinfo now reports dpi of 100 brings a bit larger text on the desktop (had been 88 dpi with text on desktop too small for me)

startx -- -dpi 100

Section "Monitor"
DisplaySize 360 270 # mm
#DisplaySize 290.88 218.16
Identifier "Monitor0"
VendorName "VSC"
ModelName "A90f+"
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync 30.0 - 86.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

--
Alan.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Driver - Intel(R) G33/G31 Lx4l720 Ubuntu 4 09-30-2009 03:37 AM
How do I get an Intel 82815 video chipset working on Slackware 12.1 NetTech21 Linux - Newbie 1 06-24-2008 12:27 AM
Motherboard, integrated video chipset and Linux mofo Linux - Hardware 2 04-18-2006 07:46 PM
intel i855 chipset crt flickers when used concurrently with lcd verdeboy2k Linux - Hardware 1 02-26-2006 05:06 AM
INTEL I865 Chipset Onboard sound joh_84 Linux - Hardware 3 06-01-2004 02:14 PM


All times are GMT -5. The time now is 01:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration