LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-03-2010, 08:35 AM   #1
TwinReverb
Member
 
Registered: Sep 2008
Location: Misawa AB, Japan
Distribution: Slackware
Posts: 191
Blog Entries: 2

Rep: Reputation: 40
Intel Framebuffer in -Current Does Not Honor vga=normal


Hello all,

I am using the most recent -current (that fixes the libpng "ratness" described in the ChangeLog 8-) and the Intel Framebuffer setup is annoying me. I specify vga=normal in LILO and to my knowledge I am not asking Intel Framebuffer modules to load at boot (and intelfb is blacklisted).

It's annoying because it makes the text microscopic. However, the machine works great in -Current so I can't complain. Graphics work fine and so does X, it's just annoying.

This is my Sony Vaio VGN-C140G detailed here:
http://www.puresimplicity.net/~delah...sony/sony.html

I had tried previously blacklisting inteldrmfb as well (the -Current release right before the libpng fix) and that made no difference.

I found all binaries with "intel" in their name and read the manual pages but didn't find anything useful for possibly manually setting the mode back to something equivalent to vga=normal.

Thanks!

- Robert

By the way, can someone please change my user name on this forum to "Robert Delahunt" or "radelahunt"? Thanks....
 
Old 03-03-2010, 11:05 AM   #2
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
This sounds like kernel mode setting to me. It's the default in the latest kernels. With kms you don't use a vga line at all in lilo.
 
Old 03-03-2010, 11:18 AM   #3
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
You should be able to disable kernel modesetting with the 'nomodeset' option on the kernel command line. At least that works for radeon cards, and I *believe* it works for intel GPUs too.

Adam
 
Old 03-04-2010, 05:46 AM   #4
TwinReverb
Member
 
Registered: Sep 2008
Location: Misawa AB, Japan
Distribution: Slackware
Posts: 191
Blog Entries: 2

Original Poster
Rep: Reputation: 40
Tried nomodeset but then X complains that it can't talk to the modesetting driver so X won't start.

Sorry, I'll be back online later. I've been in the air 15 hours, gotta get some sleep. Thanks though!
 
Old 03-04-2010, 06:01 AM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Yeah, I thought the intel driver might be dependent on KMS these days. I know with radeon you can specify a resolution with 'video=1024x768' on the kernel command line. Perhaps the same is true with intel.

Adam
 
Old 03-04-2010, 08:17 AM   #6
DonnieP
Member
 
Registered: Jan 2008
Location: Richmond, VA USA
Distribution: Slackware
Posts: 144

Rep: Reputation: 29
This blogger has posted many times about video problems with Intel KMS:
http://www.insidesocal.com/click/201...eeling-in.html
Basically, the combination of latest kernel, latest xorg and latest Intel driver results in nomodeset no longer being an option and kms is required. Unfortunately, some equipment simply won't work (currently) with kms.
 
Old 03-04-2010, 08:25 AM   #7
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Hah... They talk about switching to FreeBSD... I guess they are unaware tht FreeBSD is even worse off for Intel GPU users. FreeBSD does not support KMS, so newer versions of the intel driver won't work on FreeBSD at all. In addition, the current version in FreeBSD ports does not work on newer versions of the X server. So when the ports tree finally gets a newer Xserver, there is a good chance that intel users will be forced to use the vesa driver unless one of those two situations is resolved.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
linux framebuffer use instead of normal x and whatnot thehardcore8 Linux - Software 1 10-21-2009 06:13 PM
setting framebuffer (vga mode) after booting zoombee Linux - General 2 12-04-2008 05:41 PM
framebuffer and vga settings.... Basslord1124 Slackware 5 12-13-2005 08:32 PM
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel brancalessio Slackware 3 01-20-2005 03:21 PM
Console, VESA VGA, Framebuffer Support Question chrisk5527 Linux - General 0 11-01-2004 10:15 PM


All times are GMT -5. The time now is 07:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration