LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-07-2009, 06:06 PM   #1
biske
Member
 
Registered: Dec 2007
Location: Srbija, Kosovo i Metohija
Distribution: Ubuntu
Posts: 46

Rep: Reputation: 17
Intel 536 problem on Slackware 12.0.


I downloaded intel536 driver intel-536EP-2.56.76.0_2008_11_15.tar.bz2, unpacked, cd into directory and wrote next command:

make clean

then i wrote:

make 536

but there is an error. Here it is:

Module precompile check
Current running kernel is: 2.6.21.5-smp
/lib/modules... autoconf.h exists
autoconf.h matches running kernel
version.h matches running kernel
uname -r|grep "2.6" && \
cd coredrv && make 536core_26 && \
cp Intel536.ko .. && cd .. && \
strip --strip-debug Intel536.ko && \
exit; \
ls Intel536.ko >/dev/null 2>&1 || uname -r | grep "2.6" && echo "Failed to build driver" && exit; \
if [ ]; then \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_SOURCE_PATH= "PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
else \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_INCLUDES=/lib/modules/`uname -r`/build/include \
"PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
fi ; \
cp Intel536.o .. ; \
if [ -a /boot/vmlinuz.version.h ]; then \
cp /boot/vmlinuz.version.h /lib/modules/`uname -r`/build/include/linux/version.h;\
fi
2.6.21.5-smp
make[1]: Entering directory `/root/modem/Modemi Intel 536 i 537/intel-536EP-2.56.76.0/coredrv'
make -C /lib/modules/2.6.21.5-smp/build SUBDIRS=/root/modem/Modemi Intel 536 i 537/intel-536EP-2.56.76.0/coredrv modules
make[2]: Entering directory `/usr/src/linux-2.6.21.5'
make[2]: Leaving directory `/usr/src/linux-2.6.21.5'
make[1]: Leaving directory `/root/modem/Modemi Intel 536 i 537/intel-536EP-2.56.76.0/coredrv'
2.6.21.5-smp
Failed to build driver



I installed again kernel source and kernel headers packages but there is an error again.
Can anyone help me or give me some usefull link?
 
Old 01-08-2009, 04:18 AM   #2
biske
Member
 
Registered: Dec 2007
Location: Srbija, Kosovo i Metohija
Distribution: Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 17
Can anyone help? i was ssearching this forum but can't find answer.
 
Old 01-08-2009, 10:21 AM   #3
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
You try to compile a 2008_11_15 version on a relatively old system.
Try to download an older version.
12.0 was released the Sun Jul 1 22:30:42 CDT 2007
 
Old 01-08-2009, 08:23 PM   #4
biske
Member
 
Registered: Dec 2007
Location: Srbija, Kosovo i Metohija
Distribution: Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 17
I will try and tell you what happen. thnx
 
Old 01-09-2009, 10:09 AM   #5
biske
Member
 
Registered: Dec 2007
Location: Srbija, Kosovo i Metohija
Distribution: Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 17
Just one question before installing driver: Does I have to do any patch to kernel?

Last edited by biske; 01-09-2009 at 10:10 AM.
 
Old 01-09-2009, 04:40 PM   #6
biske
Member
 
Registered: Dec 2007
Location: Srbija, Kosovo i Metohija
Distribution: Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 17
I found somewhere on my hard old version of driver intel-536EP-2.56.76.0_23_02_2007.tgz. First and second steps now works without errors (commands make clean and make 536). But where I type:

make install

it gives me next output:

rm -f /etc/hamregistry.bin
bash Intel536_inst
running kernel 2.6.21.5-smp
installing hamregistry, used for persistant storage
installing Intel536 driver
unknown distribution - no boot scripts have been installed
make: *** [install] Error 1
 
Old 01-10-2009, 07:59 AM   #7
biske
Member
 
Registered: Dec 2007
Location: Srbija, Kosovo i Metohija
Distribution: Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 17
I installed driver and now works fine. Problem was script Intel536_inst but I took few changes on it and then installed driver. Thnx a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.2 and Intel 536 modem driver Andersen Slackware 1 12-14-2008 02:04 PM
Intel 536 Modem Problem kingfish Ubuntu 2 12-14-2005 09:39 AM
Intel 536 modem Trio3b Mandriva 0 02-07-2005 12:29 AM
Intel 536 modem Trio3b Linux - Newbie 0 02-04-2005 11:50 PM
Intel 536 ep Mandrake 10.0 PsychoDrake Mandriva 5 09-03-2004 07:57 PM


All times are GMT -5. The time now is 06:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration