LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-22-2010, 07:16 PM   #1
grimx
Member
 
Registered: Oct 2008
Distribution: Slackware 14 i686
Posts: 111

Rep: Reputation: 16
installing wxGTK SlackBuild


when i try to install wxGTK SlackBuilds.org
i get this error:
Code:
./src/aui/auibook.cpp: In member function 'size_t wxAuiNotebook::SetSelection(size_t)':
./src/aui/auibook.cpp:3482: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [auidll_auibook.o] Error 1
i tried redownloading the wxGTK-3.8.9.tar.gz file
and reinstalling it, i get the same error.
 
Old 03-22-2010, 07:22 PM   #2
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.0, 13.1, 13.37, 14.0, 64-14, -current
Posts: 1,507

Rep: Reputation: 499Reputation: 499Reputation: 499Reputation: 499Reputation: 499
Not a wxGtk error

That appears to be a gcc error, not a problem with the wxGtk source, if I am not mistaken.

How about some details on your system, slackware version, etc.
 
Old 03-22-2010, 07:28 PM   #3
grimx
Member
 
Registered: Oct 2008
Distribution: Slackware 14 i686
Posts: 111

Original Poster
Rep: Reputation: 16
Slackware 13, 32 bit, KDM, KDE
 
Old 03-22-2010, 07:38 PM   #4
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 639

Rep: Reputation: 90
Hi,

Quote:
Originally Posted by grimx View Post
i tried redownloading the wxGTK-3.8.9.tar.gz file
and reinstalling it, i get the same error.
I presume this is a typo for wxGTK-2.8.9.tar.gz? I have just compiled this with no trouble under 32bit Slackware 13.0 as a dependency for mkvtoolnix...

Andrew
 
Old 03-22-2010, 07:39 PM   #5
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
Can you compile anything else? Maybe you could try with wxPython instead of wxGTK (which is already included in wxPython).

Edit:

Since it is not reproducible (andrew.46's post), it is quite possible that your problem is installation specific or even hardware-related. It is probably best to have whole a/, ap/, d/ and l/ Slackware packages group installed (in case you removed some package by hand) and then try again.

Last edited by kukibl; 03-22-2010 at 07:42 PM.
 
Old 03-22-2010, 07:45 PM   #6
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.0, 13.1, 13.37, 14.0, 64-14, -current
Posts: 1,507

Rep: Reputation: 499Reputation: 499Reputation: 499Reputation: 499Reputation: 499
Quote:
Originally Posted by grimx View Post
i tried redownloading the wxGTK-3.8.9.tar.gz file
and reinstalling it, i get the same error.
I also asume that you mean v2.8.9, but just to be sure, did you check the MD5 of the source?

You also said you tried to "install", I assume you mean build?

To keep me from assuming too much, could you be a little more complete on what you are doing before this point, and a little more on your system, memory, speed, full install, etc., and is this a new install of SW 13 or an otherwise stable box?
 
Old 03-22-2010, 07:58 PM   #7
grimx
Member
 
Registered: Oct 2008
Distribution: Slackware 14 i686
Posts: 111

Original Poster
Rep: Reputation: 16
it's wxGTK2.8.9, slackbuild from SlackBuilds.org
new install Slackware 13, stable, 32 bit

Athlon (T) XP2200+ 1.8 GHz/266
512/2100 DDR
120 gig harddrive
 
Old 03-22-2010, 08:01 PM   #8
escaflown
Member
 
Registered: Apr 2009
Location: Canada
Distribution: Slackware
Posts: 235

Rep: Reputation: 30
Try wxPython. It includes wxGTK. There is a patch for the wxPython slackbuild in Ponce's git repository: http://github.com/Ponce/SBo-git . Use the branch wxPython. I tried it and it worked for me.
 
Old 03-22-2010, 08:51 PM   #9
grimx
Member
 
Registered: Oct 2008
Distribution: Slackware 14 i686
Posts: 111

Original Poster
Rep: Reputation: 16
i installed downloaded wxGTK-2.8.10-i486-1alien.tgz
from http://connie.slackware.com/~alien/s...xGTK/pkg/13.0/

and it installed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackbuild MPlayer trouble installing DaveXensen Linux - Desktop 1 02-13-2007 02:29 PM
problem in installing wxGTK-2.6.2 on fedora 4 mohtasham1983 Linux - General 3 02-21-2006 09:47 AM
problem installing wxGTK in gentoo matrixon Linux - Software 7 04-25-2005 12:58 AM
problem installing wxGTK for audacity lnebrown Linux - Software 1 01-31-2005 01:30 PM
lMule wxGTK and wxGTK-devel Caveman Linux - Software 3 10-15-2003 11:38 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration