LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-14-2010, 08:23 AM   #1
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1
Posts: 227

Rep: Reputation: 15
Question installing mpd 0.15.8 from SBo


Hello,

I'm trying to install mpd and I get an error when compiling with the SBo .slackbuild file. Here is the error:

/usr/lib/gcc/i486-slackware-linux/4.3.3/../../../../i486-slackware-linux/bin/ld: warning: libx264.so.79, needed by /usr/lib/libavcodec.so, not found (try using -rpath or -rpath-link)
/usr/lib/libavcodec.so: undefined reference to `x264_param_default'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_headers'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_encode'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_close'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_open_79'
collect2: ld returned 1 exit status
make[1]: *** [src/mpd] Error 1
make[1]: Leaving directory `/tmp/SBo/mpd-0.15.8'
make: *** [all] Error 2


x264 snapshots is installed, I tried reinstalling it, still, I get the same error. Any ideas?

Thanks,
Dumdadum
 
Old 04-14-2010, 08:26 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
you have to rebuild ffmpeg after installing x264 snapshot.
 
Old 04-14-2010, 09:21 AM   #3
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1
Posts: 227

Original Poster
Rep: Reputation: 15
Thumbs up

Quote:
Originally Posted by dumdadum View Post
Hello,

I'm trying to install mpd and I get an error when compiling with the SBo .slackbuild file. Here is the error:

/usr/lib/gcc/i486-slackware-linux/4.3.3/../../../../i486-slackware-linux/bin/ld: warning: libx264.so.79, needed by /usr/lib/libavcodec.so, not found (try using -rpath or -rpath-link)
/usr/lib/libavcodec.so: undefined reference to `x264_param_default'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_headers'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_encode'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_close'
/usr/lib/libavcodec.so: undefined reference to `x264_encoder_open_79'
collect2: ld returned 1 exit status
make[1]: *** [src/mpd] Error 1
make[1]: Leaving directory `/tmp/SBo/mpd-0.15.8'
make: *** [all] Error 2


x264 snapshots is installed, I tried reinstalling it, still, I get the same error. Any ideas?

Thanks,
Dumdadum

I installed the ffmpeg of Alien Bob and it compiled. I guess the version I had wasnt compiled with x264 references. Anyhow, problem solved.

Cheers,
Dumdadum
 
Old 04-14-2010, 09:22 AM   #4
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1
Posts: 227

Original Poster
Rep: Reputation: 15
Thumbs up

Quote:
Originally Posted by ponce View Post
you have to rebuild ffmpeg after installing x264 snapshot.
Yeah I installed Alien Bob's version, wich I know is compiled with x264, and it worked.

Thanks,
Dumdadum
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone got OpenShot SBo slackbuild to work? metageek Slackware 13 01-01-2011 05:20 PM
Opera 10.01 in SBo hitest Slackware 2 11-09-2009 02:14 PM
Slackware64, trying to compile wine with SBo suid0 Slackware 6 05-27-2009 09:48 AM
Openoffice with Openclipart sBo pkg ? slackass Slackware 2 01-30-2009 09:24 AM
installing MPD in ipodlinux? microsoft/linux Linux - Laptop and Netbook 6 07-14-2006 02:55 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration