LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-11-2003, 10:20 PM   #1
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Rep: Reputation: 30
Installing IDE CD writer on Slackware 9


Trying to make my CDROM writer work (slave on the secondary IDE
controller) on Slackware 9.

Followed the instructions carefully in:-
Tutorial Section
SCSI Emulation for IDE CD-Writers
Author:Rollin Hand
Slackware Release:Slackware 7.0 and higher
Written on:2002-04-29
Found at linuxtipps.sourceforge.net/show.php/en/tutorial/3.htm

Recompiled the kernel successfully. But it didn't work. Tried...

root@protos:~# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.

Any help would be appreciated.
 
Old 11-12-2003, 03:03 AM   #2
Zeratool Box
LQ Newbie
 
Registered: Mar 2003
Distribution: slackware
Posts: 19

Rep: Reputation: 0
In IDE, ATA and ATAPI Block devices you have
SCSI emulation support set to * or M

IN SCSI support you have
SCSI CD-ROM support set to * or M
and possible
SCSI generic support set to * or M

in /etc/lilo.conf do you have a line
append="hdd=ide-scsi"
?

did you run lilo after compiling kernel and moving it to /boot and editing your /etc/lilo.conf file(i usually tend to forget)?
 
Old 11-12-2003, 04:40 AM   #3
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
So you've loaded the ide-scsi module and have put an "append /dev/<IDE device>=ide-scsi" line in /etc/lilo.conf? Have you also changed your cdrom symlink to point to /dev/sr0 instead?
 
Old 11-12-2003, 05:39 AM   #4
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Before you go all crazy with SCSI emulation, check to see if you need it. Run the following command as root:

cdrecord -scanbus dev=ATAPI

If you see your burner listed in the output, then you don't need SCSI emulation (or a scsi-bloated kernel). Read the cdrecord man page.

I don't have any SCSI support in my kernel, but I burn just fine with the following command:

cdrecord -v speed=16 -overburn driveropts=burnfree dev=ATAPI:0,0 -pad -data <image.iso>

You'll probably have to change the ATAPI:0,0 to match the output of the scanbus command listed above.

Enjoy!
--- Cerbere
 
Old 11-12-2003, 10:34 AM   #5
ludeKing
Member
 
Registered: Jul 2003
Location: NSW. Australia
Distribution: Ubuntu, Fedora, Slackware
Posts: 181

Rep: Reputation: 30
Yeah, don't go crazy with compiling the kernel, check this out, I had the same problem and solved it with one simple line in my /etc/lilo.conf
http://forums.overclockers.com.au/sh...hreadid=222810
 
Old 11-12-2003, 09:03 PM   #6
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Zeratool Box


did you run lilo after compiling kernel and moving it to /boot and editing your /etc/lilo.conf file(i usually tend to forget)? [/B]
Good diagnosis! Edited the lilo.conf file but did not "/sbin/lilo". Now at least the CDROM drive is recognized. Moving forward again to a hopefully imminent solution.

Many thanks. Nice to have someone looking over your shoulder.
 
Old 11-16-2003, 06:25 PM   #7
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by ionmich
Good diagnosis! Edited the lilo.conf file but did not "/sbin/lilo". Now at least the CDROM drive is recognized. Moving forward again to a hopefully imminent solution.

Many thanks. Nice to have someone looking over your shoulder.
Thanks everyone...got everything running and am now burning with xcdroast.
 
Old 11-21-2003, 01:28 AM   #8
murray_linux
Member
 
Registered: Nov 2003
Distribution: Slackware Current
Posts: 210

Rep: Reputation: 30
Quote:
Originally posted by Cerbere
Before you go all crazy with SCSI emulation, check to see if you need it. Run the following command as root:

cdrecord -scanbus dev=ATAPI

If you see your burner listed in the output, then you don't need SCSI emulation (or a scsi-bloated kernel). Read the cdrecord man page.

I don't have any SCSI support in my kernel, but I burn just fine with the following command:

cdrecord -v speed=16 -overburn driveropts=burnfree dev=ATAPI:0,0 -pad -data <image.iso>

You'll probably have to change the ATAPI:0,0 to match the output of the scanbus command listed above.

Enjoy!
--- Cerbere
Really? Cool! Because I don't really want to recompile my kernel either. Its funny, all the howto's I've seen so far say you need to have scsi emulation. Is there a howto out there somewhere for this?

Thanks!

Murray
 
Old 11-21-2003, 04:08 AM   #9
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
I don't know about a How-To, but it's really simple if your cdrw is supported (and if it's not supported, then it's impossible ;-)

As root, run the command:

cdrecord -scanbus dev=ATAPI

You should (hopefully see something like this:
Code:
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'BTC     ' 'BCE2410IM       ' 'A.23' Removable CD-ROM
        0,1,0     1) 'DVD-16X ' 'OEM316B         ' '1.00' Removable CD-ROM
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
In my case, the line which starts 0,0,0 shows my cdrw (the 0,1,0 is my DVD-rom). So to burn, I use the cdrecord command with the option flag 'dev=ATAPI:0,0' (to be more correct, I should use 'dev=ATAPI:0,0,0', but the first zero isn't necessary).

If my cdrw were in the slave position (where my DVD is listed above), I would use the option 'dev=ATAPI:1,0'

You can find more info on this in the cdrecord man page.

Enjoy!
--- Cerbere
 
Old 11-21-2003, 12:05 PM   #10
murray_linux
Member
 
Registered: Nov 2003
Distribution: Slackware Current
Posts: 210

Rep: Reputation: 30
Cool thanks for the explaination. In my case it would be 0,1.

After installing k3b however, I get an error message saying that scsi-emulation is required for cdrdao. Bummer.

Oh well. SCSI emulation wasn't that difficult to set up. Now I can burn!!!

Thanks

Murray
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SATA - IDE Adapter on DVD Writer citro Linux - Hardware 0 10-25-2004 04:03 PM
Installing Slackware 10 with a PCI IDE Controller ubers0ldat Linux - Software 3 09-04-2004 10:25 PM
Installing Slackware-8.00 with IDE CD-ROM MITSUMI FX001D? Werner Slackware 7 07-30-2004 05:03 AM
Why does IDE DVD writer show up as SCSI? NickC Mandriva 2 07-19-2004 11:06 AM
IDE CD writer stratmark Linux - Hardware 2 02-16-2004 04:17 PM


All times are GMT -5. The time now is 11:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration