LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Installing IDE CD writer on Slackware 9 (http://www.linuxquestions.org/questions/slackware-14/installing-ide-cd-writer-on-slackware-9-a-115045/)

ionmich 11-11-2003 09:20 PM

Installing IDE CD writer on Slackware 9
 
Trying to make my CDROM writer work (slave on the secondary IDE
controller) on Slackware 9.

Followed the instructions carefully in:-
Tutorial Section
SCSI Emulation for IDE CD-Writers
Author:Rollin Hand
Slackware Release:Slackware 7.0 and higher
Written on:2002-04-29
Found at linuxtipps.sourceforge.net/show.php/en/tutorial/3.htm

Recompiled the kernel successfully. But it didn't work. Tried...

root@protos:~# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.

Any help would be appreciated.

Zeratool Box 11-12-2003 02:03 AM

In IDE, ATA and ATAPI Block devices you have
SCSI emulation support set to * or M

IN SCSI support you have
SCSI CD-ROM support set to * or M
and possible
SCSI generic support set to * or M

in /etc/lilo.conf do you have a line
append="hdd=ide-scsi"
?

did you run lilo after compiling kernel and moving it to /boot and editing your /etc/lilo.conf file(i usually tend to forget)?

adz 11-12-2003 03:40 AM

So you've loaded the ide-scsi module and have put an "append /dev/<IDE device>=ide-scsi" line in /etc/lilo.conf? Have you also changed your cdrom symlink to point to /dev/sr0 instead?

Cerbere 11-12-2003 04:39 AM

Before you go all crazy with SCSI emulation, check to see if you need it. Run the following command as root:

cdrecord -scanbus dev=ATAPI

If you see your burner listed in the output, then you don't need SCSI emulation (or a scsi-bloated kernel). Read the cdrecord man page.

I don't have any SCSI support in my kernel, but I burn just fine with the following command:

cdrecord -v speed=16 -overburn driveropts=burnfree dev=ATAPI:0,0 -pad -data <image.iso>

You'll probably have to change the ATAPI:0,0 to match the output of the scanbus command listed above.

Enjoy!
--- Cerbere

ludeKing 11-12-2003 09:34 AM

Yeah, don't go crazy with compiling the kernel, check this out, I had the same problem and solved it with one simple line in my /etc/lilo.conf
http://forums.overclockers.com.au/sh...hreadid=222810

ionmich 11-12-2003 08:03 PM

Quote:

Originally posted by Zeratool Box


did you run lilo after compiling kernel and moving it to /boot and editing your /etc/lilo.conf file(i usually tend to forget)? [/B]
Good diagnosis! Edited the lilo.conf file but did not "/sbin/lilo". Now at least the CDROM drive is recognized. Moving forward again to a hopefully imminent solution.

Many thanks. Nice to have someone looking over your shoulder.

ionmich 11-16-2003 05:25 PM

Quote:

Originally posted by ionmich
Good diagnosis! Edited the lilo.conf file but did not "/sbin/lilo". Now at least the CDROM drive is recognized. Moving forward again to a hopefully imminent solution.

Many thanks. Nice to have someone looking over your shoulder.

Thanks everyone...got everything running and am now burning with xcdroast.

murray_linux 11-21-2003 12:28 AM

Quote:

Originally posted by Cerbere
Before you go all crazy with SCSI emulation, check to see if you need it. Run the following command as root:

cdrecord -scanbus dev=ATAPI

If you see your burner listed in the output, then you don't need SCSI emulation (or a scsi-bloated kernel). Read the cdrecord man page.

I don't have any SCSI support in my kernel, but I burn just fine with the following command:

cdrecord -v speed=16 -overburn driveropts=burnfree dev=ATAPI:0,0 -pad -data <image.iso>

You'll probably have to change the ATAPI:0,0 to match the output of the scanbus command listed above.

Enjoy!
--- Cerbere

Really? Cool! Because I don't really want to recompile my kernel either. Its funny, all the howto's I've seen so far say you need to have scsi emulation. Is there a howto out there somewhere for this?

Thanks!

Murray

Cerbere 11-21-2003 03:08 AM

I don't know about a How-To, but it's really simple if your cdrw is supported (and if it's not supported, then it's impossible ;-)

As root, run the command:

cdrecord -scanbus dev=ATAPI

You should (hopefully see something like this:
Code:

Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0    0) 'BTC    ' 'BCE2410IM      ' 'A.23' Removable CD-ROM
        0,1,0    1) 'DVD-16X ' 'OEM316B        ' '1.00' Removable CD-ROM
        0,2,0    2) *
        0,3,0    3) *
        0,4,0    4) *
        0,5,0    5) *
        0,6,0    6) *
        0,7,0    7) *

In my case, the line which starts 0,0,0 shows my cdrw (the 0,1,0 is my DVD-rom). So to burn, I use the cdrecord command with the option flag 'dev=ATAPI:0,0' (to be more correct, I should use 'dev=ATAPI:0,0,0', but the first zero isn't necessary).

If my cdrw were in the slave position (where my DVD is listed above), I would use the option 'dev=ATAPI:1,0'

You can find more info on this in the cdrecord man page.

Enjoy!
--- Cerbere

murray_linux 11-21-2003 11:05 AM

Cool thanks for the explaination. In my case it would be 0,1.

After installing k3b however, I get an error message saying that scsi-emulation is required for cdrdao. Bummer.

Oh well. SCSI emulation wasn't that difficult to set up. Now I can burn!!!

Thanks

Murray


All times are GMT -5. The time now is 05:13 AM.