LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-02-2013, 04:45 AM   #1
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Rep: Reputation: 2
Exclamation Installing grub-2.00 slackbuild, fails when it can't find man directory


I think it's failing when it tries to find /tmp/SBo/package-grub2/usr/man and prints this error:
Code:
find: `/tmp/SBo/package-grub2/usr/man': No such file or directory
I'm guessing this is just the man page information, but it's not located there. I looked at /tmp/SBo/grub-2.00/docs and there's a man directory there, so I copied it to /tmp/SBo/package-grub2/usr. Is there something I need to change in the build script (which I don't know where to find, btw) to make it work, or is there something else that's not working with the package that I'm not aware of?

I never installed lilo, but opted to instead install grub2 after installing everything and just use a bootdisk to boot my system, so I don't think there's anything to do with lilo getting in the way.

I'd appreciate any input guys & gals!
 
Old 09-02-2013, 04:55 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,534

Rep: Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190Reputation: 1190
I guess you forgot to install first help2man, that is a required dependency of grub2 as stated on this page.

Also, how come you can't find where is the build script as you had to run it to build the package
 
Old 09-02-2013, 06:48 AM   #3
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 297

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Didier Spaier View Post
I guess you forgot to install first help2man, that is a required dependency of grub2 as stated on this page.

Also, how come you can't find where is the build script as you had to run it to build the package
I'm using sbopkg to download, build, and install slackbuilds. It saves a lot of time. I guess I forgot to look at the "REQUIRES" line in the readme... Thanks for pointing out that extremely obvious fault xD

Installed help2man, rebuilt and installed grub2, perfect completion!

I've been getting next to no sleep so I guess my brain is a little slower right now. Thanks!
 
  


Reply

Tags
boot loader, bootloader, grub2, slackbuild, slackware 14


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] WebkitGtk Slackbuild fails pcelka Slackware 2 11-03-2012 05:50 AM
[SOLVED] ffmpeg slackbuild fails in 13.37 arubin Slackware 3 04-29-2011 11:02 AM
[SOLVED] find: `/boot/grub/menu.lst': No such file or directory TheIndependentAquarius Linux Mint 27 10-23-2010 10:01 PM
Grub fails after installing new MoBo pbogaart Linux - Newbie 29 02-03-2006 05:49 PM
Grub Fails after installing new IDE disk silversurfer Linux - Newbie 3 03-11-2004 11:18 AM


All times are GMT -5. The time now is 09:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration