LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-30-2008, 07:35 AM   #1
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Rep: Reputation: 15
Installing Cyrus-imapd on Slackware


Does anyone have info in regards to installing Cyrus-IMAPd on Slackware?

I've been through all the HOWTOs, and all the FAQs I can find, and I'm having a hard time getting everything to play right on my Slack 12.2 system.

I get to the point where I am able to imtest accounts and get that to successfully pass, however I am still unable to connect to the service over port 143, and it reports that it is listening on that port.

Anyone have any advise about getting Cyrus-IMAPd to run on Slackware?

Thanks in advance.
 
Old 12-30-2008, 09:43 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,194

Rep: Reputation: Disabled
I have Cyrus IMAPD running on my Slackware home server for some 5 years now, and I simply love it. With the sieve daemon you get server-side email filtering for free.

I never wrote a proper SlackBuild or installation instructions for it though. Setting sendmail up to deliver emails to cyrus is not trivial either. Does the server receive emails yet?

If your server does not listen on port 143 then have you checked what is running on that port? As root run
Code:
netstat -panel | grep :143
I have the cyrus "master" process listening there.
Also, did you build the server with shadow support? If not, it will not be able to authenticate your account against Slackware's shadow database.
If you have them can you post your build commands (the configure command especially) and the content of /etc/cyrus.conf and /etc/imapd.conf ?

Eric
 
Old 12-30-2008, 09:54 AM   #3
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
I have Cyrus IMAPD running on my Slackware home server for some 5 years now, and I simply love it. With the sieve daemon you get server-side email filtering for free.

I never wrote a proper SlackBuild or installation instructions for it though. Setting sendmail up to deliver emails to cyrus is not trivial either. Does the server receive emails yet?

If your server does not listen on port 143 then have you checked what is running on that port? As root run
Code:
netstat -panel | grep :143
I have the cyrus "master" process listening there.
Also, did you build the server with shadow support? If not, it will not be able to authenticate your account against Slackware's shadow database.
If you have them can you post your build commands (the configure command especially) and the content of /etc/cyrus.conf and /etc/imapd.conf ?

Eric
Sure, I'll post my build info when I get home later today, as well as the /etc/cyrus.conf and /etc/imapd.conf files.

Yes, the master process (cyrus master, and postfix master for that matter) was running. Running the netstat it showed that the cyrus master was listening on 143.

Postfix is delivering mail, after a quick reconfiguration of the master.cf.

I was able to initially telnet to the imap port, and it showed the proper connection string that you'd expect IMAPd to show. However, that only seemed to work once, after restarting the process. I would have to restart the process again, to be able to get that to show up again.

I guess I need to do even more troubleshooting on my end, I will try throwing the login commands and such, via telnet and see if it gives me an error. I simply tried to connect to it using a imap client, like thunderbird, and was getting errors trying to connect.

I will post relavent info when I get home and back on the system, and I'll try more troubleshooting by throwing in some imap commands via telnet and find out any error messages I'm getting.

Also, the other thing I was curious about if I was using the proper pwcheck_method as shadow, or should it be saslauthd? From what you said, it looks like it should be shadow.

Thanks for the info.
 
Old 12-30-2008, 11:38 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,194

Rep: Reputation: Disabled
Quote:
Originally Posted by MikeDawg View Post
Also, the other thing I was curious about if I was using the proper pwcheck_method as shadow, or should it be saslauthd? From what you said, it looks like it should be shadow.

Thanks for the info.
You are right. Slackware's saslauthd process uses shadow authentication. This is what my Cyrus IMAP server uses too; my /etc/imapd.conf file has these lines:
Code:
sasl_pwcheck_method: saslauthd
sasl_mech_list: shadow PLAIN
If the imtest program shows that your account can login, perhaps you have not yet created the account's mailbox?

Eric
 
Old 12-30-2008, 08:36 PM   #5
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
You are right. Slackware's saslauthd process uses shadow authentication. This is what my Cyrus IMAP server uses too; my /etc/imapd.conf file has these lines:
Code:
sasl_pwcheck_method: saslauthd
sasl_mech_list: shadow PLAIN
If the imtest program shows that your account can login, perhaps you have not yet created the account's mailbox?

Eric
Ok, here is everythiing relavent that I have configured as of right now. . . Please note that they may have looked like what your suggesting at one time, but I probably changed it trying to get it to work.

/etc/imapd.conf:
configdirectory: /var/imap
partition-default: /var/spool/imap
admins: cyrus root
srvtab: /var/imap/srvtab
allowanonymouslogin: no
sasl_passwd_check: shadow
allowplaintext: yes
sasl_mech_list: PLAIN LOGIN

/etc/cyrus.conf is pretty much just the normal.conf with the package, I just commented out the pop3 and pop3s

/usr/lib/sasl2/smtpd.conf:
# Global Parameters
log_level: 3
pwcheck_method:saslauthd mech_list:login plain
mech_list: PLAIN LOGIN


a netstat -tnlp provides:
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 11858/master
 
Old 12-30-2008, 08:47 PM   #6
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by MikeDawg View Post
Ok, here is everythiing relavent that I have configured as of right now. . . Please note that they may have looked like what your suggesting at one time, but I probably changed it trying to get it to work.

/etc/imapd.conf:
configdirectory: /var/imap
partition-default: /var/spool/imap
admins: cyrus root
srvtab: /var/imap/srvtab
allowanonymouslogin: no
sasl_passwd_check: shadow
allowplaintext: yes
sasl_mech_list: PLAIN LOGIN

/etc/cyrus.conf is pretty much just the normal.conf with the package, I just commented out the pop3 and pop3s

/usr/lib/sasl2/smtpd.conf:
# Global Parameters
log_level: 3
pwcheck_method:saslauthd mech_list:login plain
mech_list: PLAIN LOGIN


a netstat -tnlp provides:
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 11858/master
Ok, I changed /etc/imapd.conf to look like:
configdirectory: /var/imap
partition-default: /var/spool/imap
admins: cyrus root
srvtab: /var/imap/srvtab
allowanonymouslogin: no
sasl_passwd_check: saslauthd
allowplaintext: yes
sasl_mech_list: PLAIN LOGIN SHADOW


When I telnet in to port 143, i type: login user1 <password>
and I get "login BAD Please login first". user1 exists in /etc/passwd (and /etc/shadow for that matter )

I also forgot to mention that I created (cm user.user1)

Any suggestions?

Last edited by MikeDawg; 12-30-2008 at 09:30 PM. Reason: modified login statement -- Added info about mailbox being created.
 
Old 12-31-2008, 05:16 AM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,194

Rep: Reputation: Disabled
Quote:
Originally Posted by MikeDawg View Post
Any suggestions?
You did notice that you have
Code:
sasl_passwd_check: shadow
whereas I use saslauthd and let sasl handle the shadow authentication?
That may be worthwhile changing.

Eric
 
Old 12-31-2008, 06:48 AM   #8
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
You did notice that you have
Code:
sasl_passwd_check: shadow
whereas I use saslauthd and let sasl handle the shadow authentication?
That may be worthwhile changing.

Eric
Yeah, in my latest setup, this is what I have in /etc/imapd.conf:

configdirectory: /var/imap
partition-default: /var/spool/imap
admins: cyrus root
srvtab: /var/imap/srvtab
sasl_pwcheck_method: saslauthd
allowanonymouslogin: no
sasl_passwd_check: saslauthd
allowplaintext: yes
sasl_mech_list: PLAIN LOGIN SHADOW


Do you mind showing me your whole /etc/imapd.conf file?
 
Old 12-31-2008, 08:16 AM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,194

Rep: Reputation: Disabled
Quote:
Originally Posted by MikeDawg View Post
Do you mind showing me your whole /etc/imapd.conf file?
For cyrus-imapd-2.2.8 that is:

Code:
configdirectory: /var/lib/imap
partition-default: /var/spool/imap
admins: cyrus
quotawarn: 90
defaultacl: anyone lrswicd cyrus lrswipcda
allowplaintext: yes
allowanonymouslogin: no
sievedir: /var/lib/imap/sieve
sendmail: /usr/sbin/sendmail
hashimapspool: true
fulldirhash: false
sasl_pwcheck_method: saslauthd
sasl_mech_list: shadow PLAIN
tls_cert_file: /etc/ssl/certs/cyrus-imapd.pem
tls_key_file: /etc/ssl/certs/cyrus-imapd.pem
tls_ca_file: /etc/ssl/certs/ca-bundle.crt
postuser: bb
lmtp_downcase_rcpt: 1
Eric
 
Old 02-16-2009, 12:04 AM   #10
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Original Poster
Rep: Reputation: 15
Man, I have been working on this off an on now, for the past 3 months, and I still can't seem to get it working right.

I would like to graciously implore you to get a slackbuild built for this, and if you can thrown up to the folks at slackbuild.org . . .

I don't know why I can't overcome this stupid obstacle.

Any help would be appreciated.

Last edited by MikeDawg; 02-16-2009 at 12:12 AM.
 
Old 02-16-2009, 03:13 AM   #11
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Originally Posted by MikeDawg View Post
I would like to graciously implore you to get a slackbuild built for this, and if you can thrown up to the folks at slackbuild.org . . .
Hehe

He is the folks at slackbuilds.org
 
Old 02-16-2009, 04:10 PM   #12
MikeDawg
LQ Newbie
 
Registered: Mar 2004
Location: Nevada
Distribution: Slackware, CentOS
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mRgOBLIN View Post
Hehe

He is the folks at slackbuilds.org
He runs slackbuilds.org ??
 
Old 02-16-2009, 05:24 PM   #13
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
http://slackbuilds.org/contact/
 
  


Reply

Tags
cyrus, imapd, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix and Cyrus-imapd manya Linux - General 1 12-22-2007 07:43 AM
Compiling Cyrus-Imapd menonsudhir Linux - Server 1 02-20-2007 02:53 PM
cyrus-imapd error TuLiss Slackware 6 02-16-2006 12:43 PM
cyrus imapd redhatlover Linux - Enterprise 3 01-03-2006 06:00 AM
Cyrus-Imapd Doesn't Work aquiz Linux - Software 0 09-09-2004 06:44 PM


All times are GMT -5. The time now is 12:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration