LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Installing ATI Drivers (http://www.linuxquestions.org/questions/slackware-14/installing-ati-drivers-98747/)

muppski 09-30-2003 04:52 PM

Installing ATI Drivers
 
Before i start : YES i haved searched the forum , I did follow some guides but I hade some problems wich these guides dosent tell me what to do to get around



ATI module generator V 2.0
==========================
probing for VMA API version...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
doing scripted based build for kernel 2.4.x and similar
compiling 'agpgart_be.c'...
compiling 'agp3.c'...
compiling 'i7505-agp.c'...
compiling 'nvidia-agp.c'...
compiling 'firegl_public.c'...
linking of fglrx kernel module...
duplication skipped - generator was not called from regular lib tree
done.
==============================
and after I run the "make_install" command and the output is:

*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.

________

I did install this Linux header thing becuse before even make.sh failed .. Now im really tierd and wanna go to bed but just now right yet...... aw crap =/

And ooooh btw When i boot linux i see the linux logo on the left top corner , Is it possible to change that one? To other penguines or simply other stuff?

muppski 10-01-2003 05:41 AM

Ehh maybe i posted this is the wrong place?
Admin move this?

muppski 10-01-2003 02:49 PM

I guess not......

What should I do?

LSD 10-01-2003 08:57 PM

I know it's possible to change the boot logo as Gentoo changes it to an icon of their "mascot" Larry the Cow but this requires a kernel patch, I don't know if there's an easier way to do it than that.

Also, did you install the full kernel source or just the headers? Make sure the full kernel source is installed and the /usr/src/linux and /lib/modules/<kernelversion>/build exist and point back to the right locations (which should both be you /usr/src/linux-* source directory).

muppski 10-02-2003 02:19 AM

I do have

/usr/src/linux-2.4.20


I dont have

/lib/modules/linux-2.4.20/build
or did you just mean
/lib/modules/linux2-.4.20 ? cuz i do got that :D

and no /usr/src/linux
just linux-2.4.20/


This means i have to download (tell me) from (tell me)
And install it?

LSD 10-02-2003 02:49 AM

If you haven't got a linux symlink in your /usr/src directory you're going to have to create it by hand (as root):

Code:

cd /usr/src
ln -s linux-2.4.20 linux

It's the same with the build symlink in /lib/modules/2.4.20:

Code:

cd /lib/modules/2.4.20
ln -s /usr/src/linux-2.4.20 build

That should allow the make.sh script to find all the header files it needs to compile the fglrx module.

muppski 10-02-2003 04:54 AM

root@ueemap03:~/drivers/lib/modules/fglrx/build_mod# ./make.sh
ATI module generator V 2.0
==========================
probing for VMA API version...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
doing script based build for kernel 2.4.x and similar
compiling 'agpgart_be.c'...
compiling 'agp3.c'...
compiling 'i7505-agp.c'...
compiling 'nvidia-agp.c'...
compiling 'firegl_public.c'...
linking of fglrx kernel module...
duplication skipped - generator was not called from regular lib tree
done.

ALMOST same msg
execpt doing scripted based build for kernel 2.4.x and similar
dosent show up anymore ...
:newbie:

muppski 10-03-2003 09:00 AM

ehh

There must be somekinda solution?

muppski 10-04-2003 04:19 PM

omg plz!

Shade 02-09-2004 11:27 PM

Please post the full path of your commands that give you this error, as well as the method you used to install the fglrx drivers.

This is the line I'm suspicious of:

Code:

compiling 'firegl_public.c'...
 linking of fglrx kernel module...
 duplication skipped - generator was not called from regular lib tree

Are you doing this within /lib/modules/fglrx ?

--Shade


All times are GMT -5. The time now is 11:21 PM.